No fastboot, no bootloader after successfull install of FairphoneOS 1.13 (Android 5.1)

Hi there!
I hope I did enough research in this forum, but I didn’t quite find my problem jet.
I have a FP 2 and had Lineage together with TWRP installed.
Sadly for my work I need Google services so I wanted to switch to FairphoneOS.
I backuped with TWRP and tried to install zip of the latest FOS, but TWRP had a problem with the checksum and gave me the error, invalid zip format.
I tried several things, but after a while I got impatient and decided to overwrite TWRP and install FOS with fastboot.
That worked, but sadly when turning on the User Interface immediately crashed and I saw only a error window.
I tried to reflash FOS with the same outcome.
Then I thought that it might make sense to install an older FOS and upgrade with the upgrade app.
I successfully flashed the FOS 1.13 with Android 5.1. but since then the phone does not turn on anymore.
In no case I can see anything on the screen.

If I use the Power+Up or Power+Down combinations nothing happens.
If I remove the battery, put it back in and press the power button, the phone vibrates, but nothing else happens.
If I plug in the phone to the computer and press the power button the red led lights up for a sec and the phone vibrates, but nothing else happens.

But there is strange things happening with the red led and plugging it in the computer. With strange I mean, it is not really reproducable, but some outcomes are:
The red led blinks, sometimes it stays on and sometimes it is white (happened once, maybe has to do with the loading level?). But in any case “adb shell”, “adb devices” and “fastboot devices” finds nothing. But I can hear the ‘new device plugged in’ sound in Windows and Linux when plugging the phone to the computer. Under Windows it shows an ‘Android’ instead of the known ‘FP’.

I hope there is something I still can do to save the phone and you guys can help me!

Thank you in advance and regards,


Fairphone had to switch their display module supplier somewhen. OS and firmware versions this old don’t support the newer display modules.
I’ll assume you have one of those.

Did you backup your Internal Storage files, too?
Because a TWRP backup will not include the Internal Storage.

If my assumption about the display module is correct, it could seem as if nothing happens, but Fastboot Mode should still work.

Please check whether rebooting or starting the phone while keeping Vol - pressed gives you Fastboot Mode … you would have to check with fastboot devices on the computer.
ADB doesn’t work in Fastboot Mode, and the fastboot command only works in Fastboot Mode.

If fastboot works, you could install the phone from scratch …


Elk you’re my official hero of this month!
Apparently fastboot worked with Power+VolDown and I could install Fairphone OS.
Now also the screen works again.

It took me then still two days to figure out the problem with TWRP. At the end I think not using TWRP at all and installing it over fastboot did the trick (should have just followed the guide for once).

A big thanks to AnotherElk and the whole community,


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.