No data after updating to Android 11 for FP3

Same problem here. Seems to have been resolved by resetting the APNs to default and then doing a full power cycle (not just reboot, power off and power up again).

1 Like

I’ve got the same problem, and the APN reseting to default has instantly solved the problem :slight_smile:

Thanks for the support !

1 Like

Welcome to the forum.

Nice to see you have found the solution

All the best

Just to confirm that forcing 2g, reset, un-forcing 2g worked for me (Orange, Spain)

1 Like

It seems I was happy too quickly :sweat_smile:
I now got back 4G working pretty well… except for some apps.
Indeed, I have at least 3 apps that are now working perfectly when I’m connected to wi-fi, but are telling me “impossible to connect” when I’m using only 4G. Those apps were working very well in 4G before the android 11 update, but are not working any more now.

I’ve checked that the mobile data were authorized for those apps
I tried to reboot the apps and my phone many times
I tried to modify my APN settings using standard ones from my internet provider.
I tried to use a manual DNS
I tried to uninstall and reinstall one of those apps

Nothing has changed : the apps are still unable to connect to 4G.
I’m desperate.
Any idea about what can I do to solve this connection issue please ?

There are some reports for some apps that a new ipv6 APN was causing issues. Maybe check this and see if your provider has an old ipv4 APN

Or as you mentioned DNS


Forcing 2g, restart and setting back to automic solved it for me as well :slight_smile:

Yes, as Yvonne says this sounds like a IPv4 / v6 issue.

What value do you have for the APN setting “APN protocol” ? If it’s set to IPv6, try setting to IPv4/IPv6.

Thanks for your answers !

Forcing 2G, restarting and setting back to autmatic didn’t solve the problem.

My APN protocol setting is on “IPv4/IPv6”. Switching to “IPv4” or to “IPv6” doesn’t change the problem.

I noticed something weird : when the concerned applications are launched under Wi-fi, they work perfectly, and losing the Wi-fi doesn’t cut the internet for those apps. But restarting the apps without Wi-fi does prevent them from connecting to the Internet.

1 Like

That sounds like there’s a DNS problem for these apps when using mobile data. With the Wi-Fi on, they are able to resolve and probably cache IP addresses so that they still work when you switch to Data. Maybe one of the Community’s network specialists can advise.

If not, you might try resetting all network configurations: Settings > System > Advanced > Reset options > Reset Wi-Fi, mobile and Bluetooth
Please be aware that this might (temporarily) cause other problems, and will in any case result in the erasure of ALL Wi-Fi network passwords, APNs and Bluetooth pairings, and all related settings.

1 Like

I tried all, my internet works only when I use IPv6 but internet is slow and I can’t play some games
When I use IPv4 (as I had before update), nothing works, I even don’t see “4g” wrote on the top, next to " connecting triangle"

I hope you understood my english,
Thank you.

Hi and welcome to the forum and yes your English is fine.

Sadly at the moment I can’t help as I only use Wi-Fi as I have no network.

Hello, I installed a fresh Android 9 stock rom, updated to Android 11 via OTA, configured my applications via Wifi, and then I realized that mobile data didn’t work at all.

I tried dozens of methods - clearing cache, resetting APNs or networks, manually configuring APNs, tweaking all kinds of settings, rebooting lots of times… nothing worked.

In the end, only a FACTORY RESET (at this Android 11 version) restored 3G/LTE capabilities.

And since the bug was included in my /data partition backup of TWRP, and that titanium backup restores completely failed (split APKs probably), I had to beging again and reconfigure my 50 favorite applications.

This is really upsetting, both the fact that backup/restore capabilities of Android are so fragile, and that a simple OTA upgrade of a fresh STOCK ROM bricks the mobile data system for good.

I’m tooling more with Swift Backup and stuffs, but still, I fear the next update of the Fairphone, I can’t lose days reconfiguring everything each time a (barely tested ?) OTA arrives.

Android 11 Fairphone OS is available for fresh installs …

OTA “Updating” Android 9 to 11 is nothing like those regular OTA updates staying within the same major Android version, instead going from one major Android version to the next are complicated in-place OS upgrades where things always can go wrong, fingers crossed they don’t, but it happens.

To compare with a Windows PC, you didn’t just install the usual updates, you went from Windows 7 to 8 to 10 in-place. Not as trivial.

1 Like

Long story short, I was in vacation without wifi, my previous phone was randomly dying (power button not working most of the time), I first attempted to get lineageOS until I changed my mind (due to issues with my banking apps, safetynet etc.), and in the end I only had that old stock rom available for flashing on my laptop. I thought OTA would work fine.

I’m OK with losing some settings while upgrading an OS, but having it half-bricked, and without fine-grained app backup/restore solution (especially for unrooted phone - I only installed root and titaniumbackup later), is a bit much annoying. I’m pretty convinced that an unrooted phone could be upgraded somehow safely, with proper testing of these OTAs.

1 Like

You can bet that they test pretty excessively, else after rolling out a bad OTA upgrade support would get overwhelmed (even more) and there would be a lot of very unhappy users and bad press. After a very heavy investment of development resources into this. Nobody wants that.

It’s good that you have this hope and expectation, but it’s software. It has gotten too complex. Anything can happen, unfortunately.
Which I realise also means that even if circumstances wouldn’t have forced you to complicate the installation, you might have found yourself with an issue. I’ve got no solution, never mind.

1 Like

UPDATE - the mobile connection kept constantly switching between 4G and 4G+, so I thought “maybe it’s the SIM card which is too old”, per the Fairphone troubleshooting guide.

So I ordered a new sim card from SFR RED, activated it, and now NO MOBILE NETWORK CONNECTIVITY anymore (but calls work). This new sim card works perfectly on my antic OnePlus 3T (with 4G+ network connection), but my Fairphone 3+, which has just been FACTORY RESET in Android 11 (so no fancy setting corruptions or OTA upgrades), has just bricked its mobile network stack once more.

How is it even possible ? It’s a simple sim card change on a freshly installed, Stock, Android 11.

I don’t have the time to factory-reset AGAIN and respend 1 day connecting/configuring my 60 apps one by one.
This is horrible user experience. I’ve been in software development for 14 years, I know how hard it can be, I’ve had lots of smartphones, but this is just a nightmare. It’s not this way that we’ll push people to buy ethical stuffs.

My FP3 mobile connection speed decreased to GRPS/EDGE since 2 weeks. If I remember right it was shortly after an system update - guess it was to Android 11.
The strange fix for this is: I switch to flight mode for a few seconds. After disabling flight mode my mobile data speed goes up to and stays at 4G as I was used to. After turning off the phone completly - which I rarely do - I have to repeat this procedure.

My FP3 is also unable to connect to mobile data:


This started 2 or 3 weeks ago, but I’m not sure exactly when, because if I’m on WiFi everything works, so I only noticed the problem when away from any WiFi network. It might have started with the most recent system update.

I’ve reset WiFi/mobile/bluetooth settings. I’ve switched to 2g and restated the phone and back to automatically choosing network. I’ve reset APNs to default (I can’t delete or edit the “internet” APN, I assume it’s fixed by my network). I’ve got a new SIM from my network operator, and then tried all the reset actions again. Nothing works. The only thing I haven’t tried is a complete factory reset (and I’m not doing that because I don’t want to lose everything saved on this phone).

Like one of the people above, I’m in Cambridge and on EE, but I have no mobile data signal anywhere, it doesn’t help if I travel to a different part of the country.

I called my network operator, but they don’t know how to help because they don’t know what a Fairphone is :roll_eyes:

At this point my phone is basically **cked.

Edit: I can’t even receive SMS messages unless I turn off mobile data. It seems that having mobile data turned on (but showing the ‘x’ on the signal meter) blocks those.

There is a fix in the process of being certified by Google, as all OS updates have to be. Sadly there is no ETA on this and as such you should take my words as random rants and just hearsay.

1 Like