No data after updating to Android 11 for FP3

Hi and welcome to the forum.

The link you provide seems to be duff

request number is 516509.
Ich habe keinen Link gepostet sondern eine Fehlermeldung!

1 Like

After updating my Fairphone 3+ to Android 11 I cannot establish an a mobile internet connection when my VPN (Nord) is enabled, WIFI no problem…

Hi and welcome to the forum

Have you tried some of the above actions?

Yes I tried it all, including a factory reset…: I have a mobile internet connection when my VPN is disabled…

1 Like

This worked for me: set 2G, restart, set Automatic and restart one more time


I assume that this is without using a VPN and that’s my problem: I also tried this with the VPN enabled and it didn’t help. I guess that for the time being I can’t use the VPN on my mobile internet connection on the FP3+…

I solved my problem by installing lineage os, the VPN is connecting now…

Thanks! That worked for me. Bizar, every update data problems.
So set to 2G, then reboot.

1 Like

Interesting, I had the same problem at home. I cycled to another area of Cambridge yesterday and it worked there. Also worked at home when I got back. Can’t be 100% sure it was the update after which it wouldn’t connect to the EE network as there are times when it is dodgy in the area anyway.

1 Like

Same problem here. Seems to have been resolved by resetting the APNs to default and then doing a full power cycle (not just reboot, power off and power up again).

1 Like

I’ve got the same problem, and the APN reseting to default has instantly solved the problem :slight_smile:

Thanks for the support !

1 Like

Welcome to the forum.

Nice to see you have found the solution

All the best

Just to confirm that forcing 2g, reset, un-forcing 2g worked for me (Orange, Spain)

1 Like

It seems I was happy too quickly :sweat_smile:
I now got back 4G working pretty well… except for some apps.
Indeed, I have at least 3 apps that are now working perfectly when I’m connected to wi-fi, but are telling me “impossible to connect” when I’m using only 4G. Those apps were working very well in 4G before the android 11 update, but are not working any more now.

I’ve checked that the mobile data were authorized for those apps
I tried to reboot the apps and my phone many times
I tried to modify my APN settings using standard ones from my internet provider.
I tried to use a manual DNS
I tried to uninstall and reinstall one of those apps

Nothing has changed : the apps are still unable to connect to 4G.
I’m desperate.
Any idea about what can I do to solve this connection issue please ?

There are some reports for some apps that a new ipv6 APN was causing issues. Maybe check this and see if your provider has an old ipv4 APN

Or as you mentioned DNS


Forcing 2g, restart and setting back to automic solved it for me as well :slight_smile:

Yes, as Yvonne says this sounds like a IPv4 / v6 issue.

What value do you have for the APN setting “APN protocol” ? If it’s set to IPv6, try setting to IPv4/IPv6.

Thanks for your answers !

Forcing 2G, restarting and setting back to autmatic didn’t solve the problem.

My APN protocol setting is on “IPv4/IPv6”. Switching to “IPv4” or to “IPv6” doesn’t change the problem.

I noticed something weird : when the concerned applications are launched under Wi-fi, they work perfectly, and losing the Wi-fi doesn’t cut the internet for those apps. But restarting the apps without Wi-fi does prevent them from connecting to the Internet.

1 Like

That sounds like there’s a DNS problem for these apps when using mobile data. With the Wi-Fi on, they are able to resolve and probably cache IP addresses so that they still work when you switch to Data. Maybe one of the Community’s network specialists can advise.

If not, you might try resetting all network configurations: Settings > System > Advanced > Reset options > Reset Wi-Fi, mobile and Bluetooth
Please be aware that this might (temporarily) cause other problems, and will in any case result in the erasure of ALL Wi-Fi network passwords, APNs and Bluetooth pairings, and all related settings.

1 Like