No caller-id (nor pick-up icon) when called in standby mode

When my FP2 is in standby mode and I am being called, the phone rings, but I do not see a caller-id, nor can I pick up the phone. In fact, my screen stays black . I need to unlock my phone in order to pick up the phone.

Probably, I inadvertedly changed some settings, but I cannot find how to go back to the ‘normal’ settings: when I am being called, the caller id is shown and I can pick up the phone without unlocking.

Help appreciated.

1 Like

Which software are you running on your phone and what settings did you change?

OS 22.04.0-rel.1
If I knew what settings I changed (if at all), I’d probably know how to restore them. Problem is, I do not know if I changed something and if so, what.

Did you check all permissions of the phone app?

Probably it’d be solved anyway by doing the factory reset having considered here: No 4G after wifi - #19 by ArjenU

Thanks @Volker When I check the permissions of the phone app, it has access to Contacts, SMS and Telephone. The others (conversation lists, camera, location and storage) are refused.
Are these the permissions you’re referring to?

I’m very hesitant of doing a factory reset, because of all the fuss of reinstalling many apps, configuring them, etc etc

Please check all permission to display notifications for each APP and in General that its allowed to display notifications on the lock screen. And third thing you can check that the phone App is allowed to “display over other Apps”. This can be found on FPOS A10 under settings-apps+notifications-special app access

2 Likes

Thanks @yvmuell
My phone settings already had permission to display over other apps (first picture below).
The second picture shows the notification screen of the phone. Here, I cannot change any of the settings.
What I did change, is the setting in Apps and Notifications // Notifications // Notifications on locked screen (I have it in Dutch, hope the English terms are correct…) - see the third picture, below. Initially, I had the 3rd option checked (do not show notifications). I changed it into the 2nd (only show notifications with a signal). This changed the behaviour when I am being called when my screen is locked a little bit. Now I get the notification that I am being called (which I know already since the phone is ringing alright), but not who is calling. Also, I still need to unlock to pick up the phone (by swiping down the top menu and tapping the ringing phone icon…)

So - not much improvement. I hope you have more suggestions that I might try? Or will this also boil down to “try a factory reset”, which I seem to have to do in regard to my battery management as well…

What if you enable the last Option in your second Screenshot and/or choose first Option in the third Screenshot?

2 Likes

Yep, that solved it. Thanks!

(Still no clue as to why these settings had changed, though - these are definitely no configurations that I fiddle around with…)

1 Like

I stopped wondering about everything reg. Systems/Software etc. everything is possible or nothing is impossible😉

1 Like