No button to connect to wifi

Hey there,
so, I cannot connect to wifi… the phone does find networks, but when I type in the password, the “connect” button is not activated, so I cannot even start the process of connecting. It is a network I have never used with this phone but used successfully with other devices, and it is also in a different country if that could be of any matter.

Any thoughts on that?

Thanks a lot!!!

Maybe you missed a letter or number of the password and the connect button stays greyed out because the password is to short. That’s the only thing I can think of.


Does the router have a WPS button? If yes then you can connect without typing the password. Go to Settings > WiFi and press the button in the lower left corner (the one with the two arrows).

You were right!!! Thank you so much.
I just didn’t know this procedure. The devices I’ve used so far would let me try to connect, and only then tell me that the password was wrong :slight_smile: