No 4G after wifi

1 Like

Hi. Did it keep working for you in the same way afterwards? For me updating carrier services helped for a couple of hours and then it came back to the same problem… Any other advice?

In a case like yours @AndresRB90 a full network reset might be worth the “cost”.

This is less drastic than a factory reset, it will just delete all network - related settings (Wi-Fi saved passwords, APNs for mobile data and MMS, Bluetooth pairings).

To do this, go to Settings > System > Advanced > Reset options > Reset Wi-Fi, mobile & Bluetooth

Before doing this you might want to make a note of your APN settings just in case (they should be reconfigured automatically).

1 Like

New SIM card didn’t help.
Updating Carrier Services seemed to help, but did not last.
Resetting network settings, like @OldRoutard suggested, did not help.

Still: when I am disconnected from a wifi-connection, my phone does not connect to 4G.

Other suggestions still appreciated :-/

does this sound familiar?

Compared to most people, I personally have a rather quixotic behaviour regarding Wi-Fi and mobile data: I turn both off when I don’t need an Internet connection and when I do require Internet I turn on the one or the other. It’s rare that I need to switch directly between Wi-Fi and data but if I do, then I turn off the one, before turning on the other. Slightly fastidious I suppose, but you might try it, quicker than having to completely reboot.

@yvmuell Sounds related, but is a different problem from what I am experiencing: after disconnecting from wifi, 4G is not found anymore (until I reboot)

@OldRoutard I don’t mind such quixotic behaviour, if it would help me. However, if I switch off wifi AND data, and then switch on only data, 4G is still not found.

Still the reboot part seems to be the same, so did you check the bug tracker, if there are any further information or workarounds noted?

I’m inclined to agree with Yvonne, the problem basically seems to be that mobile data works after starting the phone but as soon as the connection is cut (either by turning mobile data off, or by switching to Wi-Fi) it cannot later be re-established without restarting the phone.

@ArjenU your preferred mobile data network type is presumably set to “automatic”. You might try setting it to 2G temporarily, just to see if this clears the “reconnection” problem. If the phone does connect and reconnect successfully in 2G (the connection will be very slow of course) you could then return to “automatic” and see if that works (all without rebooting the phone).
Settings > Network and Internet > Mobile network > Advanced > Preferred network type

I’m wondering whether the withdrawal of 3G across many networks isn’t causing problems for some phones that “expect” to be able to use 3G “before” trying 4G.

I’m pretty sure it has nothing to do with actual availability of whatever radio access technology but it might be a software issue. For instance in Lineage OS for FP2 there was an issue with exactly these symptoms and it turned out that the NetworkManager on the phone kept crashing. The LOS maintainer of LOS for FP2 was able to source a NetworkManager from a different phone (with the same chipset if I recall correctly) and that solved it.
In such a case users can do whatever they wanted. In some rare circumstances it worked but no workaround was reliable.

@OldRoutard, I will try for a couple of days if 2G does work after switching off wifi. Will post the result here.

@Martin_Anderseck, well, that would be a pity. Maybe, if it is a SW issue, new versions can solve it…

@yvmuell if I look for “4g” or “wifi” in Products / Android 10 on the FP2, I get no results…

its labled mobile internet…

Thanks, @yvmuell for pointing at that issue. The workaround that I read about over there is to reboot. That works (most of the time) for me as well, as I mentioned in my original post.
Than I see people talking about a factory reset, which I very much would like to avoid for obvious reasons.
And someone talking about an “e/OS installation as BIOS” which seemed to work, but what this means is not clear to me.

Seems like I have to accept this misbehavioiur and hope that a next update will solve it…?
I do not find other solutions

Plesse follow up in the bug tracker, there the developer will pick it up and communicate with you and the other as needed and you will have first hand information.

Ah, my apologies - did not understand that you meant that in the first place. Will do.

1 Like

Replace the FPOS you have at the moment with /e/ OS (now known as Murena). It’s what I run on my FP2.

On these mentions …

The Developer options in /e/OS (the name stays for now, by the way) have a “Mobile data always active” switch, the description of this switch is “Always keep mobile data active, even when Wi-Fi is active (for fast network switching)”.

I switched it off because it significantly saves battery this way for me, but perhaps this could help to not cut mobile data when going Wi-Fi?
I don’t know whether it’s implemented in other OSes, though.

2 Likes

thats available on all OSs I used so far and I think its enabled per default. I checked it on the FP2 with FPOS Apr build and had to enable developer options and it was on.

3 Likes

You might use TWRP for a full backup (well, internal memory is not part of normal TWRP backup, but there are workarounds) and try out if factory reset helps in your case. Then you can restore your system as before using TWRP restore. If it helped you can still decide if it’s worth setting up the phone completely new after a factory reset…
Or if it helped you could do the factory reset and use TitaniumBackup to restore all apps and data (temporary root is quite easy on a FP).

1 Like

Yes, 4G is working normally since then.
It’s rather my wifi that is not working as well sometimes, but I think it was the case before.

1 Like