English

NHS Covid app not working

Reading this topic from /e/'s forum (microG - What you need to know, A conversation with its developer : Marvin Wißfeld - #2 by dalas.revo - /e/ Developers Blog - /e/ community) I get the impression that they haven’t implemented their own version of the MicroG corona framework.

So if they took down support, as opposed to not having implemented it in the first place, then they probably ran into some coding issue.

Couldn’t it just be that they don’t have the capacity to finish that issue at the moment? Also, they are looking for volunteers and people to help work on /e/, and this seems to be an issue where they need to work on a new way of communicating clearly to their users what they’re working on. And also transparency with regards to bottlenecks.

It was /e/'s decision to bring that extra work towards them. microG had exposure notification support for a while. /e/ delayed supporting corona apps for several months while they worked to extract the exposure notifications part out of microG into an “extension” app to cater to some paranoid users who insisted exposure notifications are a privacy hazard (even in an open source application where you have to explicitly turn it on).

After that was done, you had to go through a lot of manual steps to use it, instead of just clicking OK in a dialog box. All corona apps just failed with weird errors with no way as a regular user to know this is what you had to do to make them work.

And then, both in release 0.14 and 0.17 (of which they didn’t even put it in the changelog) they broke all exposure notification apps silently. I only found out when I opened the Dutch app and found out it hadn’t been tracking for weeks.

So, summarizing:
1.

This did go through the trouble of splitting microG and microG’s Exposure Notifications code into its own app.

They never took down support, as you can see, you can still install it. They just silently broke it on a minor OS version upgrade without telling anyone

I am normally totally understanding about having limited capacity, especially in Open Source projects. But I have no patience in this specific situation, because they chose to spend months on reimplementing something that already existed, was open source and worked fine. If they wouldn’t have the capacity to undertake something like that, it is their own irresponsibility to having started it in the first place and they are knowingly playing games with their users’ health by choosing to not revert to regular upstream microG where everything just works.

3 Likes

Thanks for the detailed answer, I now understand the issue a bit better. Seems like I’ll have to do some reading and figure out whether to change my os.

1 Like