New software update Kola Nut 1.8.5 is ready

If you played around with the partitioning yourself; yes, it is probably causing the issue your are experiencing. It is an unofficial way and we don’t support it.

You can try however to download the storage upgrader 1.8.5 manually and install it using sideload.

If that doesn’t work, try this:

  1. Download Storage Upgrader
  2. Unzip and copy cp /system/bin/fs_upgrade.bin to /mnt/sdcard/adb push system/bin/fs_upgrade.bin /mnt/sdcard/
  3. As root run cp /mnt/sdcard/fs_upgrade.bin /proc/sd_upgrade
  4. echo “–wipe_data” > /cache/recovery/command
  5. Reboot recovery
  6. Reboot recovery again and adb sideload 1.8.5 partition upgrader (to
    replace the recovery)

These are basically the only options. Maybe one of our devs @keesj can help out further if it doesn’t work.


after everything is installed, the screens were empty, so I put my widgets in again. Not happy, but ok. Then I found out the old 5-part-screen is back again, the dots in the bottom disappeared, and I can only collide only some specific widgets in the same space, but quite a lot refuse to share a space. These changes were not in the specs of the update, and I would have liked them to know.
I was happy with the option to put more widgets toghether on a single screen, and to keep together comparable widgets (GMaps&Navigation for instance). Well, I’get used to this again.

The official changelog only describes changes between 1.6 and 1.8.5 because 1.8 was withdrawn and is no longer an “official os version”. But it was mentioned numerous times that v2 launcher will not be in the new OS versions anymore.
Here is the discussion on how to get it back.



after the not working automatic update, the manual one bricked my partition and is not available anymore from recovery (not even via ADB).

Do you know an UPDATED or OFFICIAL guide to force a ROM flash?


hi Paul, no I’m not sure what I did, but following the manual. After installing 1.8.5. the Install button was on my screen, and I probably tapped it. I agree it’s unlikely GPlay downloads itself unwanted.
I think I followed the manual and opened FpUpdater again to install GPlay as indicated, and saw it already downloading in the top bar.
Both ways are indicated in Fp’s instructions I think (no time to check), but I don’t remember it was indicated to choose eiter way, but not both.

Took me about an hour for the whole process, but everything went all right.

Started with 1.8 and already had a unified storage. Pre-update, update, gapps install… restarted the phone 3 times in total. Had to do the home screen and widgets again, but I knew that was coming because of the old launcher coming back. Not too happy about that, but okay. (See here: Getting the 1.8 Launcher back - (originally: What's wrong with consistency?)) Had to log in with Google again, but after that all the apps were good. Automatic log ins, tabs still open in chrome… good stuff.

I do hope this software version is more stable. I complained about some bugs in 1.8 earlier (See this page: Bugs in software version 1.8), and they don’t seem to be adressed according to the change log, but I hope it will do.

Good luck to all other Fairphone owners.


I moved a post to an existing topic: Google Apps can’t be reinstalled

thank you! very dumb… it did “fix” it.

1 Like

Updated the Preupdate for 1.8.5, restarted it wanted to open the FP-Updater App but it doesn’t open. It exits with the Error “Fairphone Updater wurde bendet” (Fairphone Updater closed)

What can i do? I’m in between the steps for full update and gapps is missing too…

Thanks in advance.

Reboot the Phone and try again. If it doesn’t help clear the cache and data of the updater app (settings > apps > all > fairphone updater > “clear cache” and “clear data”)

That is really create!
First, Fairphone can´t get a proper partitioning done…for a very long time!
Users, just as “gsoundsgodd” and myself try to get it working all the same by re-partitioning the system. Believe me, I like to spend my time better than correcting errors of software developers…

Than, after some time Fairphone managed to get a proper partitioning done…

Later, the distribute updates that preffere to mess up the system before actually checking if an installation is possible or not.

Finally, of course, no support is provided for those manually partitioned systems. Now people like me are stuck with a system that doesn´t work properly, not because of myself but because of the stupid update software…

Thanks, Fairphone, I thought you would be better than the big ones…

1 Like

Don’t work. same error :frowning:

Have the same problem as Abra_Cadabra and Elin_S – Google contacts (= all contacts) are gone after the update.

Rebootet the phone several times and waited for a few hours now. Google Apps have been reinstalled and my Google account (only use one) was already added after the update. Is there anything else I could do to get them back?

:de: Nach dem Download des Updates erscheint beim klick auf Neustarten nur: Datei nicht gefunden: /cache/
Es ist genügend Speicherplatz vorhanden. Was nun?

:gb: After downloading the Update and rebooting I get the error: "File not found: /cache/"
I have enough space. What now?

1 Like

I am having the same problem with the message Android Keyboard has stopped working - anyone solved this yet?


Wenn der Update Prozess mit der Meldung “Zu wenig Speicherplatz vorhanden” (o.ä.) fehlschlägt dann lösche deinen Medienspeicher (Einstellungen > Apps > Alle > Medienspeicher > “Cache entleeren” und “Daten löschen”)
Kann sein, dass das auf deutsch alles ein bisschen anders heisset, ich hab meine Systemsprache auf englisch eingestellt.

Hi, same as me and others too.

I´m currently trying to get it working again.
If you wait a few minutes I might be able to help you.

I had the same problem and made the installation manually. But now I’m in the loop to reinstall the Google-Apps.

As I have mentioned, there is enough space. I’ve already cleared the cache and rebooted the phone. I’ve tried to install the update six times, but it doesn’t work…

How is your phones storage partitioned?