New software update Kola Nut 1.8.5 is ready

I am now trying to flash my phone, as described in this guide ( and as suggested in some of the posts above.

I installed the driver, downloaded the Flash tool (, downloaded the Fairphone recovery file (

However, when I load the scatter file in the FlashTool I get the following error:

Did anybody else encounter the same error? Since others have been succesful, I assume I must be missing something… could anybody point me in the right direction? thanks!

I think you have to download the image-binary if you have the updated partition layout, with the original partition-layout the file You downloaded the recovery -file, I remember the same error some time ago with another update I made, so it’s worth a try. good luck

1 Like

I moved a post to an existing topic: Google Apps can’t be reinstalled

thanks for your reply, but in the files you linked there’s no scatter file. How am I supposed to flash them?

Is there no simpler solution for an update? Your suggestion sounds rather sophisticated. And if there is none, what is the ‘stay awake’ in the german Version?

I finally found the solution… I this post by @daveboschma in another thread explaing the process in more details and providing direct links to the files needed:

before you start the process, read the post until the end: there’s a link to a functioning scatter file by @Kephson that will allow you to install directly the latest 1.8.5 version of Fairphone.

1 Like

:de: Einstellungen > Entwickleroptionen > Aktiv lassen (Display wird beim Laden nie in den Ruhezustandversetzt.)
Diese Option versichert, dass das Handy während dem Update nicht einschläft.

Der Teil mit dem “Recovery Mode” ist normalerweise nicht nötig.

I’m glad it’s working now.
I thought you allready tried that solution since you said…

…replying to a post that said

Btw, @inamo did you solve your problems yet?

My update worked without any issues. However, now the phone regularly checks for updates - even when WIFI is disabled. How can I turn that off?

1 Like

Here you go.

Tried to install autostarts via F-Droid, but only get cryptic “not installed” message. Don’t have google store. Any alternatives you could recommend?

Oh ok Paul, Sorry about that I didn’t realize you weren’t FP employee. Thanks for the update. I’ll keep my eye out for the new storage upgrade then.

1 Like

Sometimes you have to wait a few seconds after installing an app on f-droid.

other option would be to download one of the goolge apps via evozi

I managed to install autostarts by downloading the apk directly from via f-droid website. For some reason, directly installing from F-Droid no longer seems to work. Wonder if this is related to the update (had no issues previously)

Strange. Maybe reinstalling F-Droid helps?

Hi I have updated my fairphonne and reinstalled Google Apps from the widget as told, but it keeps telling me that a new update is available, and I can just keep doing it over and over again. Can it be true?

I tried “Empty cache” and “Erase data” but it’s still the same. It keeps checking if there are new updates. Otherwise it works perfectly.

I have the some problem with the Android Keyboard stopped. I though I could use the Fairphne without installing the Google app store. After all we are offered the choice to install or not, or don"t we?

Please help me to install the old version on this Phone for gods sakes!
I am sorry but your forums are not understandable for me and any tutorials are not helpful.
I tried this but I get an error when installing the 1.6. Version.
this Update is impossible!
I had so far no troubles updating the phone and I liked the slight changes of the previous Versions, but this updates takes away what the fair phone was standing for for me!

No free space anymore - you want me to spam my screens with tons of apps just like any other cheap phone out there?? no thanks, I enjoyed the blank spaces and the ability to launch apps from the hidden side swipe- that was innovative and great about fairphone! It made the fairphone worth it!

the swiping! where is that now? I don’t see any option to enable it? are you serious? it is the only way I can type on a phone/ Again its something innovative and great and now it is gone???

You make me force use google search with the ever present google bar now?? that is no longer fair and autonomous, and do as you please, dear user, as how you were selling your phone so far!

concluding - everything the FairPhone was good for is gone now.

Please help me reinstall the old version or I am going to sell this phone off on eBay. And I am sadly not the first one of my Fairphone Friends planning this by now!
Already the fact, that it is not possible to buy a single cable, which got a loos contact with the phone, but only the charger itself, is ridiculous and not matching with your, you can buy any part extra shows how much lies and not working customer support options are going on here!

I need the previous version to be able to keep using it! Thank you!

If you have used Google Apps previously, the FP thinks you would like to keep using it. If you don’t want to install Google Apps again, you have to choose the AOSP keyboard in the settings. Here is how to do that:

Go to Settings > Input and Language and tick "Android keyboard (AOSP).