New Modular Fairphone Earphones not working on my FP2

I just received the new Modular Earphones made by Fairphone and ran into the following problem:

  • They are not recognized by my FP2: the sound is not played on the earphones but on the regular phone speaker as if no earphones were plugged in at all
  • other earphones are working on my phone
  • the new modular earphones work on other devices.

Therefor I suppose there is a problem in the interaction of the new earphones with FP2.

Does anyone have a suggestion how to solve this?

Have you checked if it makes a difference when you plug it in with the case removed?

We had a similar problem like yours with someone on the FP3 as well and in her case it actually took a harder push until the plug (different headphones though) was properly in its place.

I myself used the new Fairphone earphones in an FP2 without such problems.


Thanks for the suggestion! After taking off the case, I managed to get it to work for the first time.

Now it also works when the case is in place, however it seems to be dependent on how I put the plug in…I can’t really describe it. I most often works, if the tip of the plug is pointing a bit towards the front / the screen side of the phone while firmly pushing the plug in. However I usually have to give it 2-3 tries until it works.

Once the headphones are accepted by the phone the contact is reliable, there is no wobbling or transmission problems, so it doesn’t seem to be a problem with the dimensions of either the plug or the socket.

Unfortunately the remote controls are not working. But since the sound quality of the headphones is great and they sit quite comfortably, I can live with this for the time being.


I read this thread and was interested in buying earphones for my FP2.
However, this is what I found on fairphone online shop about these earphones:
“Compatible with Fairphone 3, as well as most Android and Apple devices with a 3.5mm audio port.”
Compatibility with FP2 is not explicitly declared.
Not sure if your issues are to be expected.

Dear and.rea,

I’ve come across this note on the shop page as well before buying the earphones. I read it as a marketing statement, merely meaning that they were designed to be compatible with the FP3.

If they knew that there are problems with the FP2, I would find it deceiving not mentioning this explicitly, since both products are from the same producer and you would therefor expect them to work together flawlessly by default. However, being a FP-customer for some years now, I don’t believe it was intentional by them and that this is an unknown problem.

Plus, since both FP2 and FP3 have a 3.5mm audio port and run reasonably modern versions android, I wouldn’t know what technical difference there should be causing problems. That’s why I still bought them.

1 Like

I just got the Modular Earphones and they’re not even recognized by FP2, while other earphones are. Sorry, but that’s just ridiculous. I tried them with the case removed and they still dont work. Ill’ send them back and just hope to get my money back - but it would be really nice, if there was an information on the shopping page, that your modular earphones are not working with your own phone -.-’

Sorry, but the modular earphones are only to be used with a Fairphone 3.

I have had a 45 minute phone call using the Fairphone modular earphones without any problems on my FP1 just this sunday and am listening to music :white_check_mark: using them on an FP2 (original 2MP top module) right now. On the FP2, volume control :white_check_mark: as well as pausing :white_check_mark: works on the default Music app (under the latest /e/ version).

Further testing

Fairphone Open OS 19.08.1.
Reduced functionality. Plugging in sometimes gets recognized, sometimes not. When the connection is there, both audio playback :white_check_mark: works and the microphone :white_check_mark: picks up my voice (in Sound Recorder), but remote control :x: input is without any effect (neither pause/skip nor volume) in the default Music app although the notification bar shows a headset symbol.
Maybe Android 7 vs. Android 9 makes a difference here.

Sailfish OS (Android 6?)
Very limited testing possible for me only (no music app pre-installed, resorted to just testing optional system sounds). Audio playback :white_check_mark: works, volume control :white_check_mark: works, pause :x: does not work.

Ubuntu 16.04
Same result as Sailfish OS: Audio playback :white_check_mark: works, volume control :white_check_mark: works, pause :x: does not work. Hit and miss when it comes to plug recognition.

LineageOS 17.1
Audio playback :white_check_mark: works, volume control :white_check_mark: works, pause :white_check_mark: sometimes worked … in a very special way (vague theory: once you have paused a track, the same button will only work again to resume play after you’ve waited like 10 seconds – otherwise it won’t respond at all). Functionality of the remote control is generally hard to predict, it will sometimes even skip forward or back a track when using the volume buttons. Microphone :white_check_mark: works. Hit and miss when it comes to plug recognition.

Microphone tests all done with both the primary and the secondary microphone simultaneously pressed shut with my thumb/finger – to make sure it's the headset phone that picks up my voice, not the FP2's built-in ones.

That might be true for the microphone or the call-function.
But listening to music to my knowledge should work with those headphones on each and every device with a 3.5 mm headphone plug, as the audio-contacts are the same with every headphone. Or am I missing something?

My guess is, that it is simply the problem, that existed with the FP2 from the beginning.
Some headphones seemed to get no contact, because the cover of the FP2 is to thick, so the plug can not be put in firmly enough. Maybe the plugs of some headphones are shaped a bit different (longer, shorter, slimmer …).

Some explanation can be found in this wiki:

and in this thread:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.