New Fairphone 2 stuck on "powered by Android" screen


I just got my fairphone today and successfully installed some apps on it. As I was installing the messenger app however, I all of a sudden got the “Fairphone - Powered by Android” screen. Now the phone is stuck and shows that screen every two seconds or so. It also vibrates now and then.

I’ve tried:

  • holding down the top right button
  • holding down top right button and volume UP
  • holding down top right button and volume DOWN
    but nothing happens.

I’ve also tried taking out the battery, but that hasn’t solved anything. Not sure if this matters, but I was charging the phone when it all started.

I really wanted to love this phone, but now I’m just frustrated. :frowning:

Any help is much appreciated!

Let your phone charge till it’s full and you see a green light.
If one of the apps is facebook, then remove the app facebook.
A lot of Fairphoners have suddenly lots of problems with facebook.

1 Like

Other Fairphoners have reported issues with some chargers, especially if they continue to use the phone while charging. You might want to try different USB cables and/or chargers if you have any. There’s a list of chargers others have tried out.

1 Like

Hi Lidwien and urs_lesse!

Thank you the response! Facebook was one of the apps that I installed. I’ll try different cables and chargers and will wait for the phone to fully charge. I do wonder how long this will take, considering the vibrating and the screen popping up so often.

Can’t stand any more of that buzzing sound, it’s driving me crazy!! :slight_smile:


Hi @Eve_Flam, did your phone finally start ?
Mine is 6months old and I have now exactly the same problem. It does not boot and sometimes (when plugged on the charger) shows the “power by android” screen and vibrates then shuts down again.

Two ideas, although not very specific to the problems, but worth a try:

  • Try a proper Battery Reset Fairphone 2 as described in the #batteryguide. Lidwien hinted at it already above, but note that this requires leaving the battery out of the phone for a full 30 minutes first.

  • Check if the battery sits firm in its bed. If it seems a bit loose and might slip off the contacts, you can try to fill the gap under the battery’s lower slim end with a small piece of folded paper to make it sit firm.


I got in touch with the fairphone team. They thought it was the battery, so they sent me a new one. I could boot and use my phone, but the new battery only charged up to 50%. During the day the indicator jumped from 50 to 78 to 1… You get the idea.
They then suggested I should drain the battery, and take it out of the phone. I had to connect the phone to my charger without the battery in it first and put in the battery afterwards. Then leave it charging for five hours. The result is that now I’m back at the start: phone doesn’t boot and shows the “powered by Android” screen when I charge it.

Wonder which solution they’ll offer me now… It’s been 12 days since I got my phone and it hasn’t worked properly yet. :frowning:

Good luck with yours, @Lucas_Menant. :slight_smile:

I thought this was only the procedure for FP1… :confused:

Maybe, it’s a defective USB port. In this case, the phone only charges when the USB plug is pushed back (away from the display). You need a new bottom module then.

I don’t know if this issue is still actual but for the record I’m adding some points I observed.
My FP2 got stuck in a Bootloop after upgrading to Android 6 Marshmallow (Bootloop Android6 Marshmallow), but before I found this post I observed some similiar behaviour of my FP like you described:

  • when I remove the battery and plug the phone to my PC, then the “powered by Android” screen appears and a short vibrating every 2 seconds, with short blinks of the red LED
  • when I remove the battery and plug the phone to my standard-charger, then the screen does not appear, but every 6 seconds a short vibrating, with red LED
  • when I insert the battery while the phone is already plugged in, then the phone boots (or it tried to, in my case)
  • battery inserted and afterwards plugging in leads to normal charging, without booting

So this post is not really related to your problem, but maybe it helps somehow. After my observations I would have said maybe you have to replace your battery, but you already tried that…

1 Like