New Fairphone 2 doesn't work, although seems to be charged

Hey guys! Sorry if this is the wrong place for my issue, but I really tried all other ressources and ways of contacting support, they all don’t work and I’m a bit in real trouble now…

Here’s my issue:

I just received a new Fairphone 2, followed all the instructions, but it wont start / power o.

Details:
My new Fairphone2 (Order Number FP300078356 ) arrived today. I watched the unboxing video, but unlike shown there my Fairphone was already put together / assembled in the box.
However, I charged it, as the instruction said, the screen of the phone showed a picture which looked like the internal of the phone, at least for a short time. The LED top left was green, so I assumed it was already charged.
I opened it and put my SIM inside, tried to turn it on, doesnt work. It vibrates, but doesnt do anything.
I took out the battery, put it back in, tried on and off the charger, doesnt turn on when I press the power button.
I left it at the charger for a while, although the LED is always green, no difference.
Tried switching on with and without charger - it always vibrates a bit but doesnt do anything else, screen is black.

I really appreciate your help, thanks!

In which way did contacting support not work? Try calling them (see #contactsupport for details).

Try to start it without the SIM.

Try to disassemble and reassemble the display module (you will not lose warranty doing this), perhaps there’s some glitch in the contacts there … here’s a nice video (you only need to do the display parts) …

Else … try the #blackscreenguide .

4 Likes

Thanks, will try all that! Support contact doesnt work because of bugs in the contact form, either the captcha is not rendered or other mandatory fields, depending on which browser I use

Thanks again AnotherElk! Seems like the display was the problem.

1 Like

Which is strange because it showed something when I connected to phone to a charger for the first time… anyway, you saved my weekend :wink:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.