New Camera module: no connection to camera

Hi folks,

I upgraded the camera modules in mein FP2. The Front Camera works like a charm but the rear cam only worked one day. I did not use it some time and some days ago I wanted to take pictures but the camera apps say “No connection to camera possible”.

I already opened the phone again, cleaned the contacts and reassembled the system but the error remains. I tried to use the “old” module but now I am not even able to calibrate the proximity sensor and the old module is not usable again.

Any ideas what I could try?

Have you updated to the lastest update available 17.12.1?

1 Like

Hello Lidwien,

thank you for your answer; yes the operating system is current 17.12.1.

1 Like

Can you try another camera-app?

I tried the Google Camera, the Camera app from and OpenCamera

Is there a heaven in your neighbourhood to test the cameramodule in another FP2?

Sry, what is a “heaven”?

A heaven is a place where a Fairphone Angel is situated. A Fairphone Angel is somebody who on a volunteer base is offering help for owners of a Fairphone with the approval of Fairphone.

cool program … unfortunately no heaven in eastern Germany (Dresden) … maybe Pegidas’ fault? :smiley: … maybe I can manage to visit Stuttgart or Munich :neutral_face: … thank you for your ideas; I’ll clean the camera contacts tonight with Isopropanol maybe it helps :confused:

You just get experience now and would be prepared to create one yourself and help other people in your region. :slight_smile:

1 Like

Hi there,

I had this message recently and also failed to fix it with any of the above.

I then dropped and broke my display and had to order a new one, and the camera is now working again - so perhaps it is an issue with the display module rather than the camera? When it was broken I also found I was still able to use the front camera module by the way, but only having that is hardly ideal!

Thank you mzungum, I am going to check the display module maybe I have to clean upsome things there. Thanks for the hint.

I have the same problem here Sven, when I start the camera app it opens but gets stuck in the start-up screen and says ‘can’t connect to camera’. If you find a solution, I’d love to hear it… Thanks and good luck!

Hi evdh,

I do not have this problem any more but I don’t know if you like the solution. I accidentially throw my phone in the toilet. Fast opening,complete dissassembly and some hours on the heater and after a reassembly the camera now works like a charm :wink:

I would recommend to disassembly all parts (all with phillips screws), clean them and reassemble; maybe this helps.


I was just on my holidays far away, when the rear camera stopped being recognized. Plowing through the net, I went to have all the contacts of the camera module cleaned. The phone was reassembled and apart from the camera and the occasional unwanted reboot, all is good.
Is there any new information as to what I can do to get the camera going?

Looks a lot what I’ve just been through. You must have already checked this post, didn’t you?

I had the same issue, and here’s what I did:

  • Disassembled everything, as explained in the official steps ( / Camera / Can’t connect to the camera)
  • Reassembled everything. Camera was still not working.
  • Waited for a couple of weeks, procrastinating on the issue.
  • Disassembled everything, and this time I took pictures as indicated in the official steps. As I was taking the pictures, I noticed that a piece of plastic was kind of covering a contact
  • I took off that piece of plastic (it might have been a piece of glue from the screw hole), finished taking the pictures, reassembled everything, and the rear camera is now working!

I’m not sure if that’s of any help, but I thought I’d share my success story to give a light of hope to some of you <3 Otherwise, it looks like your next step is to send a support request to the official support at Fairphone.

PS: I still haven’t got an unwanted reboot, but it’s only been 20 minutes since I turned my FP2 on…


Hey Matt,
Yes I did. I went to a repair shop in Can Tho and the the phone was taken apart, the contacts cleaned to no avail. So, I did write to Support and currently am waiting for a reply.
Thanks for asking

Totally fair. Good luck with the next steps!


I just did exactly the same (issue, proscratination, and then disassembled, reassembled) and now it is working again. Let’s see next week if it lasts.
Thanks for the tip.

Best regards,

So, not sure if that gonna help, but my camera stop working after a few days… I just redid the entire cleaning process (after another week of procrastination…), including taking off pretty much all the glue from around the screw holes, and… still not working :frowning: