New camera module can not connect

I replaced my camera by the new module. Most times (not always), I have an error “the app can not connect to the camera”.
What went wrong. How can I dissolve the problem?

Did you update your OS to the current version?
(What does it say in Settings - About phone - Build number?)

Perhaps disassemble and assemble again.


I have the current version latest update (android 6.0.1 - 05 october).
I will try to reassemble. Maybe I need to clean the contacts? How can I do this?

1 Like

I get a new module for my camara too and I have the same problem. When I replaced the camara I received the message that the camara have been replaced succesful but when I start the camara app skip the message “the app can not connect to the camera”.

I have the current version too.

What can I do to resolve the problem?

I replace now my old camara and works correctly.

The images on the shop website show a different part number to the original camera module (FP-REC02 not FP-REC01).
When I have received my upgraded parts, they both have the same part number as the original modules, but they show up in Settings - “About Phone” as the 5MP and 12MP parts, so don’t think you have been sent the wrong parts just because they have the same part numbers.

Also by me, the new camera has the same number (FP-REC01) as the original.

The part numbers were already discussed here …

I would carefully guess … with a clean cloth that doesn’t give off fluff and some cleaning alcohol.

Did you …


I essambled twice and the error continues

What can I do to resolve the probleme?


Suggested the new module(s) are correctly reported under phone info and you use the built in camera app, have you tried to purge the apps data and cache? I would suggest to save your photos to disk before. Then Settings -> Apps -> Camera (“Kamera” in German) -> Memory (“Speicher”) -> Data/Cache. After deleting data and purging cache and checking the apps permissions, the new module(s) might work. If not, I assume the module is defect.

Another test for the module would be using another camera app (there should be some in the stores, have no experience). If it works, you could decide to stay on the new app.

I did both (purge apps data and cache / using another camera app), without result.

So if you don’t know another FP2 user which could try to test the new module in his device, I would return this module as being faulty. I have no further idea :disappointed:

I got it. Today I essambled again the camara and works correctly. Thank you for your help.


Great! So I would suggest if the camera works stable to mark your post as solution.

My camera module still remains “death”; so the solution of KleinerAdmin is not for all of us good .
I reassembled the old camera and it works perfect. So I think there is a problem with the hardware of my new camera. It should be replaced by another.
I contacted “Fairphone support”, but untill now without answer.

You could call them, that works faster.

I received a new FP2 (including the new camera modules) some day’s ago and yesterday I also discovered this severe hardware issue.

When I physically stress the phone a bit (e.g. bending) I can trigger complete or part failing of the rear camera (see picture below). Sometimes, when the image fail remains for a couple of seconds when you start the camera app, it just says that it can not connect to the camera at all.

I already broke down to the module twice, cleaned and “rebended” the 3 contacts without success. I wrote an email to the support team, without a reply yet. I’ll keep you guys posted!

I also have the same problem with my new phone module, “no connection”. I also purged apps data and cache, and tried using another camera app, without result.
I have identified that the issue is with the front camera (not the one for taking selfies).

I had the problem that my new camera module did not connect. The problem turned out to be “two circular black thingies” preventing the new module to connect properly.
I made a picture of the thingies next to the old module, but with some imagination you should be able to vision where they were stuck.
We removed them with a screwdriver (veeeeery carefully!)
I hope this helps some of you
:slight_smile: Mette