New camera module can not connect

I would carefully guess … with a clean cloth that doesn’t give off fluff and some cleaning alcohol.

Did you …


I essambled twice and the error continues

What can I do to resolve the probleme?


Suggested the new module(s) are correctly reported under phone info and you use the built in camera app, have you tried to purge the apps data and cache? I would suggest to save your photos to disk before. Then Settings -> Apps -> Camera (“Kamera” in German) -> Memory (“Speicher”) -> Data/Cache. After deleting data and purging cache and checking the apps permissions, the new module(s) might work. If not, I assume the module is defect.

Another test for the module would be using another camera app (there should be some in the stores, have no experience). If it works, you could decide to stay on the new app.

I did both (purge apps data and cache / using another camera app), without result.

So if you don’t know another FP2 user which could try to test the new module in his device, I would return this module as being faulty. I have no further idea :disappointed:

I got it. Today I essambled again the camara and works correctly. Thank you for your help.


Great! So I would suggest if the camera works stable to mark your post as solution.

My camera module still remains “death”; so the solution of KleinerAdmin is not for all of us good .
I reassembled the old camera and it works perfect. So I think there is a problem with the hardware of my new camera. It should be replaced by another.
I contacted “Fairphone support”, but untill now without answer.

You could call them, that works faster.

I received a new FP2 (including the new camera modules) some day’s ago and yesterday I also discovered this severe hardware issue.

When I physically stress the phone a bit (e.g. bending) I can trigger complete or part failing of the rear camera (see picture below). Sometimes, when the image fail remains for a couple of seconds when you start the camera app, it just says that it can not connect to the camera at all.

I already broke down to the module twice, cleaned and “rebended” the 3 contacts without success. I wrote an email to the support team, without a reply yet. I’ll keep you guys posted!

I also have the same problem with my new phone module, “no connection”. I also purged apps data and cache, and tried using another camera app, without result.
I have identified that the issue is with the front camera (not the one for taking selfies).

I had the problem that my new camera module did not connect. The problem turned out to be “two circular black thingies” preventing the new module to connect properly.
I made a picture of the thingies next to the old module, but with some imagination you should be able to vision where they were stuck.
We removed them with a screwdriver (veeeeery carefully!)
I hope this helps some of you
:slight_smile: Mette


Thanks, but it is no help for me. Always the same message “can not connect to camera”.

I have a similar problem with the new camera modules. They seemed to be working just fine, at first, but then I got one “cannot connect” message, and since then my camera app just hangs when I try to use it.
I’ll try reassembling. If that doesn’t work, I guess I’ll switch back to the old modules (I’m glad I haven’t sent them back for recycling yet) and try to get a refund.

UPDATED: I reassembled the phone, and cleaned the camera modules’ contacts with alcohol, and for now, the cameras are working.
In the instructions, it warns against tightening the screws too much. But, I think tightening them too little will also cause problems, because it means the electrical connections would be less secure. Just a thought.



After having my FP for 6 months. I also had problems with the connection of the camera. Sometimes my camera works, sometimes it doesn’t. So I read this whole topic very well. But now for the last week it worked well every day.

If the problems will come again. I hope to solve it by reassemble and clean the camera module. And I will take all your tips & trick about this in mind. So thanks everybody for this.

My phone has suddenly stopped communicating with the camera, even though I have not dropped or knocked it! I have tried rebooting several times, as well as trying to update the phone to no avail. I have disassembled both camera units, cleaned the contacts with alcohol, reassembled and still no connection with the camera! :roll_eyes:

I even tried restoring phone to factory data reset, but that did not help connect to the camera!

Sounds like a hardware defect. The fairphone troubleshooter will tell you what the optimal way is of filing a support request with Fairphone support.

Still the same with my camera. Today I sent a support request. I don’t know what to do anymore. I’m missing the camera so much. It’s so practicle to have always a camera in your bag without to lug always with a real camera.