English

Netflix 5.x on LineageOS (FP2)

Tags: #<Tag:0x00007f05dcae1eb8>

We have another reproducer!

I had a chat with @StevenHachel, he installed Netflix 5.x and got the same error on LineageOS.
(Steven’s device isn’t encrypted, so that’s definitely not the reason for this problem)

Did you try to collect some logs with logcat in order to see if there’s some error somewhere during the use of Netflix app?
Bye!

1 Like

Found this on “help.netflix.com”:

Rooted or uncertified Android mobile devices are unable to download the Netflix app from the Play Store. Rooted or uncertified mobile devices are not blocked from accessing Netflix, but, depending on configuration, may not function properly.

More info here:

https://help.netflix.com/en/node/12983

that’s right, but you can download the app from other sources as well, and then the installation will fail, with version 4.x working.

Might just be the cause. (I know, it is quite illogical, but …)

https://download.lineageos.org/extras

@DjDas
Yes. I’ve put them into the bugreport I created.
https://bugtracker.fairphone.com/project/fairphone-lineageos-on-fairphone/issue/22

Exactly!
Nothing more, nothing less.

This means, rooted devices with LineageOS can run Netflix 5.x!
(like my Samsung Galaxy S4 Mini running LineageOS with addonsu)

As long as you don’t install addonsu (https://download.lineageos.org/extras) you can even download Netflix from PlayStore (I’ve tested).
That’s because without addonsu you don’t have root access (/system/bin/su), which is what the PlayStore is checking for.


But because of this is may be hard to get help from Netflix.

Rooted or uncertified mobile devices […] depending on configuration, may not function properly.


Luckily we know, that Netflix 5.x runs on the Fairphone 2, because it works fine on the Fairphone 2 stock OS (even on the FP Open OS). So it’s not a hardware problem.
And we know, that Netflix 5.x runs on LineageOS.

My current guess is, that this problem is something about:

  • a driver being different from the ones in the Fairphone 2 stock OS,
  • or a compilation setting being different from the ones used for other LineageOS build like the one for the Samsung Galaxy S4 Mini (serranoltexx).

Unfortunately I do not much about building LineageOS ROMs. So maybe someone can help who knows more about that.

Another idea, how to find out what’s happening:

ApkMirror shows, that Netflix 4.x requires at least Android 4.4 (API 19/20). While Netflix 5.x requires Android 5.0 (API 21/22).
https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-4-16-1-build-15145-release/netflix-4-16-1-build-15145-android-apk-download/
https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-5-0-1-build-16103-release/netflix-5-0-1-build-16103-android-apk-download/


But Netflix also says, that not every Android 5.0 device is compatible with Netflix 5.x.

The most recent version of the Netflix app for Android is not compatible with all Android devices running Android 5.0 (Lollipop).
https://help.netflix.com/en/node/57688


So this must be something about an Android ability/feature introduced in Android 5.0. But this ability/feature may still be disabled somehow in Android >= 5.0. And exactly that might be the case here.

The trick is to find out what possible relevant feature was added between Android 4.4 and Android 5.0!

I guess it’s maybe some DRM or safe storage stuff, so Netflix can safely store movies without allowing the user to copy them.

My bad, the Netflix app from Play Store installs on recent LOS 14.1 nightly but I didn’t bother starting it (I don’t have an account). It actually doesn’t work as it doesn’t start up. They suggest to download an APK instead of version 4.x. I started that version and it starts up, but I didn’t verify it works beyond that (again, no account).

So yeah, just to clarify: I can start up 4.16.1 build 200147 (didn’t play videos etc obviously).

That’s exactly the problem with Netflix 5.x we’re talking about. No need to login!

And yes, Netflix 4.x works but misses the very useful offline watching feature. That’s why it’s relevant to get Netflix 5.x running

My take is: I assume they don’t blacklist anything; instead they default to blacklist and whitelist platforms (device + OS) based on whether they are guaranteed not rooted. FPOS (@ FP2) is guaranteed not rooted, so Netflix whitelist that. LOS @ FP2 might be rooted so it won’t work. That an earlier, probably unmaintained version still works is by God’s grace.

Perhaps a community member who feels like leading could contact Netflix but without any given authority from the community (it not being an official port) I am not sure how far that will go.

Ah right, that feature explains a lot actually. So what probably happens is in offline usage mode is it stores the DRM keys to decrypt the content in a secure enclave.

I guess not.

Remember, I have an Samsung Galaxy S4 Mini, running LineageOS. And Netflix 5.x works fine on it. So it’s probably not a device or os/rom blacklist/whitelist thing.

@JeroenH did a little testing and found out the following:

  1. Uninstall and reinstall the app, or stop it an clear it’s data.
  2. End all network connections (e.g. WiFi and mobile data).
  3. Start Netflix 5.x and you’ll get the following error instead: “Sorry, we could not reach the Netflix service. Please try again later. (-14)

That doesn’t have to necessarily mean anything for our problem. But maybe Netflix somehow needs a connection to it’s server when doing the compatibility check. But it could also be unrelated to the compatibility check.

1 Like

@chrmhoffmann found a solution!

The the FP2 LineageOS ROMs had missing/incorrect libraries for WideWineCDM. Should be fixed in the next nightly! (probably 2017-11-14)


DANGEROUS - BE CAREFUL

For those who can’t wait: Copy those three files onto your system partition. You need to remount the system partition writable before.

After copying, issue chmod and chown to each file.

chmod 644 FILENAME
chown root:root FILENAME

Don’t forget to remount the system partition read-only at the end!

Finally stop the Netflix app, delete it’s data and restart it.

5 Likes

Netflix 5.9.1 works for me on the latest LineageOS+MicroG.

Netflix 5.10.0 works for me on latest LieneageOS (14.11.2017). :slight_smile:

2 Likes

oh, oh, emailadress is visible! :wink:

3 Likes

I did not pay attention. :slight_smile:
thx :slight_smile:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.