Need help installing openos

Hey everyone,
I finally received my new fairphone (2) and wanted to run fairphone open os. I followed the guide on bu ran into multiple issues.

  1. On Windows 7 my laptop doesn’t recognize the phone when in fastboot mode.
  2. On Linux Mint when typing “sh” I get the answer “can’t open…”
    Am I doing something wrong? Or did I forget sth?
    I hope someone can help.


On linux, you may try to run the command “sh” with root rights using sudo “sudo sh”.

Hope it will work…

thx for the fast answer. Tried sudo… already and got the same answer. I also tried it with and without “usb debugging” enabled. How do I enable root rights?
I don’t really know what I’m doing, just following tutorial steps.

My first question is why you have to do the manual installation at all. :thinking: When I installed OpenOS (at its first release), I did it directly from the updater. Fairphone Updater -> Advanced Options -> Android for Fairphone -> Fairphone Open

Is the phone correctly detected on your linux system?

As far as I know, the updater way no longer exists… that’s why he needs to do the manual install I guess :wink:

How do I find out if its detected?

I assume you didn’t install fastboot yet neither on your Linux nor on your Windows machine, because it’s not clearly stated in the instructions. Correct?
On Linux Mint you should install android-tools-fastboot.
The command should be similar or same to
sudo apt-get install android-tools-fastboot
(I’m on Ubuntu, that’s why I’m not absolutely sure about the correct command)
After that you should connect your phone after booting it into fastboot (Power + Vol-) mode (USB debugging has to be activated).
If you already have installed fastboot please type the following to verify if your phone is correctly detected
sudo fastboot devices

Also, could you please state the complete error message you receive when the script on your Linux machine aborts?

1 Like

I did already install fastboot. Is installing enough or do I need to do something else?
When I type “sudo fastboot devices” I get “4e1363d6 fastboot”.
When I type “sudo sh” I get “sh: 0: Can’t open”

Ok cool, your phone is detected correctly.
The error message indicates that the file either can’t be found or has wrong permissions set. But I think it’s the first issue. The file is part of the package you downloaded from You have to navigate to the folder where you extracted (unzipped) the downloaded manual switcher package, i.e. cd Downloads/fp2-sibon-18.04.1-manual-switcher/ or whereever the folder is located on your hard drive. Try to run sudo sh there again.

I read something like that already, but I didn’t really understand it. Do I type it in one line or two? It’s the first time I really use the console so I don’t really know what I’m doing.

Please type it in two lines (hit Enter after each line). If you somehow get lost on your hard drive inside the console you could type ls to see which files and folders are inside the folder you are currently in. When you see the file in that list you reached your destination folder :wink:

It worked!!! Installation was completed and it looks good for now. I will ask if I’m still having trouble with something, but I think for now I’m fine.
Big Thanks to everyone for the fast help and to Freubert for solving the problem.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.