Native calendar empty after 1.8 update

After updating to 1.8 Kola Nut I’ve lost all of the entries in my native calendar app and I don’t have a backup :frowning:

FYI - community moderator police Robin - I’ve searched for a mention of this in the forums and the only mention is a comment buried in a massive thread. Since this should be deemed important and needs not be overlooked, I’ve added this as a new topic.

Since I don’t see this as a bug yet (I did not experience any trouble with the calendar), I recategorized this to the Help category.

1 Like

Darren, just FTR, are you using Google to sync your calender? If so, you might just have to re-establish the syncing (before entering new stuff to the calender, I suggest…).

If not, @Stefan: do you? This might explain why you had no problems.

To clarify: if you update and have to re-install the GApps, of course your calender will be gone without an update.

No I don’t use Google to sync my calender.

But you have GApps installed? And re-installed it after the update to 1.8?

I thought the update probably overwrites the calender storage. But since you did not loose the entries, my idea goes to the bin. :put_litter_in_its_place:

Talking of storage, @Darren_Smith, did you come from 1.6? Have you got the unified partition applied (as I assume Stefan has)?

  1. I do not have Google Apps installed.
  2. I applied the unified storage upgrade, when on 1.6.

Hi @humorkritik (& Stefan),

I do have Google Apps installed and performed the updated after going from 1.6 to 1.8 (haven’t applied the unified partition update). I’ve just checked the settings for the Native calendar app and it is set to sync with my Google calendar (which I never use). I’ve never knowingly set this up, and definitely haven’t changed any Google settings since I went from 1.6 to 1.8 (or any time recently). This calendar issue did not happen when I upgraded to 1.6.

Thanks for the help.



Darren, I vaguely remember that syncing settings are an opt-out, so if you re-installed Google Apps after the update, you would have to actively de-activate this.

However, for me, this does not yet fully explain what went wrong. If the syncing was set in the last OS version as well, you should be able to see calender entries (also via the web interface). If it wasn’t, and the (online) calender would be blank, but should IMHO not overwrite your calender entries if they were preserved during the update. Please check your calender online, because as far as I can see, that’s the only option where you could still possibly get your entries back.
Since Stefan still has his calender after the update, and without using GApps, I see several possible explanations, but none of them helps you regaining your calender, sadly.

A likely explanation would be that an update of Android (always) deletes your calender entries, and most people don’t notice because they either have a local backup or store their stuff in the cloud. This would mean Stefan lost his calender entries with the update but forgot about, because he restored them either from a backup or from his Owncloud (I think he uses this to sync his calender(s), as I take from another thread). It could also mean that his calender entries are stored on the SD, or at least somewhere out of the basic android partition, and did not get deleted because of this.

We could try to rule out that stuff if people come forward who upgraded to 1.6, applied the unified partitioning, and do use Google Apps without ever having the syncing active, and their calender was left intact. (Or if someone knows about how Android implants the calender storage. :slight_smile: )

If they loose the calender then when then upgrading to 1.8, that would explain something, at least. Not that it helps.

Bottom line: backup everything, constantly, and especially before you do apply system software updates. Everything else is like searching needles in haystacks. :-/

The calendar is stored in the folder /data/data/
I don’t think that this folder gets wiped during an update of Android because it is not in the system files. An install of Google might erase calendar data though.

Hi, thanks again for your replies @humorkritik and @Stefan.

@humorkritik, I have tried checking my Google Calendar but it was blank. But I conducted a test and it seems to sync with my phone with the current settings I have. Before I start to re-enter everything, I am interested in knowing what happens to the Google Calendar if a re-install on my synced FP wipes everything on the phone again - will that be seen as that I’ve removed everything and wipe it all from Google? By guess is probably yes!

Stefan - I don’t have a top level ‘data’ folder, nor a folder (that I can find anyway). The closest I can get to is: Phone storage/Android/data/

@Darren_Smith: you would need a file browser with root privileges, e.g. Open Explorer Beta. There are also many others, the one I linked to, is the one I use to see the file, I mentioned.

An Android update should not wipe all the entries from your online calendar. Can you think of any other way that the calendar entries got deleted, for example MS Outlook or Mozilla Thunderbird?

True, it should download the online entries after the update.
Except when you e.g. restore an old (empty) version from the backup, and then sync from your device to the online calender. But Google/Android is smart enough to warn you that you are deleting X entries, and if you really want to proceed.

That could be a possible culprit, indeed.

1 Like

@Stefan, I am still not seeing a top level ‘data’ folder, nor a folder, even with Open Explorer Beta (and root access). The only folder that comes up in a root level search for ‘calendar’ is: storage/sdcard0/iSMS/calendar? I don’t have (and never have had) MS Outlook or Mozilla Thunderbird on my phone.

I didn’t receive a Google/Android warning about deleting X entries when I upgraded to 1.8.

I meant the following: If you connect your Google calendar to Outlook or Thunderbird on your computer, it could be, that events were deleted there.

Can you see the “/” [slash], which is highlighted? Press it! :slight_smile:

1 Like

Oh yes, now I see it (doh!).


Just for anyone reading this thread in the future. I wasn’t able to retrieve the calendar entries lost after the update to FP OS v1.8. So I guess that the cause remains unknown/unsolved. Going forward, I’m going to (hopefully) avoid this happening again by storing everything in Google and then just sync with the native phone app.