My FP2 is not detected by my computer

  Hi there,

I have a FP2 and I use its OS system.
I cannot get my phone detected whenever I try to connect it to my computer.

It is very curious since when I put the usb cable I immediately got notifications on my screen telling me " access point and connexion sharing" and another one saying: (in french sorry I can’t find the translation in english) “Debogage usb activated” but I know it means mainly that the developper can access the data of the phone logged on the computer.
I hope that I have been clear, and you manage to help me.
Thanks a lot in advance

Stella

Hi Stella and welcome to the community and its forum!

Once you have connected your FP2 by USB to a port on the computer, on the phone you need to go to
Settings > Connected devices > USB
in order to choose how you want to use USB. In order to see the files from the computer and maybe move them choose “File transfer”.

4 Likes

Hi Od Routard,

I am really sorry for not having replied since your last answer.

Honestly I did not check the connection with the usb device.
But my main issue currently is that I still cannot answer any calls! :(( Whenever someone calls me I cannot see the page with the phone ringing to tick "answer :confused:
so I always have to wait for the call to stop, to see who did call me and call him or her back.

By the way, as I put the Open OS system on my fp2, I cannot use some apps like those which recquire a geolocalisation(electric bikes) so this is really annoying too as it is obvisously bec I forbid any google “settings” on my phone… :thinking:
I am even considering of changing my phone to a classical one.
Are there fp users here, who set an open OS or lineage OS on their phone and still can use such apps?

Thanks a lot and have a nice day!

Stella

Once you unlocked the phone (or activated the screen, if you don’t use the lock screen), there should be another notification telling you that the device gets charged via USB. Tap this notification, until you are given options like File transfer, PTP etc., then choose File transfer. This should make the phone’s storage available to your computer.

Such user interaction is needed by default as a security measure since Android 6.

Or do you already do this, and it doesn’t work?

Sounds like the “Phone” App is lacking permissions for notifications.
I’m not using Fairphone OS or Fairphone Open OS, but you should be able to check something like Settings - Apps and notifications - See all … apps - Phone - Notifications.

Location should work, of course.
GPS alone should work out of the box, but GPS alone can take a little while to get a location fix.
Lacking the typical Google setup, additional location providers (cell towers and Wi-Fi) might need to be set up seperately.
I can’t remember my setup steps for Fairphone Open OS or LineageOS, it was too long ago for me. I’m using /e/OS on my Fairphone 2 now, where this all was set up by default.

If you happen to have #fairphoneangels in your vicinity (<- see #angelsmap) with Fairphone Open OS or custom ROM expertise, you could ask whether they would be able to have a look at your setup.

Two things which usually pop up regarding location on Android OSes without Google Apps and services are UnifiedNLP and Nominatim …

https://f-droid.org/packages/com.google.android.gms/

https://f-droid.org/packages/org.microg.nlp.backend.nominatim/

3 Likes

Hi AnotherElk

Thanks for your message.
I have to try it again for the usb device, with your advice.

What is very curious is my phone settings since : My phone Notifications are OFF(as supposed to be so) but bellow it is written: "At your request, Android is blocking this app’s notifications from appearing on this device (!) So what can I do now to “unlock” this?

For the geolocalisation app I will have a look at the links you sent me.
What worries me the most currently is that I cannot reply my calls…
Thanks again!

Stella

Just to make sure we are talking about the same thing here, this is what it looks like for me (/e/OS) …

You are saying for you the general notification switch at the top is set to Off, and it is supposed to be like this?

Or do I misunderstand?

You can make a screenshot by pressing Power and Vol - simultaneously (might need a few tries to get used to). To post it here, there’s an upload icon in the edit window.

Hi AnotherElk,

Ok my screen about my phone notifications does not look like yours at all ^^ :thinking:
No of course the general notification us not supposed to be set off ! ^^
Here is the screenshot. I will try to upload it here. Thx again

Hi again,

Actually I got another issue with my phone :sweat_smile:
I don’t know if it is related to the settings like the one with my phone notif, but I could not pay my phone package/subscription for a few weeks now. This is why the line is kind of restricted :confused: (another anoying issue then.)
I got an error message at the end of each payment, cancelling everything …
I don’t want to confuse you more with this so we’ll solve one issue after the other :wink: of course

Interesting. I just notice I can’t switch this setting to off.

The internet says it helped users to clear cache and storage of the Phone App. If you go back in the Settings from this screen there should be something like “Storage & cache”, where you can clear both for the Phone App.

Edit: Doesn’t work for me, though. Will need to investigate later.

Just checked on my FP2 with FPOS Android 10 and when its off its like this, no issues to toggle on or off (not sure if this is, because I have a second App installed)

however when you enable you have different options

So you cant enable it?

What about testing another phone App like the one from simple mobile tools?

2 Likes

Hi Yvonne,

Thanks for your advice AnotherElk because it worked but not completely!
I cleared both cache and storage and the notification is now on But when I called myself (with another phone) I still cannot see the page to reply! ://

And as on your second screenshot Yvonne, I have got the same options BUT I could not put on the incoming calls… :sweat_smile: :face_with_raised_eyebrow:

Strange…so you have in general notifications, allowed as well as notifications in general on the lock screen


And the phone app is allowed to “display over other apps”?

2 Likes

Hi,

Eventually it works! I saw the notif for the call !!
Thanks for all your help
I will try tomorrow for the rest :muscle:

1 Like