My FP2 bricked, help please

Hello,

My so loved Fairphone 2 bricked yesterday :sweat:

It started slowing down suddenly, I though maybe some app was causing trouble, so I decided to reboot. But it doesn’t boot anymore. Not even with power+vol up or down. If I try to charge, the led does not turn on neither. It doesn’t respond to any input. I don’t know what to do.

I was running Fairphone Open, and I updated to Android 9 some time ago and it was running smoothly.

I recently replaced the bottom module and it was working great also.

Any idea of what could I do? I had some photos and videos stored in the microSD, but do you think I could recover what was stored on the phone’s memory?

Thank you all in advance.

Did you try

  • holding the Power button for 15 seconds?
  • connecting it to a computer and see if it’s recognized in any way (e.g fastboot devices / adb devices (both require having fastboot and adb installed) / lsusb, in a terminal)?
  • removing the battery and putting it in again?
  • leaving the phone charging for some time?
  • another battery?
  • opening up the phone and reassembling it again?
  • contacting a #fairphoneangel for help and spare parts testing?
8 Likes

Hi soila and welcome to the community forum :slightly_smiling_face:

To Alex’s list, I’d just add:
Clean contacts (beginning with battery, SIM and SD card) with isopropyl (or high-percentage) alcohol. I recently resuscitated an original FP2 battery that wasn’t responding at all (well, hardly), by cleaning the battery contacts. Since then it’s worked so well I haven’t even put the more recent battery back in!

5 Likes

Hi,

Thank you very much @Alex.A and @OldRoutard for your advices.

I have tried all of these with no success:

  • holding the Power button for 15 seconds
  • removing the battery and putting it in again
  • leaving the phone charging for some time
  • opening up the phone and reassembling it again

However:
lsusb gave me this output: Bus 002 Device 005: ID 05c6:f006 Qualcomm, Inc.
So it seems it’s recognized. But I don’t know what to do next. It doesn’t appear as a device I can mount I my file explorer.
fastboot devices / adb devices showed an empty list

Now when I charge the FP2, the LED turns red, but after some time it turns off.

I will try cleaning the contacs as @OldRoutard suggested, and if that does’t work I will try with a new battery as soon as I can get one.

Thank you very much!

3 Likes

That’s exactly what I had with the old battery I’ve just put back in service.
Use a cotton bud. Moisten one end with alcohol, clean the contacts with it and dry them with the other end of the bud.
Good luck!

2 Likes

Right, so searching this ID tag on the forum leads me to the following topic:

On which I see:

Searched a little bit more, here’s what a qualcomm dev says about it:

The VID-05C6 PID-F006 is the low level code communicating with the PC for trickle charging power. This occurs when normal power is not provided and only the USB cable is connected. Applying AC power to the unit will cause the device to start booting.

Which would mean that your phone isn’t charging? I’m not sure I know how to interpret that. Perhaps your battery is dead and you should try a new one. Or hopefully perhaps, it’s only the contacts. Or it’s bricked (hopefully not).

Hi again,

I had no luck cleaning the contacts, but I managed to get another battery, and it was somehow involved. Now the charging animation appears and I’m able to boot to recovery menu.

Now lsusb output’s the next:
Bus 002 Device 003: ID 05c6:901d Qualcomm, Inc. FP2
and
Bus 002 Device 004: ID 18d1:d001 Google Inc. Nexus 4 (fastboot)

adb devices:
List of devices attached
1e8ff69b unauthorized

The recovery menu shows the next error message also:
E:Failed to clear BCB message: failed to fsync /dev/block/platform/msm_sdcc.l/by-name/pad: I/O error

Any idea on how to continue?

Thank you again! Your help is very appreciated :slight_smile:

Did you try to start #twrpwoflashing ? If it starts it might help to recover what was stored on your phone’s memory.

5 Likes

If you have no recent Backup of your data, you might want to give Volker’s suggestion a try before proceed.

Does it boot into recovery automatically? If that’s the case, I for one would try to check if the system-Partition got corrupted by executing the “Mount /system” option from the recovery menu. If the Recovery can mount the partition without any error, than that partition is probably good. If the partition does not mount without an error, I probably would consider reinstalling the whole system. (But that’s just me, probably there are smarter ways.)

If the system-partition can be mounted, I would proceed to wipe the cache-partition. This should ensure that it does not contain any corrupted data. Then I would give it try and see if it still boots into Recovery.

3 Likes

I recently dissembled my FP2, and discovered a lot of dust in the USB-charging plug. I cleaned it with a pair of fine tweezers. Now it charges fine again! Perhaps this helps you, too?

2 Likes

Are you interested on an used FP2? It is just laying around. It is fully functional. I would let it just for shipping cost and a symbolic price.

4 Likes

Well, a good way to go is to send it to an #fairphoneangel . They can help others with swapping parts for testing etc.

4 Likes

I would be interested, since my mic on my bottom module doesn’t work any longer…