My Fairphone does not accept SSL certificate of this forum

Hi,

For some reason, my Fairphone doesn’t seem to accept the SSL security certificate of this forum. I’ve tried with both the built-in Android Browser and Google Chrome. The built-in browser warns that the certificate is invalid, but allows me to continue. Google Chrome simply blocks the way and doesn’t let me continue. I haven’t tried other browsers on my phone yet. Both Google Chrome and Firefox on my desktop computer accept the certificate without problems.

Maybe it has something to do with a missing intermediate certificate, as described in the answer to this Stackoverflow question.

1 Like

@jerry I noticed this too today when I tried to connect to the forum from my phone. Works without issues on a desktop as you say.

I saw this yesterday as well! I couldn’t access the site at all with my Fairphone.

I have forwarded it to our developers to look into. Hope to resolve it today, we shall see.

1 Like

Looks to work properly on my phone now. Coincidence?

1 Like

It should all be fixed now! Closing this topic.