Mozilla UnifiedNlp Backend and battery usage

I’m on Fairphone Open 17.06.4. Three days ago, F-Droid made me update LocalGsmNlpBackend and since then, when checking the battery usage in the settings, I have noticed that Mozilla UnifiedNlp Backend always shows up (see screenshot). Before the update, I had never seen it up the list. Location is off and I barely use it. WiFi is off most of the time.
In Location recent permissions, I have:

  • contacts
  • dialer
  • WiFi Location Service
    I don’t think that I had any of those with Android 5.

Any idea what changed and if I can deactivate something?

WiFi is automatically turned on in background for network location (the one UnifiedNlp/microG provide).
Uncheck Settings > Wi-Fi > ⋮ > Advanced settings > Always search for networks (*) (or similar).

Does network location work fine? It may be missing some permissions and that may be causing the backend to retry again and again.

Also look in the backend preferences ((microG Settings >) UnifiedNlp Settings > Configure location backends > :gear: Mozilla Location Service) and play with the settings to evaluate energy consume.

(*) This is also good for your privacy, WiFi identities (MAC addresses) are tracked in some real world™ places like shopping centres.


Thanks for your quick answer. I’ll try to play with the settings.
I have no problem with location it works both with WiFi (energy saving mode) and with GPS. UnifiedNlp seems configured as it should. In the self-check, everything is checked.
Inside the backend preferences, in Mozilla UnifiedNlp Backend, I can only change settings for Data sources:

  • use Wi-Fi
  • use Cell
    Both are checked right now. I guess that I could uncheck them to see if there is a difference. I kept them checked to contribute to the database.

I don’t have anything like this. Is it really available on FP open? In my advanced settings, I miss this option (but it is available on other FP, as you can see in this post):

In Android 6, you have to search for “scanning” in the settings (click on the magnifying glass in the upper right corner) because the appropriate setting is hidden.

1 Like

Thanks for the tip! They were indeed under developer options and the box was already unchecked.
No Mozilla UnifiedNlp Backend in the battery usage this morning, maybe my playing with the GPS yesterday did the trick (it may have been the first time I used the GPS since the update and maybe I had to use before everything comes in place?). I’ll check these next days and report here.

1 Like

Oh, they’ve hidden that too from the user… damn Gobble!

I’m in 5.1 yet, that’s why I wrote those instructions.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.