Mobile Network not available


I received my Fairphone 2 three weeks ago but I can’t use it. When I try to make a call or send a sms, this message appears: “network not available”. I know that some people have this problem when they use two SIM cards but I precise that I use only one. I thought it was because my SIM card was too old so I ordered a new one. I receive it today but the problem is still there. I precise that when I put the SIM card in my old phone, it perfectly works. Can someone help me please? Thank you.

Do you have signal?

Yes I had a signal. I don’t understand why but today it works. I can not explain the origin of this problem and why it solved itself.

Maybe the APN settings weren’t correct and got pulled from the network in the meantime.

Anyhow, great that it works now :slightly_smiling:

Mostly the issue isn’t with the hardware, it might be because of your Android OS. Follow these tips, I hope your issue will get resolved:

1: Switch off your phone, take out its batter and sim card and insert them back.
2: Replace your battery with a new one.
3: Turn on/off airplane mode and then check out your mobile network.
4: Manually select mobile network.
5: Turn on roaming and check if it works.
6: Lastly, reset your phone or install a fresh firmware on your device. I hope any of these will for you, found these tips here, you can find more here and on other websites.

Hi! I have a similar problem, only that I only used it for one week before I lost network connection, and I have no signal.
I’ve tried everything in Hammad_Rs list, and the list he links to, I’ve also tried to boot my phone in recovery mode and reset the memory cache.

When I try to connect manually, I do find my mobile network provider, but when I try to register there, I get an error saying “Could not register at mobile network at this time, please try again later” or something like that. It’s the same for both of my sim cards, and for the simcard i borrowed. This has lasted for a few days now. Any ideas?

I’ve got a fairphone 2

Hi! I don’t know why but my problem solved itself few weeks ago. Since
this moment, it perfectly works but I can’t explain why…

Have a look at this thread… maybe you’re affected as well.