Mobile network connection issues -- protocol problems?

Hi,
during the last year, my FP2 (OpenOS) often dropped out of any mobile network/GSM connectivity. Outages were highly correlated with the mobile Cell it tried to connect to (I traced cell id from SatStat). Meanwhile, connections do work again around my home. There have been no software updates on the FP2, at least during the last months. So I concluded the back-and-forth must be related to changes on the network side – and perhaps to protocol compatibility issues. I took a log with a failed connection, it’s here:
https://www.staff.uni-marburg.de/~pauly/fp/log-gsm-fail.txt
I am familiar to general networking, but neither to GSM nor to Android internals.
So the log has been filtered only roughly in order not to destroy the relevant bits.
I think the relevant parts are around line 2747, which reads:

08-29 15:28:06.348 4656 4656 D CellBroadcastReceiver: Service state changed! 0 Full: 0 0 voice home data home congstar congstar 26201 congstar congstar 26201 (manual) UMTS UMTS CSS not supported -1 -1 RoamInd=-1 DefRoamInd=-1 EmergOnly=false IsDataRoamingFromRegistration=false Current state=1

Could someone tell from the log what exactly was going wrong, e.g. in relation to SS7?
If so, it might help developers to get better connectivity in situations like this.

Thank you, Martin

1 Like

As you mention 15:28:06:

08-29 15:27:48.993 3877 3877 I UpdaterService: Network connectivity potentially available.
08-29 15:27:48.993 1478 1719 D ConnectivityService: notifyType CAP_CHANGED for NetworkAgentInfo [WIFI () - 114]
08-29 15:27:48.995 4927 4927 D c : Quality of service changed from ONLINE to ONLINE
08-29 15:27:48.996 4927 4927 I c : Intent {
08-29 15:27:48.996 4927 4927 I c : ACTION: android.net.conn.CONNECTIVITY_CHANGE
08-29 15:27:48.996 4927 4927 I c : COMPONENT: null
08-29 15:27:48.996 4927 4927 I c : 4 EXTRAS:
08-29 15:27:48.996 4927 4927 I c : networkInfo: [type: WIFI[], state: CONNECTED/CONNECTED, reason: (unspecified), extra: “UMRnet_staff”, roaming: false, failover: false, isAvailable: true]
08-29 15:27:48.996 4927 4927 I c : networkType: 1
08-29 15:27:48.996 4927 4927 I c : inetCondition: 100
08-29 15:27:48.996 4927 4927 I c : extraInfo: “UMRnet_staff”
08-29 15:27:48.996 4927 4927 I c : }
08-29 15:27:49.008 4927 4927 D c : Quality of service changed from ONLINE to ONLINE

Shortly before your disconnect there was a WiFi available, but connection was not successful. Normally Android switches of GSM-Data-Services when you have WiFi.
Under Settings-> Developer-Settings you can enable things like “keep GSM-Data active even with WiFi”, “aggressively change networks” etc. - This will drain your battery quicker, though.

If you look for “ConnectivityService:” in the log you get all events where GSM connected/disconnected, service changed (UMTS/HSDPA/…), WiFi-connections (and loss), etc.

Hope that helps a bit.

2 Likes

Hi Drezil,
thanks for your hints. As it happens, I am the administrator of said WiFi network. For the test, I had simply walked out of the building in order to do the test well out of reach of any of our WiFi APs (forgot to turn off WiFi, though.) The point is:

  1. In the outage condition, I can’t even do any phone calls, neither place a call nor receive one.
  2. The much-reduced log (narrow time windows, grep’ed for “connectivity”) on
    https://www.staff.uni-marburg.de/~pauly/fp/log-gsm-fail-connectivity-only.txt
    does show the IP address change from WiFi (137.248.227.154, routable, issued by my own DHCP server) to UMTS (10.93.4.158, German D1 NAT address for mobile clients).
    But despite the UMTS IP adress, the connection was not able to transport even a ping packet.
    Only now and then I would receive a message about a “missed call” with some delay,
    but indeed over mobile connection.

Also in every day use, I had tried everything far off any WiFi, and with WiFi switched off.
As 3 weeks later it magically all started to work again, I think something in the interplay
of mobile client and network did not work out, but you would need the network-side logs
or more experience in testing mobile connections to get an idea what exactly fails.
(E.g: you could play with MTU and the like, how do you do this?)
BTW: Cell Id changed again when mobile communications started again, little suprising …

Other mobile phones around me never had this issue, including two FP2 with stock Android.
Should I ask in the development forum?

Cheers, Martin

If you have access to other phones that work: Do they use UMTS as well? Or do they switch to LTE or similar?

Maybe the connection of the rf-antenna is bad (popped off the connector). In my case i rarely get HSDPA+ and mostly fall down to 2G until i can replace my rf-cable (which i broke completely -.- ) - although the phone states good connectivity.

Step 11 Picture 3 shows the RF-Cable leading up to the antenna: https://de.ifixit.com/Teardown/Fairphone+2+Teardown/52523

Other than that i would not know where to look. When another FP2 works i would guess that it is indeed a hardware issue like a loose cable and not tied to software.

I had already checked for hardware issues like loose antenna cables.
There was no hint to that.

Other mobile phones around me never had this issue, including two FP2 with stock Android.
Meanwhile, I spoke to someone with a CAT smartphone (the ruggedized ones) who experienced similar problems around the same time, but not as bad.

If you have access to other phones that work: Do they use UMTS as well?
not sure, I think they have LTE. While changing preferred network from 3G to LTE
helped in an earlier case, right now my FP2 is happy in what Satstat reports to be
an LTE Cell-ID. Since Sep4, it has been working OK again.

Martin

Hello Martin!

I am having some similar problems.
My phone is laying an the table beside me, with WIFI connected and a connection to the mobile provider. But sometimes a caller cannot reach me. I am informed by SMS some minutes later, that I had a call.
I tested this behavour some minutes before - and I could not reach my phone either.

From your logs I have found that you are using congstar as a mobile provider. I am too.
I had my sim card exchanged last week - and this did not change anything.

Can I ask you if you are using a prepaid oder postpaid plan without LTE?
Mine is without LTE and I have found some informations on the net that some people have the problem that the provider wants to make a call over LTE (VoLTE), but the phone is having troubles gettings that.
Maybe this is your problem (alswell as mine) ?

Best regards
Alex

Sorry for ma late reply. This sounds really like a similar problem.
I think I will try to get an LTE SIM Card from someone nearby
and give it a test in my phone.
Right now it has gotten much better, though. The issue is only
their in certain mobile cells.

I get back to you as soon as I have some more information
Martin

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.