Mobile Data not working though SIM seems to function (SMS, calls)

I surprisingly couldn’t find my problem, so I hope I just missed a really stupid thing or there is another easy explanation.

A few days ago I set up my FP2 with the FPOSOS. Doing so mostly via Wifi today was the first day I was not connected to a wifi anymore and to my surprise my data connection does not seem to work at all in the FP2.
SMS I get and I can call and receive calls. I have only 1 sim in 1. slot.

I tried

  • disable/enable the card under SIM cards. Interestingly when opening the dialogue for SIM 1 there is no Numer in there, just the provider name (Telco) … should there be a number?
  • Under Data usage switch off and on Mobile data, set and untick mobile data limit
  • Under Mobile networks Switch on/off Data roaming, tested all preferred network types, change APN (is it normally necessary to choose this manually?), change network operator

Nothing changes. No letter showing up, no connection in the browser. Sometimes there is an exclamation mark next to the provider name, but no explanation why.

I did not retry yet to move the SIM out of the slot/into other slot or whatever, because I am a little bit worried to break somethign in the slot (and since calls/sms works I don’t see so much of a reason)

Anyone any ideas? Please tell me I forgot something totally stupid that solves this issue in a a second :confused:

Hi Sonne,
I’ve had exactly the same problem.
I found this post No mobile internet after “hard reset” from Irina… -and it solved the problem and fixed the data connection…
Thanks to Irina!



Wow that worked! Thanks so much