Mobile data not working completely (only basics like WhatsApp texts)

Since yesterday (01 October) morning I have had issues with my mobile data not working properly, as in I can send messages over data, like WhatsApp still works and some other things but loading a website just doesn’t see a connection and the indicator in the status bar always has the little cross on the data symbol.
I’ve tried with my old phone and it’s not an issue with the SIM, it works perfectly fine on the other phone.

I’ve sent in a similar message to FP support, but I thought I’d ask here to see if anyone else has a similar issue and/or ideas to help resolve it.

1 Like

My experience is that my FP4 has always been slow to reconnect in 4G when I don’t have access to a wifi. Often I have to switch to airplane mode until the provider name disappears, then disable airplane mode and the connection is made. When roaming it takes even longer and applications like Citymapper have a lot of trouble connecting, whereas in wifi there is no problem.
My previous FP2 did not have this kind of problem.

Strange, I’ve never had this kind of issue before and I think that what this is is something different to what you’re experiencing…

I thought it was a SIM/Carrier issue at first but it doesn’t seem to be that

How old is the SIM card? Just because its working in another phone, does not meant its not faulty…its strange that WA works…what are your settings? Do you have VoLTE enabled? Do you have 5G enabled? Did you check the APN settings?

May be a problem on the network. I recommend contacting the network operator, as well as having contacted FP support.

SIM card is brand new, got it under a month ago. Contract doesn’t support 5G. I’ll have a look at the apns if I can find some official ones online.

I called the provider and they basically said that there’s nothing they can do if my SIM works fine in another phone…

Unfortunately a response one often hears. Things don’t suddenly stop working for no reason and you’ve indicated no possible cause on your side. The fact that the SIM functions in another phone does not necessarily mean there’s no problem on the operator’s side and, as yvmuell said, it’s not really proof that there’s no problem with the SIM… Would you indicate which operator you use? There’s likely other user experience to be found.and we may be able to help with the APN.

I’m inclined to suspect a change in the operator’s DNS which their help-desk may not even know about. If you can bear to do a network reset it might help but let’s look at the APN first.

I’m using a subcontractor for German Vodafone.
Any help is greatly appreciated.

Of course it’s Vodafone :see_no_evil:

Try resetting the APN settings as the others have suggested:

1 Like

I reset the APN settings, but it doesn’t seem to have done anything, even after rebooting the phone twice…

Does anyone know where I might be able to find the APN setting so that I can input them manually? It does seem to be the same issue that was resolved this way in te other instances.

Also why do Vodafone and Fairphone not like each other? Is there a reason or is it arbitrary…

I just copied the APN settings that were default and switched out some things to check where the issue lied, and it seems to now work fine after removing “Authentication Type: PAP or CHAP” and setting to to “none”

Data now appears to work fine… How can we get this issue resolved more officially?

2 Likes

This happens regularly, see many threads if you search the forum for APN and Vodafone. I just set up a new FP4 on Vodafone Germany and had the problem as well. For me it has been stable after creating and switching to a new APN with the exact same settings as the default and it has worked since, mostly.

After a reboot I saw the issue reoccur more than once and then it was not fixed by switching between the default APN and the copy. However, in these cases it strangely helped to switch the Authentication setting in the copied APN from the default “PAP and CHAP” to “none”, and saving the APN. Then it connected and stayed connected after changing it back to “PAP and CHAP” and saving again. (Changing other settings in this way did not help. It is very weird).

I talked to the VF Germany hotline about it and they knew nothing about it although VF has an option to include an FP4 in contract packages. (However, they are not a very reliable hotline)

Just a few days ago I reported this issue to FP support as described in #contactsupport. It would help if everyone affected did the same. This is a bad experience for new FP owners on VF. (I read in other threads that it also seems to occur with O2 at least)

2 Likes

I got a software update yesterday (3rd) that fixed it on the default APN for me.

I hope this won’t happen again too often… (I’m not very hopeful)

1 Like

For O2 I think there was only some struggle at the very beginning, or did you read anything recent?

I use O2 and it worked out of the box by inserting the SIM card.

German VF and Fairphone have a long love and hate story latest since the FP3. Most worse issues occurred on VF while other carrier worked well.

It’s well possible that this was solved for O2, I didn’t read it that extensively after I found out what the problem was