Mobile data connection not working

I have a FP1 without working mobile data connection (WIFI works fine). After checking all the settings with my provider, FP support recommended sending the phone in for repair (I don’t know if that makes any sense - does the mobile data connection have hardware separate from voice connection? But that’s what they recommended).

Now, I created an account on the returns portal, and simply cannot log in. I’m always returned to the login page without error message.

I contacted support about this, but haven’t received anything beyond the automatic “we’ve got your request” within one week.

What can I do?

BTW I would much prefer a local repair option in Austria. But I guess that would mean forfeiting warranty.

Support appears to be very busy so it could take a while for them to answer. Calling them (details at the bottom of the support page) might work to speed things up. In the meantime, have you tried using a different browser (or clearing the browser cache)? I’ve not heard of issues with the returns portal before (at least I can’t remember reading any posts here), so it could also just be a glitch.


If calling works I would find it is very unlikely that it is a hardware problem (hence replacing / fixing won’t work).
Do you have more information about your provider and can you share their setting page?

It does sound unlikely. Here are the facts:

  1. I have mobile connection and calling works normally - just data connection does not work
  2. I do have data connection enabled
  3. I have used my data connection for the past year without issues. My settings have not changed, and my provider has assured me that they have not changed anything in their system
  4. I went through my settings one by one with my provider, and they are correct (see also
  5. The provider also has checked that the data connection works from their side
  6. My SIM card had working data connection with my wife’s phone
  7. Just to be sure, I had the SIM card replaced. No change
  8. It’s not just the browser - no application can get data connection

Just in case, since recently we discovered an issue with national roaming and the German provider Simyo, could you please allow “data when roaming” to see if it has to do with that…

1 Like


You just saved me a lot of trouble! Thank you!

1 Like

It works??? Really?

I just renamed your topic, so it reflects the content/solution.

It’s not an acceptable solution, though. I live in Austria as well and in many areas nearby the border the phone connects to a foreign cell because the local network is weak or missing. Having “allow data when roaming” switched on may lead to enormous costs this way (drei charges 0,24 euros per Mb).

Yes, I know that, but at least we found out why Asperamanca wasn’t able to get an internet connection.

There have been fixes for national roaming issues with other providers included in former system updates for the FP1.

I don’t know if there’s an easier workaround, but maybe switching roaming off in the settings of the provider’s web page could help at least to avoid unwanted costs.

You may have a look at this topic:

So…it didn’t quite end there.
The data roaming was a false hope. I must have hit a page that was still in browser cache, or something. It didn’t work after all.

Then I went through all the settings again. And I found a sub-sub-sub menu I’ve never been to before: The detail settings for the access point. And there the data source was specified as LTE. And I changed it back to default (Unspecified), and it worked!

Now this is what I suspect had happened:
I regularly have issues with my touchscreen while calling. My ear seems to activate it, and I open all kinds of strange menus. I’ve even activated airplane mode several times during a call (that’s something you tend to notice quickly, at least).
Now I suspect, I once opened this sub-sub-sub menu, scrolled down and changed that one setting. The provider’s support probably never bothered to check those settings, because the default are fine - and who in their right mind would change settings randomly, when everything works fine?
Well, I’m going to tell them to extend their checklists on “data connection issues” in this regard.

Thanks to all for your suggestions and comments!