MMS not working

It is not possible to receive or send pictures(MMS) from the standard SMS/MMS application. When I try to send, the application tells me, that it is sending, but after a long moment it stops and nothing happens.When other persons is sending a picture to me, I get the message, but not the picture, when I am trying to press teh download-button. I have tried another SMS/MMS application (Google Messanger) with the same result. The normal SMS-function with pure text is working perfect.
I think it has something to do with the settings in my FP2 concerning pictures, but I du not know what to look for.

There are two possibilities.

  • Did you check your settings for MMS?
  • It could the same problem which other apps have and can be solved by the following workaround:
    Re-enable Privacy Impact by unticking the option found at:
    Settings > Sound & Notifications > Privacy Impact

The problem still consist after re-enabled Privacy Impact
I am using the same phonecompagny as before when using my old iPhone and here the MMS worked fine, that indicates that the phonecompagny-setting is correct.
Is there a MMS setting in the FP2 ?

Yes, there is. It’s in the APN of your phonecompany. You have two lines, MMS proxy and MMS port.
Can you find them? If not, who is your phonecompany.

My phonecompagny is danish Coop Mobile (using the system from an other big danish phonecompagy -TDC).
I found a solution on the internet serching for the problem, the same as you have recommend.
A workaround for Nexsus 6 is also working for the FP2. I am using the first workaround (using Hangouts insted of the standard SMS/MMS-applicaton). I do not dare change the APNs parameters.
Here is a link to the article describing the problem:

Thanks for participation in the problemsolving…

1 Like