Missing H.264 Acceleration after Marshmallow Upgrade


with Android 5.1 on Fairphone 2 it was very easy to play 1080p even 4K content (encoded with H.264 codec).

After the marshmallow upgrade (Android 6.0.1), my MX Player App says that there is no hardware acceleration for H.264 anymore!

VLC Player has also problems to play some 1080p content now (with Android 5.1 everything was smooth)

Can you confirm this problem? Or do you have a solution?

Best Regards


I’m afraid I can confirm this, 1080p lags in youtube on my phone. I never verified whether 1080p h264 (or youtube in general) worked on 5.1.
Did you try reporting this in the bugtracker? That’s where all the devs hang out, not on the forums unfortunately!

1 Like

In the YouTube APP, 1080p runs fine, for me. But I tested with Big Buck Bunny from here:
1080p with 60fps lags severely, 30fps runs fine. Let me know if I should open a Ticket.

I also tried this webm file: https://cloud.blender.org/p/glass-half/5645e616c379cf0386babbf7

Runs fine.

1 Like

Well, I can only tell about my MX Player experience.
I wanted to test the codec features of Snapdragon 801, so with Android 5.1 it was even possible to play 4K H.264 content an the Fairphone 2 (of course downscale to 1080p). The HW+ Decoder in MX Player has also displayed support for H.264.

After upgrade to Andoird 6.0.1, MX Player does not show H.264 Support in the HW+ Decoder anymore. I can play most 1080p content, but it is not that smooth like it was under Android 5.1.

It would be great if you would file a bug report in the link I pasted up there. That way they can contact you for further information if required. I suspect it might simply be a missing firmware file or something vaguely similar. However, I have neither the MX player nor video files to test it with, so it’d be more convenient for you to report.

Done (bug report), thank you.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.