MicroSD-Card does not appear anymore

Dear all,

I have a problem with my microSD. After my phone showed me regularly messages mounting the sdcard and a message as if I was putting it out. I didn’t care so much, as I didn’t really need the Card. But now, as the phone storage is filling up, I wanted to put some data on the sd… Which I cannot access with the phone. I tried with my Laptop which recognizes the Card and I can also put data on it. The phone doesnt show any reaction when i put the card in.

Does anyone have a hint what to do? Or is the slot broken?

Best Leon

Dear Leon,

I have the same problem. Suddenly (I think after the new Update) my FP2 showed a message about mounting my SD-Card and to format it. A few times I ignored it, switched off and on the FP2 and it was okay. But since a few days my FP2 just wanted to format the SD and I can’t use my Card anymore. I tried on the PC with the same results as you. Then I bought a new SD (the old one was very old), but my FP2 didn’t even find the new SD-Card. It is a new Samsung EvoPlus 128 GB microSDXC Card.
I contacted the support. When I have an answer, I let you know about it.

Sorry about my english :wink: I hope you understand what I want to say :slight_smile:

Best regards
Marqs

Great thank you! Today I saw the message on the phone again that SD-Card was detected… but directly disappeared again.

If you have access to a computer, backup any data on the card, and then format it with the FAT32 file system (quick format is sufficient).
FAT32 is old, but it is still the most compatible file system for use in electronic devices.

When using Windows for this, modern Windows versions limit formatting FAT32 to a size of 32 GB or don’t like to format FAT32 at all … I used a little program I found here without problems.

If there’s no important data on the card, you can keep it in the phone and format it using the TWRP recovery (I’m using TWRP 3.2.3-0 currently):

Boot into TWRP by keeping Volume + pressed when starting or rebooting the phone.
In TWRP: Wipe - Advanced Wipe - select “Micro SD card” - Repair or Change File System - Change File System - FAT - Swipe to Change

1 Like

Thanks for this advice. There is a strange problem now here. In the advanced wipe it shows me now that current file System is vfat. but down of this it says:
Present: No --> Does this mean that the SD-Card ist somehow not detected?
Size: 30428 MB --> Strange because this is a 32 GB Card.
Also the rest of the Information is correct…

Any ideas what to do.

Ok solved it somehow. I think it was a loose contact…. now I have the second paper clip in my phone after the battery :smiley:

This is normal.

Storage vendors may calculate on a base of 1 kByte = 1.000 Byte (notice the small “k”) and 1 GByte = 1.000 * 1.000 * 1 kByte (notice how it isn’t a small “g” then), whereas computer tech being based on the binary system calculates on a base of 1 KByte = 1.024 (= 2 to the power of 10) Byte and 1 GByte = 1.024 * 1.024 * 1 KByte.

Another factor in this is that any kind of file system needs to reserve a small chunk of the storage space for its own organizational needs.

So, 32 GB of theoretical storage according to the vendor never ever will be reported as 32.000 MB free storage according to any computer tech.

1 Like

To be entirely precise, 1 GByte would equal to 1.000 * 1 MByte. :slight_smile:
For more details and another variant denoting the binary factors with an additional “i”, e.g. 1 GiB (“GibiByte”) = 1.024 MiB, see https://en.wikipedia.org/wiki/Binary_prefix.

Just as a side note: I remember this confusion was there for quite long, at least since a 3.5" HD diskette was referred to as 1.44 MB when actually the capacity was only 1.38 MiB (where 1.44 MB was calculated as 1.000 * 1.440 KiB, becasue the capacity in Bytes was something around 1.480.000 Bytes). But I started to drift away into the past…

1 Like

Argh … thanks. Corrected.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.