Microphone disconnected unless I press on screen

I noticed some time ago that my microphone did not always work.

At first I thought that it was a matter of restarting the phone or making my call again.

But suddenly it started happening all the time and it wouldn’t go away. Then by chance I noticed that if I pressed the screen a bit where the microphone is people were able to hear me.

I then decided to open the phone and unscrew the microphone and screw it back in following the online instructions. Sadly, this did not fix it.
When the cover was off, I also noticed that the parts attached behind the screen do not look parallel to it. There is a small gap between them, so it looks like the plastic has warped a bit… and that is probably the cause of my microphone being disconnected unless I press…

If anyone has had a similar problem, I’d be glad to know if you found a solution other than ordering half a new phone…
I have not contacted FP2 directly yet.

I see that someone else had a similar issue here, but it wasn’t solved either.

You should contact them directly now as you need some replacement parts.


I have a spare microphone module which I could borrow you, so you could try if it is the module or the phone “base”.


How would I borrow your microphone? :thinking:

Send me a PM, we could send it back and forth.

Where do you live?

Having the same problem, yesterday everything worked fine, today its not.
Not sure maybe its a update problem (installed the latest firmware today)

Mic works in loudspeaker mode, not in sound recorder or normal phone mode.
Sometimes it works if i press on the bottom right corner of the phone for a short while (some seconds)

Its quite stupid, phone starts breaking (also my cover splits up) shortly before the two year warranty ends.
What is next? A friend of mine had similiar problems a while back and i proudly said, mine works great, but now i’m not to sure.

Also whats the normal support response time? Waiting for a ticket for 6 days now.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.