May have bricked phone, need help!

I was using the 4.4 alpha but battery life was awful, so I reverted back to 4.2 (using a custom recovery). I noticed the GPS bug that was eating my battery life was still there, so I decided to fully format the phone, data, caches and system. But when I tried to install the 4.4 .zip again (since the bug was not related to the build, I reckoned I could use it again), the phone just rebooted.

Now I’m stuck in a unrooted recovery that returns “Installation Aborted” when I try to install a flashable image or “Invalid Partition Setting” when I try to install 4.4.

I tried flashing a new recovery through ADB and Fastboot but it also only returns errors.


There’s always the procedure over on XDA for hard-bricked phones, though you may need to look for the tools required somewhere else. Installing binary images (listed on the downloads page as flashable images) via recovery does not work, so if you do want to try again via recovery make sure to use the update zip file (presumably the one with the updated storage layout).

Upgrading the firmware through SP Flash Tool worked! But the GPS issue still happens… and on a 110% fresh install…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.