Manually reflashing the fairphone


after upgrading my fairphone to FP OS 1.6 and performing the partition update, I wanted to flash the the FP OS 1.6 manually again, as this is [or so far was] the only way to get rid of the google apps. Unfortunately this fails (it just says failed, no specific error message). Now the phone doesn’t boot anymore, it gets stuck in the boot process, showing the blue screen with the fairphone logo for eternity (bluescreen in relation to software problems sounds familiar btw ;-)). Could you please help?

I also tried to flash the FP OS 1.6 manually again. And yes I got the no specific error message.
Could you try:
Turn your phone OFF
Press and hold the Volume Up and the Power button combined until you see the green Android robot on the screen
Press the ON/OFF button shortly and the “Android System Recovery” screen with orange text will appear
And now try to flash it again (yes I know it won’t succeed)
After you get the error message
Select "Reboot system now"
Confirm with the Volume Up button
Now your Fairphone will boot up normally
At least my phone did.

Hi, thx for your reply. Sadly that doesn’t work for mine, still gets stuck. Maybe the update doesn’t work anymore due to the changed partition layout (so the update script can’t find the places tho copy the system files into). On the other hand the scatter.txt (which as far as I know defines the partition layout) is the same in both the partition-update .zip and the FP OS1.6 .zip. (And yes, the .zip files aren’t corrupted, md5sum is correct)

I just succeeded to fix my bricked Fairphone thanks to the amazing people in the xda community following the guide at the bottom of this article.

I am pretty sure now that the problems are caused by the missmatching partition layout. When I just tried to flash the phone with the flash tool I got an error that the flash layout doesn’t match. When I replaced the scatter file with the one from the binaries for the 2nd batch FP (which has the new partition layout by defaut (?)), I was abled to flash it (so the partition layout matched). Unfortunately the phone did’t boot. I had to format the flash memory and afterwards I could flash the original binary file from the download section for the 1st batch FP. So now it works and I have the internal/phone storage layout from before doing the partion update (that I actually prefer). So please FP-Team, let us have a recovery .zip file for the 1st batch FP with Version 1.6 and the new partition layout, thx.

So far I recommend 1st batch FP owners not to do the partition update until a suitable recovery is available.

By the way, is it possible that you release the music from the small introduction video clip (the one saying “thank you” in many languages) as an audio file, so we can use it as a FP special ringtone?


Thanks @Elchi for finding this out. I suspect you are correct that it is the partition layout that has caused this. It wonder if you’d tried to update again to V1.6 via the Fairphone OS Updater app whether you would have had this problem or not. I believe the app knows the difference between the two FP versions

I’ll flag this up to the support team anyway so we should be able to get an official answer/updated recovery files or guidance

Hi @Chris_R . Yes, the updater app knows the difference and installs the right version, but it doesn’t remove the gapps. If you want that or something goes wrong in the updating process one would need a proper recovery.

Point taken :wink: but thanks for confirming the app works as expected

I’ve flagged this up to the support team

Hi, thanks for taking care. I just noticed my posts may have sound a bit rude. A lot of things went wrong when I was getting my phone back to life (not exclusiveliy FP-related), so I was kind of pissed, but it had nothing to do with the FP-team :wink: I think in general the FP-team has done a good job and I totally concur with focusing on the majority of users who just want a worry-free update.

Thanks, @Elchi for that detailed information. Can you please give some more details on how you reformated flash memory? Do you know of a way to do that on Linux?

PS: I totally agree on the music topic.

Hi everyone,

I’ve found an easier solution combining all the information gathered in this thread.

Short version:
The recovery image is the same as the image for the second batch Fairphone found in the download section.

Long version:

@Elchi says

Maybe the update doesn’t work anymore due to the changed partition layout


So please FP-Team, let us have a recovery .zip file for the 1st batch FP with Version 1.6 and the new partition layout

Unfortunately there is no download link for such a update/recovery archive, as Elchi already found out.

But @Chris_R suggests that the Fairphone Updater app knows the difference between the different partition layouts and downloads the correct recovery archive.

I believe the app knows the difference between the two FP versions

@Elchi responds by noting that …

the updater app knows the difference and installs the right version, but it doesn’t remove the gapps.

So what I did is, I let the Fairphone Updater app download the correct recovery archive but didn’t press the install button. Instead I used the archive downloaded to /storage/sdcard1/updater/ on the phone and manually flashed this image. Voilá, flashing works and Google Apps are gone.

While searching for that archive, I also stumbled upon the location where Fairphone Updater app stores download links of recovery images. /storage/sdcard1/updater/ holds a XML file with several download links. One of them is exactly the image we need. The given (and verified) download link is Coincidentally this is exactly the same file advertised as the recovery image for the second batch Fairphone found at the download section and the manual recovery Howto.

That means, we already had a “proper recovery” (which @Elchi requests) but we didn’t know it was there because the download section doesn’t tell anyone that it can be used for both batches of the Fairphone.

Hi, you can follow the guide in the given link. If you haven’t done the partition update yet, thats all you need. As you need the flash tool provided by the chipset manufacturer (Mediatek), I don’t think there is a way to do it on linux as it is avaliable for Windows only, and so are the drivers. You can try wine or a VM, but I would not recommend that as with those progs hardware level communication is a critical thing and if anything goes wrong there’s a good chance to brick your FP for eternity. I too had to install a dedicated Windows system just for this purpose (which is one of the reasons I was pissed^^ ), but I afaik it’s the only way.

The process itself looks scary at first, but it is basically very easy ;-). The guide from the xda forum already is pretty much detailed, it’s just a few steps. If you already did the partition update or you are facing any difficulties/uncertainties, just ask. Maybe after flashing your device the IMEI nubers got lost, inhibiting the phone from connecting to gsm network. In that case this is what you need. The engineer mode app is already installed on the fairphone and can be started by dialing *#*#3646633#*#*.

1 Like

ok, you were faster :wink: Great job!

Are you sure it is exactly the same (md5sum or such), as the 2nd batch FP has a slightly different chipset. I flashed the binary files for the 2nd batch FP to my 1st batch FP and that didn’t work (bootloop).

Yes, I was worried about the chipset as well. But apparently they use the same image for both (either because it doesn’t make a difference or because the software is clever enough to abstract the differences away).

I’m positive that it’s the same archive because I checked the md5sum. I’m also positive that it works because I flashed it and my Fairphone (1st batch) still works. Not bootloops or anything similar.

That said: Of course I can only vouche for my phone and the specific case that I updated to 1.6 earlier already and chose to repartition the internal memory.

Thanks again for the detailed help. I’m still glad I don’t need it anymore :wink:

That’s great news. There are many other reasons that can have caused my trouble with the 2nd batch binaries. Or maybe, as you said, the recovery somehow distiguishes the chipset, which the binaries of course could not. Btw, I found the startup video in the recovery and extracted the soundtrack. @anon90052001, is it subject to sime kind of copyright or am I allowed to offer a download? However, it can be found in the /res/raw directory of the FairPhoneHome.apk (in /system/app/).

Hi @Elchi,

If all this is getting too advanced (it certainly is beyond my average user experience) then I would write directly to support (

The introductory video/song is subject to staying where it is I think :slight_smile: I wouldn’t mess with it. I realize now, @Elchi, that maybe I misunderstood about your question with the intro song - there is some copyright to it that we can’t share outside this format.

I softbricked my Fairphone[1st edition]…
I have updated it to v1.6 from Fairphone updater app and also unified the partitions. Then I installed a Bold font with “iFont” app and when it reseted it never started…
It stuck in the blue boot screen with the Fairphone logo for Eternity…
I tried to make Factory reset in recovery mode but nothing. Then I tried to apply update from sd card with almost every fairphone version and showed me the following message “Installation aborted, error”. What do you recommend me in order to make my fairphone alive again???

@toyotis - you can restore your Fairphone by following the ‘How to restore Fairphone if you totally bricked it’ guide provided on the XDA forum

Make sure you use the correct binaries for your phone - as you have the 1st edition, you need the FP1 files and not FP1U


So you could just Download the latest recovery for the FP1U and flash in Recovery Mode via sd-card/ADB.


What do you mean by “almost”? :wink: If you already tried the FP1U-Recovery, and still get the error message, you will indeed have to go the way proposed by @Chris_R

  1. Where can I find-download the latest recovery for the FP1U ?
  2. I started the ‘How to restore Fairphone if you totally bricked it’ guide provided on the XDA forum using Fairphone_1.6_Cherry_1G13G_Image_31-07-2014 and the Smart Phone Flash Tool in Windows gives me the message:
    PMT changed for the ROM; it must be downloaded.

So, how can I move on??

First you have to download the file Fairphone_1.6_Cherry_1G13G_Image_31-07-2014 to your computer.