"Make calls with" reverts to SIM 1 after reboot if SIP account is configured in Phone app

How to reproduce:

  • Insert one SIM card (or, if two SIM cards are inserted, disable SIM 2 in Settings / SIM cards).
  • In Phone app, add a SIP account (Settings / Call settings / Phone account settings / SIP accounts).
  • Still in Phone app, go to Settings / Call settings / Phone account settings and set Make calls with to Ask first.
  • Reboot phone.
  • Again, in Phone app, go to Settings / Call settings / Phone account settings.
  • Make calls with will have reverted to SIM 1. You can set it to Ask first again, but this will last only until the next reboot.

This seems to be a side effect of the dual SIM feature. The SIM card configured as Preferred SIM for calls in Settings / SIM cards seems to override the setting made in the Phone app after a reboot.

If a moderator can reproduce this, please add to the list of known bugs. You probably don’t need a real SIP account for testing this, I guess you can just enter any Username / Password / Server.


Can anyone reproduce this?

[Poll name=“1”]

  • Yes, the same happens to me too
  • No, I can’t reproduce this
    [/Poll]
    Poll added by @paulakreuzer

Sorry to wake the dead, but this is still not fixed in 1.6.2.

Everyone who uses only one SIM card, has a SIP account configured and wants to use “Ask first” (or the SIP account, actually) for calls should be affected. Is there really no one out of 11000+ forum members who has that configuration?

(For me it’s not an issue anymore because I now use two SIM cards.)

2 Likes

I have the same problem.

Just configured my FP2’s telephone app to use it with my fixed network router / telephone system (AVM Fritz!box 7490), which works at least for outgoing calls (more testing to be done). Now I hopefully can use my FP2 as a wireless phone at home with my fixed network number. But after a reboot of my FP2 the setting “Ask first” is gone and my SIM1-provider is set under “Make calls with” (which isn’t translated to german like some more settings by the way).

Seems that I have to set this manually after every reboot as I also still have to for time and date.
I have FP Open OS 16.11.0 and use only 1 SIM card.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.