English

🇬🇧 🇩🇪 Magisk Update to 8.0.0 and ctsProfil

I wonder why there is no option offered for the FP3.
I didn’t try that any further and wait until an FP3 version can be selected under “props”.

Steven

I had tried FP2, which made the situation worse after a restart. SafetyNet Check then had both red. After that I took with props option 2
2 - Force BASIC key attestation (active)
He asked me if FP3 was correct and I answered yes and after that after reboot the SavetyNetCheck worked with everything green.

1 Like

Many thx! It works! :grin:

Steven

Notice if an automatic update to FP3-REL-Q-3.A.0054 fails with such a routed phone. Download FP3-REL-Q-3.A.0054-20200929.092252-user-fastbootimage.7z then unzip with 7z - put Fairphone3 in fastboot and FP3_flashall
then it is in the new version. Magisk will then no longer work. So after successful flashing go into fastboot again. Then fastboot boot twrp-3.4.0-0-FP3.img
Enter its pin on the screen to decrypt the partition.
adb push Magisk-v21.0.zip /sdcard/Download/
Install Magisk with twrp and maybe even props
After the restart everything seems to be ok, but apps at least my targobankapp recognize the phone as rooted, so it is not so, execute su props and force as above and of course hide again. After that everything was ok again.

1 Like

:smiley:

Where do you get that? It’s not on ✏ FP3 OS updates - changelog & OTA links so far.

From https://support.fairphone.com/hc/en-us/articles/360048050332
there is a link to https://fileshare.fairphone.com/link/aDk3NhugysKaHI7zX52sCz/download/FP3-REL-Q-3.A.0054-20200929.092252-user-fastbootimage.7z

1 Like

Since the update (incl. props/BASIC + reboot), the check fails competely, including the basicIntegrity. It also shows “evalType: HARDWARE”. Other than that, root and everything related to it seems to work fine.
Update: After another reboot, the evalType is BASIC again, but it’s still failing.

I had to switch form stable to beta channel for magisk (v21 instead of v20.4) to get the props and busybox modules working. Forcing basic mode seems to work for me now.

Magisk v21.0 final has been out since Oct 3rd:

Magisk Manager does stick with v20.4 by default though

Here is the latest official version of Magisk Manager available, currently v8.0.2:

[https://github.com/topjohnwu/Magisk/releases/download/v21.0/Magisk-v21.0.zip](Magisk 21.0) and https://twrp.me/site/update/2020/06/24/twrp-3.4.0-0-released.html Is that what I used.

I used 21.0 first. Since the Manager started showing only 20.4 as latest, I thought maybe there’s been some issue, so they’ve gone back. So I tried again with 20.4. Didn’t make any noticable difference. Except for “props” showing “FP2” as “loaded value” with 21.0 instead of “FP3” - but only for the first call, after a reboot, it’s FP3 as well.
Right now, I’m back to 21.0, props with “Basic”, and all tests failing.

see Magisk Update to 8.0.0 and ctsProfil

That’s exactly what I did. Doesn’t work with the current firmware on my phone. I even dis- and reenabled the basic key.

Hmm, then I do not know why it does not work. But I did these steps with the firmeware before and then just repeated them with the new firmware. Maybe this makes the difference.

Nope, no difference there as well. With the previous firmware all worked fined.
Seems like I just have to wait if a future Magisk (or firmware?) update will fix it. Luckily the few apps that’d need it aren’t that important to me.

After a boot in safety mode, it suddenly didn’t want to either. I had to use

props -s

to get it to work again, I had to reactivate the scripts that were switched off and enable props in Magisc again.

Do you mean “Background boot scripts”? They’ve been disabled on my device as well, though I never had a boot in safety mode.
However, enabling didn’t help.
What’s also strange: If I dis- and reenable enforced basic auth, it shows “FP3” as value, but after reboot, it’s set to “FP2”. But setting “FP3” as custom value doesn’t help as well.