Lost internet yesterday even with 4G present - any ideas?


It is weird. Hopefully it is not the combination of Fairphone and Ecotalk as both companies are doing the right thing for the world - I don’t want to change either but it is the 3rd issue within a year.

So just to ensure we talk about the same setting

This is what I meant

So beside the setting, could you get mobile data with the other SIM and was it from a different provider?

no data from other SIM - same provider though.

Did you check these settings: https://www.ecotalk.co.uk/help/getting-started/apn-settings

1 Like

Yes, all identical to my phone.

1 Like

In your screenshot

  • 4G means 4G is available on the cellular network connection.
  • The triangle indicates signal strength (pretty low in this case).
  • The little cross in the triangle usually means that the mobile data connection is switched off or unavailable, but in that case normally you wouldn’t see “4G” mentioned. Seeing the two together is strange and I don’t remember ever having seen that.
    I would interpret that as meaning “4G is available on the cell but signal too weak for a data connection” but that’s just guesswork.

Tomorrow when you contact ecotalk support, make sure you describe these symbols exactly – and that they understand.

You might go to the following setting:
Settings > Network and Internet > Mobile network > Advanced > Preferred network type,
and instead of Automatic (4G/3G/2G) which is the normal value for this setting, test the other options.in descending order.

1 Like

Thank you - all tried and still same, no internet via:
google calendar

but can still use:

The same has happened to my phone and my wife’s. I was assuming it was the last Android update. I haven’t found a solution yet

1 Like

If anyone knows anything about the latest Android update that might be helpful

1 Like

Topics in the forum : Search results for '0016.6' - Fairphone Community Forum

Yes. These services use a different type of cellular connection, not regular Internet as provided by Wi-Fi or mobile data.

Whatsapp does not use mobile data? Since when is this the case?

Does your provider also use EE network as Ecotalk? Have you tried the troubleshoots mentioned above? Like resetting APN to default?

1 Like

Oops, going too fast. Be interesting to see whether anything more than text can be sent (photo for e.g.)

Yes, EE. Have tried all of the above - thank you everyone! No solution yet.

We are also with Ecotalk. As you say, hope it’s not that combo that’s the issue, but I think it would be EE rather than ecotalk as they just buy into their network I think

1 Like

I have just spoken to ecotalk. They confirm it is a known issue and that it should be resolved for all users tomorrow. They could not state if it was Ecotalk or Fairphone issue but the combination of the 2 has caused the issue.


Yes, likely EE as it is their network.

Thanks for the update. I’m glad to hear its being resolved

Unlikely to be resolved to morrow if it was a Fairphone issue as it would require changes to the OS and a whole new update.