Locking the Bootloader after installing eOS caused Fastboot Mode loop

Hi everybody,

I just tried to install the e/OS on my Fairphone 4, but unfortunately this caused the phone to stay in a Fastboot Mode loop.

I followed the instructions from https://doc.e.foundation/devices/FP4/install until the last step where I had to lock the bootloader again. Until then everything worked. However, the very last step fastboot flashing lock caused the problem. My phone said after this step that it is corrupt. Since then the phone is stuck in the FastBoot Mode. No matter which option I choose the phone reboots to FastBoot Mode, even Power off results in a restart.

When the phone is not connect via USB-C to the computer Power off works.

Unlocking the bootloader fastboot flashing unlock and fastboot flashing unlock_critical didn’t change anything.

I have read that there are others who are dealing with the same issue. FP4 Device corrupted and won't boot in locked mode after fresh /e/OS install - Fairphone - /e/ community

However, there is not a real solution given. Is there any hope that this can be fixed? Can reinstalling Fairphone OS fix this? Does anyone has experience with this? Does Fairphone offer support? What is the correct way to contact them?

Best regards,


That guide is harmful for not telling users to test functionality before locking and to ensure the OEM unlocking toggle is enabled beforehand.

Furthermore there is no reason /e/OS isn’t including the firmware, here is an example for them to use: crosshatch · master · DivestOS Mobile / firmware-empty · GitLab

I agree.

I don’t understand what you want to say with this. I visited the link, but I don’t know what to do with that.

So did you disable OEM unlock in the developer settings?

What does this mean, you cannot unlock the bootloader again? Is there any error showing?

Can you change the slot?

Yes at the beginning of the whole procedure, but still with the original Fairphone OS. After the installation of e/OS I didn’t do anything with e/OS because I just followed the instruction on the manual page, which told me to lock the bootloader.

I can unlock the bootloader, but the phone still does not boot normally. I could change the slot to b

user@computer IMG-e-0 % fastboot getvar current-slot
current-slot: a
Finished. Total time: 0.004s
user@computer IMG-e-0 % fastboot --set-active=b
Setting current slot to 'b'                        OKAY [  0.054s]
Finished. Total time: 0.056s

Then I after trying to start, I got the dialog that my boot loader is unlocked and after that I ended up in the FastBoot Mode again. So I saw one more dialog but I am still stuck.

Please try changing it to the other slo

You cannot switch slots when locked.

but I don’t know what to do with that.

The /e/OS developers should be including something like that in their code.

I can unlock the bootloader

That is good! It is recoverable then. You should be able to try the steps again or flash stock again.

This means, when I run all the commands from the manual again, but don’t try to lock the bootloader afterwards there is a chance that the phone will boot again. Or when I install the original Fairphone OS I can revert everything?

Ok so I think OEM unlock is enabled and your bootloader is unlocked, which is good. Maybe try to install e/OS again, but

Yes but it was not clear if locked or not…

Thats confusing here…

Ok it seems like it is working now. thank you very much for your support.
I realised that during the installation there was the following message
******** Did you mean to fastboot format this ext4 partition?.
The message embedded with context:

Sending 'core_nhlos_b' (111772 KB)                 OKAY [  2.407s]
Writing 'core_nhlos_b'                             OKAY [  0.526s]
Finished. Total time: 2.941s
******** Did you mean to fastboot format this ext4 partition?
Erasing 'userdata'                                 OKAY [  0.179s]
Finished. Total time: 0.185s

The same message also appeared the first time but I didn’t notice that. I don’t know whether this is normal or not. However, this time (without locking the bootloader) the phone boots and works as expected.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.