Living without Google 2.0 - A Google free FP2

What are you missing or trying to do? Perhaps we can help …

If you could elaborate what confuses you, I’d be willing to help. Personally I love K-9 because it has nearly all features of a true desktop email client.

And if you want to know what Microsoft does with your emails, check their terms of service.


Google Maps works pretty well in the browser, if that helps.

Yes, I would say so.

Not one I know of, sadly.


@AnotherElk, @StephanK and @ben thank you so much for your replies. So here the points:

OsmAnd: It takes a really long time to load the map if I move city or even neighbourhood, I cannot enter a street AND a number for an address, it only lets me choose a crossroads on that street (which I don’t necessarily know most of the times), and when looking for something that isn’t a precise address (such as a restaurant, or a touristic site) it often doesn’t find it and gives me completely unrelated results (e.g. a bar with the same name but 300 km away). I just find it slow and difficult to use in general, and find myself needing to use google maps on the browser more often than not.

K-9 Mail: I actually took some time to explore and try the many different settings and I think I managed to change most of the settings I was unsatisfied with. I’ll use it with the new settings for a while, maybe I solved the issue.

Thank you guys a lot again for your availability to help :slight_smile:


Indeed, OSMAnd is relatively slow. Maybe because it runs completely locally and has to churn through huge maps - the full data sets of OSM. I can understand your problem with house numbers, although this was better in earlier versions, I think. It won’t become any better performance wise, I guess.


I only experience this since I moved my downloaded offline maps to the SD card, since the SD card is considerably slower than internal memory apparently. But perhaps my perception of slow is different, I’m pretty patient :slight_smile:

You could try whether online maps work better for you. Using them OsmAnd only has to display some picture tiles instead of rendering all this vector stuff from the map files. Catch is, of course, this needs internet access, the faster the better:
Configure map - Map source - Enable Online maps - Settings (just appeared) - Enable "Use Internet"
Configure map - Map source - OsmAnd (online tiles)

A thing to tweak for offline map performance are the details:
Configure map - Details - Disable everything
Configure map - Hide - Enable some stuff to really simplify the map (But who wants that :slight_smile: ?)

Yeah, OsmAnd search seems not to work as conveniently as Google, I was puzzled by that, too. From my point of view there are two factors at play here:

  1. The map data OsmAnd uses doesn’t include all the house numbers it seems.
    Google’s data also doesn’t include all of them, of course, especially in the countryside, but it is better than OsmAnd currently, no way around that.
    Anyway, OsmAnd can’t find what isn’t in its data. Doesn’t help especially if you are used to Google Maps and enter the street complete with the house number already everytime (I tend to do that, too :slight_smile: ).
    In OsmAnd, just enter the street and wait for OsmAnd to find it and give it to you in the results list, then tap on it, and you get the list of numbers OsmAnd knows for this street.

  2. The developers messed up the default search feature. In older versions of OsmAnd you got the incremental search you still get with e.g. Directions - From - Address, but the developers obviously decided to be much more clever than every user who loved that simply working and useful approach. Now you can enter anything in the same search field and just hope for the best …
    The good news: You can still access the incremental search feature, even if this needs a few more taps … Dashboard - Scroll down to History - Show all (right beside “History”) - Address


Wow, that’s a lot of info, thank you so much :slight_smile:

So I changed the settings like you said, I hope it will improve my user experience. I also kind of want to be able to live without google maps so I’ll definitely try every possible alternative.

Throughout this thread I’ve seen many mentions of the microG project, which, and I’m not sure I understood it well, is a “fake” version of google apps that can be switched on and off as needed? Is it a whole google apps package that comes at once or is it possible to get, say, a microG maps? And does it have any privacy issues as the official google apps have?

I’m asking this because I started running lately (impressive, I know :wink:) and I found an amazing app to track my runs, distance, time, elevation, etc. The problem is it won’t work in a reliable way without google maps. Would it be possible to have this microG thing and use it only when I go running? Would it possibly “trick” my running app into thinking I do have google maps?

Thank you again so much for helping me out, I’m getting more and more on board with this google-free idea and with knowing my phone better, and that’s mostly thanks to people like you here in the forum who are willing to take some time and help out a noob :grinning:

1 Like

OSMAnd can track your movement with the GPX extension - either locally or to an online resource. I use it with my hiking trips on holidays.

In OSMAnd you can optionally only load pure street maps which may reduce loading times drastically.


Interestingly, following user demand they added “Address” back to the normal search from version 2.6 up, so you can start your search with the city or a zip code, then easily select the street, then the number … now that’s better.

I just now realized my F-Droid was somehow broken and didn’t tell me about new versions although it was configured to do this, I was still using OsmAnd 2.5, currently they are at 2.7 :slight_smile:

Some more info about 2.6 search changes


I noticed on a net monitor that Firefox Klar connects with *** and *** Firefox says this browser is build for privacy, but it doesn’t to seem like it…

Am I right about that?

p.s. FK also connected with another server: ams15***something***

And it looks like Afwall+ cant’t prevent ( UID 0 ) calling ‘home’. Just a few minutes ago it made a connection to Although I dont’ know if that’s Google…

1 Like

Not in the source code, but it could be a dependency, although it would be rare. Most probably is some third-party component on a regular web page you visited, and not Firefox Klar itself. Most matches of * I find online let me guess that it’s a CDN —a Content Delivery Network, a network of quick and distributed around the globe servers that web developers use to get web dependencies (pictures, CSS stylesheets or JS scripts) for their webpages. It’s not a privacy-respectful way to do to your users (if you are a webdev like me), but Firefox cannot block CDNs because it would break the whole Web.

Edit: Damn, remind me that the next time I should search on Wikipedia before randomly browse the Web for something:


Sounds like a nice open company though …

[quote]The National Security Agency and Federal Bureau of Investigation have reportedly used Facebook’s Akamai content delivery network (CDN) to collect information on Facebook users.[83]

According to researchers from the Universities of Cambridge and California-Berkeley, University College London, and International Computer Science Institute-Berkeley, Akamai has been blocking access to web sites for visitors using Tor.[/quote]

@Roboe Tnx :slight_smile: . You’re right. I found out that it’s just 'cause of the website one visites. Some other websites give the same results.

Does anybody know how to prevent (UID 0 ) to call home? I saw that it also makes connection to (Google DNS).

  1. Is this only possible with XPrivacy or is there another way? Privay Guard doesn’t seem to give a solution.
  2. If Xprivacy (yes, I flashed it again…). Does anyone know which UID I have to block and in what way? There is no possibility to block (UID 0) in xprivacy.

ps. I’m on Lineage OS. Maybe this is just a problem on LOS, but possibly it is also relevant for FPOS-users.

I know this post is quite old but I installed RadioDroid the other day and it seems to be playing, but I get no sound. Anything specific that I should look for, e.g. in Settings? My phone is running FP Open Source, version 6.0.1 - planning to download the pending update today or tomorrow if I find the time.

Thank you!

@Linda_CH: I moved your post to the FP2 topic. I never used RadioDroid. In my post you replied to I just explained to someone how to make sure the newest version (of any app) is displayed in F-Droid.

I can use radiodroid without problems or special settings. Maybe you should check, if you change the correct volume type while pressing vol+ button (not ring tone)? You should try this DURING the radio is already playing!

What I’m doing is using WireGuard over public WiFi and mobile (LTE) to connect to my home router and use that as DNS. The DNS (dnsmasq) uses blacklists to filter ads, so I don’t see any ads in any apps. It then forwards to unbound which uses DNS over TLS (its slightly slower because of this setup, but doable). This solution doesn’t require root on clients though WireGuard runs better as root. Furthermore, all outbound traffic on my router with destination port 53 (TCP and UDP) is redirected to dnsmasq. So it catches and and anything else unencrypted.

1 Like

can you explain how do you block ads via DNS?
I’m using openWRT with adblock (with custom lists), but the majority of ads are not blocked since the block is not possible at DNS level.
Remember that and are google DNS. It is much better to use OpenNIC via DNScrypt ( and or via DNScrypt and or, if you like DNS over TLS, cleanbrowsingDNS ( and or cloudflare ( and that are more privacy focused that google .

Why is the block not possible at DNS level?

These are the rules I use:

DNAT       tcp  --           !          tcp dpt:53 to:
DNAT       udp  --           !          udp dpt:53 to:
DNAT       tcp  --           !         tcp dpt:53 to:
DNAT       udp  --           !         udp dpt:53 to:
DNAT       tcp  --              tcp dpt:53 to:
DNAT       udp  --              udp dpt:53 to:

All loose DNS traffic is being forwarded through (my gateway internal LAN address). Except when it is going to (my main server). That’s for failover. The rules are for VPN. The DHCP server also already gives the correct DNS information; the above is just for stuff which (for whatever reason) still wants to use something else.

OpenDNS = Cisco. I use Quad9, but that’s owned by IBM. I don’t assume any of these companies are not data hungry (including Cloudflare) but I will agree with you that Google seems to be one of the worst offenders.

1 Like

Just supporting your thought of avoiding Google!.. I’ll keep digging on how to uninstall Google from my FP2 - as it feels like malware to me - once I found out Google was automatically copying my photos up to some Cloud somewhere - and I could only access them when I had wi-fi… Maybe a clean re-install? (I’m over 60 - and think mobiles are for making telephone calls - and I’m only just working out the basics of them also taking photos… and there’s a list of other things I don’t understand, but that seem to have “icons” - but why would anyone under 30 care? )