Living without Google 2.0 - A Google free FP2

I have hte same problem and clearing cache/data for Google Framework Services doesn’t work for me either. Any other ideas?

If by trick you mean the suggestion posted by @MMMM, in post 246 - Then yes, but I only saw it after I had finished my post. It did solve my problem though - I can now disable Google Play Services whenever I want to. So hat’s off to @paulakreuzer, @MMMM and everyone else in this thread who helped me!

With a bit of experimenting, I discovered: Having either Google Play Services or Google Services Framework disabled, and then switching Location (well, the GPS) on, removes the prompt asking if Google may share anon data. Subsequently going to Settings > Location reveals that GPS is set to High detail. So to choose a lower level (Device only, as @paulakreuzer pointed out earlier), it must be changed there each time after GPS is switched on.

I only ever really used the GPS for Run-keeper (cycling), and as I suspect they won’t run happily with Google services (I could be wrong), I doubt I’ll use it much at all. Unless I find a decent alternative as an Open Source.

Emmy: I don’t know whether that trick works for you? Ie disabling Device Administration for Google Play Services (or is it Framework, can’t remember from the top of my head). Either way, here’s @MMMM’s trick again:

My previous handset is a Samsung Note II, so S Planner is my calendar. After some research, I think my best/only way of getting my calendar contents onto my GAPPS free FP2: Following This Guide and use iCal Import/Export to get calendar contents as a .ics file.

(I’ve only got a MAC; Looks like Kies is available for Mac but not sure how well it works, judging by hits on the search I made)

It dawn upon me this weekend that I’ve not been backing up/synchronising my calendar at all so far. Anyway, I was going to ask whether either of the two Calendar Apps supports importing .ics file(s)? I’ve tried to look through the info on F-Droid for each but I can’t see if that’s possible.

PS. Whilst looking for help, I found a .ics import/export app which is available on both Google Play and F-Droid: Calendar Import - Export (ics) So no need to touch the Play Store to obtain a copy, should anyone need to use it.

PPS. The most recent comment says it’s not possible to transfer data correctly, but hopefully it’ll work out better for other people…

I am doing my first start following this guide.
I started without sim card, installed F-Droid through USB, now I’m disableing google services. I see those you succesfully replaced, but whixh ones should I keep?

In other words, if I go to “All apps” I have around 20-30 apps and services preinstalled, Which ones should I keep?

I already disabled the most Google branded ones (e.g. Google, Google Play, Google Music, the camera etc). I also removed Contacts, is it ok? How will I find my contacts now?

So, which apps can I keep?
This is a screenshot of my current installed apps, am I “as google free as possible”?

When I went through this thread the other week, I think I read that the Contacts app is part of FP, and not Google. So you need not disable it?

Although I’d rather someone with more knowledge that me could agree/put me straight on that though…

1 Like

Some further info; I’ve still got Contacts enabled.

A bit of experimenting: If I attempt to add a new contact, I get the following prompt:

Your new contact won’t be backed up. Add an account that backs up contacts online?

And my options are:

Keep Locally, Add Account

Now, apart from Contacts I’m reasonably sure I’ve disabled all the apps suggested by this thread (and one of the linked guides). A total of 25 Apps.

But is the above prompt confirmation that I can keep Contacts enabled, or just a symptom that I do not have any account added to the phone (yet)? I’ve also disabled auto-synch.

Google-apps to deactivate:
Android System Webview
E-Mail (does not work OK, bettter K9Mail)
Photos (better QuickPic up to 4.5.2)
Google App
Google Backup Transport
Google Contacts Syncadapter
Google Drive
Google One Time Init
Google Partner Setup
Google Play Movies
Google Play Music
Google Play Store
Google Play Services
Google Services Framework
Market Feedback Agent
Talk Back
Voice Dialer

You will need Google TTS for navigation Commands


1 Like

Any feedback about ? It is an apk downloader to bypass google play store. The good thing about it comparing to similar websites is that it also comes as an app, which sounds convenient…


Neat idea, though I suppose the Play Store is the same thing already… (I’m personally hoping I’ll never need to access it direct again though).

But the idea inspired me to check whether there’s anything similar available for F-Droid, which there appears to be…??

1 Like

Huh ???
:confused: :confused:

To the guys and girls that have followed the awesome descriptions of this thread to get rid of as much google as possible:

Have you had any problems with the new update. I’m wondering if and which of the changes we made will be reset when updating the OS. Are all google apps and services still disabled or are there any cheeky comebacks?

I had uninstalled a couple of Google Apps. Those were reinstalled during the update (so I needed to disable them after the update). All the other “googly” apps that I had disabled before (without uninstalling them) remained unchanged (= disabled). Otherwise, the update worked pretty smoothly. :slight_smile:


I just added the currently tested Version of FPOSOS to the first post.

Just FYI, I’ve found two apps doing this. First, the new app SnooperStopper, who’s main purpose is to be able to have different passwords for encryption and lock screen, also offers to reboot the phone after a customizable number of failed attempts to unlock the screen lock. It’s also available via F-Droid after you’ve added the repository to F-Droid.

Secondly, there’s the app Wrong Pin Shutdown, where the last version on F-Droid is from 09/15, because it hasn’t been open source anymore since then. It reboots the phone after 10 failed attempts.

Thirdly, there’s also the app Locker, which wipes the data partition after a customizable number of failed attempts to unlock the screen lock.


It seems that now there is: LeafPic, see also the screenshots on the Github site (I have also posted it in Picture viewer app: what’s your choice? - I hope that’s fine). Though it may still be in (early) development phase. I haven’t test it yet, because the preinstalled open-source AOSP Gallery app is fine for me.

Btw I wonder whether the preinstalled gallery app in FPOS (with Google Apps) is actually the same as the one in FPOSOS and so is open-source as well? Could someone with a preinstalled OS (who knows how to use adb) try the following commands in a terminal after having enabled USB-Debugging? (root is not needed, I think)

$ adb shell
$ pm list packages -f | grep Gallery

The output should be one line containing the package name and path of the Gallery app. If it’s


this would at least be a hint that it’s the AOSP version (otherwise (i.e. if it was a proprietary Google app) it should be something like[...], I guess).


I’m pretty sure the default Gallery app on FPOS-GMS (that with Google Apps) is Google Photos. I remember the lack of gallery after disabling all Google Apps.

LeafPic is great, and the one and only gallery on F-Droid. Using it by default for some days and no problem at all (they’ve fixed some weird video playing bug in the last release). Hope it gets more features to be a drop-in replacement for my friends using Quickpic.


Indeed, I now remember that I’ve heard of Google Photos. Thanks for the feedback!


I apologise if this doesn’t belong here (The only other post on this forum mentioning LeafPic is the thread that @tphysm links to in post 273…). However, has anyone else come across a bug where Open Camera and LeafPic don’t quite see eye to eye?

I’ve got the two open source apps installed (and the two built in cousins disabled…), LeafPic (v.0.2.7) and Open Camera (1.28.1).

Problem with LeafPic and Open Camera:
Running Open Camera and then tapping the icon to view the last taken photo: I get a prompt telling me “Unfortunately, LeafPic has stopped.” and the only option available is “Ok”. Not much to go on…

For completeness, I compared the behaviour versus the two built in apps:

Uninstalling LeafPic, re-enabling built in Photos app. Running Open Camera and tapping the icon works fine.

Uninstalling Open Camera, re-enabling built in Camera app. Running Camera and swiping down the last taken photo is fine.

Disabling Photos and (re-)installing LeafPic - Running Camera works fine, tho it looks like Camera’s got it’s own “picture viewing” app and doesn’t (try to) run LeafPic.

Although as @tphysm did write:

Maybe I just need to wait a bit, or better yet submit a bug to the developer(s) of LeafPic.

1 Like

I should add that running LeafPic on it’s own (not from Open Camera), works just fine.

1 Like

I came across the same bug. Maybe it is LeafPic’s responsibility, since it is a pretty new app.

1 Like