Living without Google 2.0 - A Google free FP2

Thanks for the clarification concerning the DNS! :slight_smile: I’ll add a remark to my post … (Btw: where has the thumbs up smiley gone? :hushed:)

Well, yes seems like. But you need to configure it properly as described in the before mentioned topic or the corresponding xda forum post.

@paulakreuzer Yesterday i got my FP2 so i was using this day to follow your instructions for a Google free phone. Since i’m running Windows and am kinda afraid of bricking my new phone, i sticked with your description for Method 3 to limit Googles influence as much as possible. I didn’t insert a SIM, skipped all parts of the introduction that were Google related/unchecked all boxes referring to locations and improvement, set the time and date, allowed unknown sources and tried to disable the Google Services. As many others, i encountered the Play Services problem. The buttons for disabling and force quit are greyed out. Then i read about the order of disabling, enabled all the apps again, rebooted the phone trying to disable Play Services first, still greyed out. Then i tapped the 3 dots on the upper right corner to reset the App settings, rebooted the phone, still greyed out. Am i missing something? I still haven’t inserted am SIM or anything. Furthermore i connected it via USB to my PC. While the loading works, i can’t see it anywhere in the device manager so i’m not sure how to transfer F-Droid to the phone :-/


Did you try this order?

You should get a notification on your phone when connected to the PC. Slide from the top of the screen down to get to the notifications. Tap on the notification to choose USB connection options. I don’t know which one is the right one for Windows (but I believe it says that in braces anyway). If the first option doesn’t work try another and keep in mind that unticking all options is also an option.

Yes i tried that order. At first i was following your list of services which is mentioning the Play Services as the last item in the list.

After having disabled everything from Google Account Manager to Google Services Framework the disabling options at the Play Services were greyed out. Which made me understand what

meant. So i tried doing what @schept was doing. I enabled Google Play Store, Google Drive and Google Account Manager. Still, i couldn’t disable the Play Services. I also saw, that @Hooloovoo had the same problem:

So i enabled all the GAPPS again, rebooted the phone and tried disabling Play Services first (this trick is also mentioned on the website, that @schept posted). Still the buttons are greyed out :frowning:
The last thing i tried was the tip that @Hooloovoo gave @OHarrra:

I did that as well, rebooted the phone but still the buttons to disable the Google Play Services are greyed out. Sorry for redundancy or going too much in detail but having an IT background i know it can be sometimes more useful to explain each step.
@paulakreuzer: Thank you for your work here in the forum and for your fast replies. Maybe you can help me with this one :slight_smile:


I’d love to give you a step by step guide but what I did won’t help you much. I:

  • disabled everything I could
  • tried to disable Play Services
  • failed
  • tried again
  • gave up
  • went on with my life
  • by chanze tapped on play services again and suddenly it wasn’t greyed out anymore.
1 Like

I had the same problem. I’ve tried every single trick, but I was not able to disable Google Play Services.
BUT!! After hours of research I found the following tip and it finally worked:

  1. Click > Settings > Security > Device Administration and TAP the app you want to disable Device Admin
  1. The Device Administrator screen will appear > TAP > Deactivate – You will then be asked “Are you sure you want to deactivate Device Admin rights? TAP > OK

3.Click the BACK icon until you reach > Settings > TAP > Apps and scroll down to the app you disabled Device admin. “Force stop”; “Uninstall”; “Clear data”; “Clear cache” and “Clear defaults” should now be enabled.



@paulakreuzer THAT DID THE TRICK!!! Thank you @MMMM Nevertheless i can’t seem to connect to the PC :frowning: Neither do i get a notification nor do i see a USB connection option when i slide from top to bottom to see the notifications. I already switched USB ports :worried:

1 Like

If you don’t get the notification than your cable probably doesn’t work properly. But you can also get to the USB options by going to: Settings > Storage > Settings button (3 dots in top right corner).

When i press the 3 dots, i can see (in grey letters) “USB-connection (PC)”. Maybe i should add, that i haven’t inserted a Micro-SD card yet, since i thought, i could access the internal storage.

It doesn’t have to do anything with the lack of an SD. If you don’t get the notification and the USB connection button is greyed out than not only does your computer not recognize your phone, but also the phone doesn’t realize it’s connected to anything. So like I said I guess your cable doesn’t work properly.

I think that’s due to the fact tant the default usb setting is “mount SD card”. In order to access your internal storage, you have to do the following: When your phone is connected to your computer, swipe down the notification bar and of the left side you’ll find a notification to change USB options. Choose “MTP”. This will show your internal storage and your SD card on your computer.

@paulakreuzer @Irina_Spitznagel it was in fact a faulty USB cable. I couldn’t imagine that, since loading the phone worked really fine with the faulty cable. Nevertheless, i bought a new cable today and as predicted, as soon as i connected it to my PC, i got a notification on the PC and on the phone as well. I selected “MTP” (like @Irina_Spitznagel suggested) and i could access the internal storage. Next question, referring to @paulakreuzer 's post:

Now my file explorer shows me this folder structure of the internal storage:

I downloaded the “Fdroid.apk” from the project-website. Does it matter, where i save that file?

Kind regards and thank you again very much for your fast, friendly and competent support.

1 Like

Not really. I always choose “Downloads”.
Once you saved the -apk file on your phone you’ll simply have to use Amaze to navigate to where you saved it and tap on the file to install the app. You’ll have to have “allow unknown Sources” enabled in Settings > Security.

I did a mistake and accepted this once:

Once I activate gps location via dropdown menu, it is automatically set to “high accuracy”. I have to activate location via settings and set it every time manually to “Device only”. How can I make this behavior undone?

Since I have the same behavior after disabling Google Services Framework maybe erasing cache/data of the Google Services Framework will bring the popup back. (Settings > Apps > All)

I erased cache/data and reboot. Unfortunately did not work on my FP2.

EDIT: Oops, I don’t know how obvious it is, but I replied with @paulakreuzer’s post #90 in mind…!

What he wrote:

That’s about the NLP without GAPPS isn’t it? In that case the warning
would be misleading, but on the FP2 where you can’t disable Google
Location Services the warning is indeed accurate. Disabling the
Framework just gets rid of the warning, not of the Location Service I’m

----------- Original message: ------------

I’m sorry but I’m finding this a bit confusing. I’ve read until post ~215, so forgive me if this is explained near the end of this thread. I’ve kept personal notes trying to summarise how to “Ungoogle” my FP2 although there are 2 things I currently don’t quite understand.

When the phone is brand new, or the booted up after a factory reset, the 6th option is labelled “Google services”. Here, if I untick the first option “Use Google’s location service” I’ll prevent anon location data being sent to Google. But if I understand @paulakreuzer warning, if I later go to Settings > Apps and disable Google Services Framework, is it then the case that each time I subsequently turn on my GPS, my FP2 will be sending that anon data onto G, without me being prompted asking if I want to share my location?

(My other question regards disabling Google Play Services, but I need to gather my thoughts into a separate post first)

Thank you for this brilliant forum, and this very informative post!

I’m not absolutely sure. All I know for certain is:

  • The message will be gone
  • Google Location Services are still there
  • Turning on Location automatically sets it to “high accuracy”

I’m quite sure that means that Google Location Services will be used and therefore anonymous data will be sent to Google.
To avoid this - if you use GPS a lot - it’s probably best to keep GPS activated and manually set to device only. As long as it’s not used GPS won’t drain the battery and this way you won’t have to switch to device only every time.[quote=“pCubed, post:258, topic:11587”]
(My other question regards disabling Google Play Services, but I need to gather my thoughts into a separate post first)

Have you tried this trick?

I have hte same problem and clearing cache/data for Google Framework Services doesn’t work for me either. Any other ideas?

If by trick you mean the suggestion posted by @MMMM, in post 246 - Then yes, but I only saw it after I had finished my post. It did solve my problem though - I can now disable Google Play Services whenever I want to. So hat’s off to @paulakreuzer, @MMMM and everyone else in this thread who helped me!

With a bit of experimenting, I discovered: Having either Google Play Services or Google Services Framework disabled, and then switching Location (well, the GPS) on, removes the prompt asking if Google may share anon data. Subsequently going to Settings > Location reveals that GPS is set to High detail. So to choose a lower level (Device only, as @paulakreuzer pointed out earlier), it must be changed there each time after GPS is switched on.

I only ever really used the GPS for Run-keeper (cycling), and as I suspect they won’t run happily with Google services (I could be wrong), I doubt I’ll use it much at all. Unless I find a decent alternative as an Open Source.

Emmy: I don’t know whether that trick works for you? Ie disabling Device Administration for Google Play Services (or is it Framework, can’t remember from the top of my head). Either way, here’s @MMMM’s trick again: