English

LineageOS/Modem firmware: Benefits of the lastest updates


#1

Modem firmware (19.02.1): Power on while charging now works.
Modem firmware (19.02.1): Fastboot mode shows a pulsing blue led (Neat!).

LineageOS (20190306): Powering off works.
LineageOS (20190306): Advanced reboot (to bootloader or recovery) now works.


#2

LineageOS 20190313: March security fixes (lots, it seems). :wink:


#3

I tried to install the last update with twrp3.2.3.0 and ended up in the black screen with the fairephone word. I’m able to boot into TWRP. How can I come back to the “last known good” or something si milar?
Kurt


#4

Which file did you install exactly?

Have you tried turning off the phone (real shutdown, no reboot) and turning it on again?


#5

I don’t remember the exact file, it should be the update which came one of the last 2 days. And yes, I tried to turn off the phone totally and turning on again. It seams to reboot once and end up on the same black screen


#6

If it was me, I would just try to install it again and watch out for possible error messages in the process.

(Latest LineageOS build is March 13, latest LineageOS for microG build is March 12.)

You would restore your latest backup before the update attempt.


#7

Thanks ofr your answer @AnotherElk, but how to do one of your suggestions?


#8

What does twrp say while flashing?
And the name still would be interesting, i think. How did you flash it? It should still be on the source from where you flashed it


#9

I was booting in TWRP when I got a update remark in an actual lineageOS. I now only be able to boot into TWRP by pressing the volume+ button. Then I’m in TWRP. How can I find the updates??


#10

Oh, an Updater malfunction then? All right …

  • Download the OS file you want to install to your computer, it has to correspond to what you are using on the phone. Don’t try to install regular LineageOS over LineageOS for microG and vice versa.
  • Connect the phone via USB to the computer.
  • Boot the phone into TWRP, this will enable MTP mode, and the phone’s storage and the micro SD card (if you have one in the phone) should become visible in the file explorer.
  • Transfer the OS file to the micro SD card or, if you don’t have one, to Internal Storage.
  • In TWRP, choose Install.
  • Select the Storage location where you put the file (micro SD card or Internal Storage).
  • Navigate to the file and select it.
  • Swipe to install it.
  • Watch out for error messages.
  • When done without errors, reboot (to system).

#11

IIRC, you can find it under /cache, if you didn’t delete it


#12

@AnotherElk Thanks for the solution. It works now again. Only a few icons I have to rearrange
@Iklaus I had to download it again and transfer it to the phone. I couldn’t find /cache, as you suggested
Thanks all
Kurt