lineageOS installation instructions 'wipe system'

Hi there,
I am trying to install Lineageos 15.1 on my FP2, using the instructions at
However, step 7 during the ‘wipe’ process states:
" Select the Cache and System partitions to be wiped and then Swipe to Wipe ."
…however, the ‘advanced wipe’ menu that i see doesn’t have ‘system’. It only has ‘Dalvic / ART Cache’, ‘Cache’, ‘Data’, ‘Internal Storage’, ‘Micro SD Card’ and ‘USB OTG’.
Any ideas of which of these might have been renamed from ‘System’.?

1 Like

I’ve never seen “USB OTG” in TWRP, even when I had some USB OTG storage connected. “System” was always there.

Is some USB OTG device connected to your phone via USB?

Which TWRP version are you using?

You signed up as a beta tester for Fairphone’s Android 7, did you install it?
Else … Which OS is installed currently?

Since you are wiping the phone anyway, you could just wipe Cache and proceed with the install and see whether some helpful error message comes up.

I’m sure @skimo12 is using twrp included in the current FPOS beta version (as there is by design no system partition but usb otg).
So maybe a “standard” TWRP should be used.

Hi @Volker, I did have the FP beta version installed. I see that the version number is 3.1.1-0 when go to ‘recovery mode’. I had followed the steps to install, but maybe I copied the wrong file from my downloads folder.
@AnotherElk, My current version is 3.1.1-0. I will wipe cache and proceed with the install as you suggested.
Thanks to you both for such a fast response!
edit: I checked my command prompt on my laptop. I did run the command to install twrp-3.2.3-0-FP2.img. I guess that the overwriting doesn’t work.

1 Like

Directly after flashing a TWRP version, you will have to reboot into it to let it make itself resident.
If you boot into the OS instead, the OS will most likely restore its own recovery.

If @Volker is right and presenting USB OTG instead of System is the usual way of things with the Android 7 beta TWRP, you should wipe USB OTG, too.

Hmmm - USB OTG is there as an option, but I don’t think it’s there instead of system…

Problem solved!. I followed the advice to reboot into the new TWRP right after flashing it. That worked perfectly. I installed the new LinageOS nightly and MindTheGapps. It’s quite smooth, but needs some patience. Thanks again.


Hi skimo12,

How did you manage to reboot into the new TWRP? Anything I try, gets me into either TWRP, bootloader or FPOS (beta). I do not see the latest TWRP appearing.

After flashing and Volume Up on fastboot reboot, I get into the bootloader.
After powering off and key combination Volume Up - Power, I get into TWRP
Normal power on, gets me into FPOS (beta).

Did you find an option to wipe system?



That seems to be the problem. “Volume up on fastboot reboot” should result in recovery, not bootloader, i.e. in the new TWRP version you have just flashed.
I have no explanation why this happens to you. Hardware problem with the volume buttons maybe?

Yes, if it weren’t for the line after that which says I can get into bootloader just fine when the phone is switched off … but I’ll test whether Volume Down is activated at the same time … it may not get precedence in the latter case … thanks for the quick reply … to be continued

Ok, there are more ways to install TWRP apparently … use TWRP app to download … use TWRP in recovery to ‘Install’ the downloaded TWRP to recovery … press ‘Reboot’ while holding Volume Up … boot in to TWRP 3.2.3-0 … done …

TRWP 3.2.3-0 prompts to make the system partition modifiable … now I can proceed to LineageOS.

Note that in ‘adb sideload <filename>’, you can’t use backslashes … (didn’t try forward)

Another note: The LineageOS page on gapps tells you to ‘adb push’ the gapps zip, whereas the LineageOS FP2 page tells you to ‘adb sideload’ after sideloading LineageOS … I used a second sideload for OpenGapps nano …

Reboot system … wait a minute or two with LineageOS logo animating … now I can enter my PIN.

… and now let’s see whether it fixes my problems

Well done @Spenk. I was trying to remember how i did it, but i think it was what you got at the end. I didn’t power down then reboot. I think that I pushed the ‘magic buttons’ while rebooting from the point when the install completed. It was not intuitive. Great that you have described it in detail here.

It didn’t … LineageOS 15.1 apparently uses the same Adreno GPU driver … chrome://gpu shows same list of workarounds to avoid the browser to crash … the GPU still resource locks and crashes the OS in the same circumstances …

Additionally unlocking the phone when there are notifications, may hang the system and then a forced reboot is required …

On the other hand … LineageOS nightlies probably provide bug/security fixes earlier … and it’s Android 8.1 …

Keeping my fingers crossed for solutions …

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.