LineageOS fork including MicroG

I also have been thinking for a while that the battery indicator might just not be completely accurate at low levels? Last time I had an enormous 15-2% drop within 10 minutes I forgot to turn it off, put my phone back in my pocket (wifi on and everything) and 2 hours later it was still on, at 1%.

Apart from that:

MicroG is awesome! I have dabbled with microG on FP Open before but ran back to Google after a while because I lacked the discipline to keep my proprietary apps updated via Raccoon (and I couldn’t miss my beloved railway and banking apps and Whatsapp for the world). However since a colleague told me about Yalp I decided to give the Google-free-battery-sparing life a chance again and this LineageOS fork including microG seemed like the perfect opportunity.

I installed the then-latest version of the LineageOS-microG fork on January 1st following all instructions at but queuing the zips for the latest modem files and addonsu as well. Afterwards I updated TWRP to be able to receive OTA updates. In the microG-settings I enabled Google device registration and GCM.

So far, most of it works like a charm. F-droid provides almost everything I need and Yalp recovered some of my precious paid-for Play Store apps. Location and weather have never been as accurate before.

However I noticed some weird behavior that I believe no one else mentioned in this topic:

  • After every regular reboot, some settings are lost: I have to set SwiftKey instead of the stock Android keyboard again, set storage permission for almost all apps, set standard apps for various purposes (SMS), have to choose which launcher to use for the home screen, etc.

  • Signal works just fine both for encrypted messaging and SMS but doesn’t show contact names in chats, only phone numbers (Contacts are stored locally - with names - and Signal seems to be able to access the numbers but not the names?)

  • VDK mobile banking app (which probably no one else uses) seems to work fine at first, I can register my phone, but upon trying to login, it ‘forgets’ my settings and I end up in a register-ok-register-again loop.

Now, the latter two are probably just app-specific quirks. The first issue however, is quite incovenient - especially if you quickly grab your phone and have to set everything right again before being able to - for example - take a picture.

Enabling and disabling Safety Net does not help. I suspect my adoptive storage SD of causing all of it (it isn’t immediately recognized upon reboot either) but I’m not sure.

As I’m on quite a new install anyway, I figure just wiping the phone and re-flashing the same version of LineageOS is the quickest solution. However to prevent the same thing from happening (and avoid having to do another and then another and then another factory reset) I wanted to ask for some input from you guys first.

Does anyone recognize the ‘forgotten settings’ issues?

Did anyone succesfully use LineageOS with microG without GApps with an SD set as adoptive storage?

Would anyone know what else to do to prevent this quirkiness from occuring?

Have you tried to delete the apps’ data and cache ? After my update I restore OsmAnd maps through ADB and every time it started it behave as if it was the first time I launched it (downloading every time offline maps, ecc…) but after clearing app’s data it worked fine.
Have you read this #troubleshooting ?

For those with fast battery drop. Did you try a battery reset (#batteryguide) ?
Battery drops under 12-13% occurs to me too, but I think battery reset somewhat mitigated them.


I have the it on Fairphone Open aswell. Maybe it’s not Lineage related.

Weird thing, sure it’s not a common issue. Did you do a clean install? To me it seems to be two possibilities:

  • Your memory chip is faulty (unlikely)
  • As you are using your microSD card as adoptive storage, your microSD is faulty or broken, or the FP cannot make proper contact with it

Long time ago, when smartphones had kind of 50MB free on disk from factory, tweakers like me used to use some hacky techniques to expand the internal memory with partitions on microSD and other stuff. As there’s a wide spectrum of SD cards qualities, issues like that (loosing some apps, or some app’s data) arrived from time to time with cheap and slow cards (depends on the “class” of the card) or just because microSD are prone to break.

That works just fine here and near me. Have you enabled LOS’s Privacy Guard for Signal? Make sure its disabled (or well-configured), Signal has read and write permission to your contacts and try to resync them (pencil icon -> open ⋮ options -> Reload).

Nothing to say. Some apps just don’t work because of missing Google APIs in microG.

OSMAnd doesn’t store offline maps or cached tiles in app’s data (which is the thing you restore with ADB), but in user-accessible storage (/storage/emulated/0/Android/data/ If it doesn’t find them, it will download assets again, obviously.
(Note that /storage/emulated/0/Android is considered system data and is flushed when you wipe data from TWRP, even it being on user-accessible storage.)

1 Like

Thanks guys for your help. I should have mentioned some more details in my previous message: I cleared app data and cache, checked permissions and configured Privacy Guard already. The problems did not go away.

However… it turns out all my LineageOS issues were related and they’re all gone now! I just did a clean install and everything is working as it is supposed to. My phone doesn’t forget what apps I gave permissions to anymore, Signal is suddenly able to give people a name instead of a number, I don’t switch to the annoyingly vibrating stock keyboard after a reboot and even my banking app is fixed, it doesn’t act like it’s the first time I ever use it anymore. Hurray! Party! LineageOS forever!

I didn’t dare to use my microSD as adoptive storage this time, as no one in this topic confirmed they’re successfully doing so. The thing is, I don’t know whether the problem was the LineageOS install itself or the use of adoptive storage. Right now, I don’t have time to go through the whole process of backupping and setupping again, so I won’t test it, but as soon as I do, I’ll report on the results here!

Haha, well, fair enough, I did once screw up a (quite decent, Transcend) microSD by using partition managers with what some might call an overdose of enthusiasm. The replacement I got (even after honestly telling the store it was most surely my own fault!) was fine at first but slowly degraded over two years of extensive use, syncing a lot of data, using it for backups and later on as adoptive storage. Turns out SD segments have a limited amount of read and write cycles and you’re screwed afterwards (I didn’t know that).

The microSD I’m using right now however, is only 1 month old, its specs should be sufficient for adoptive storage (Samsung EVO) and it was doing just fine - adopted - in FP Open, about an hour before I installed LineageOS. I’m pretty sure that’s not the problem this time. :slight_smile:

PS: to fix the battery drops I had in FP Open, I tried everything in the batteryguide a few times yet without any effect - but so far, my battery is doing really good with LineageOS, yay!


Yesterday I had the second battery drop, this time from ~ 40% to 14% while I was walking outside at a temperature between 2 and 5 °C and taking a few photos. When I noticed the drop, I switched to flight mode immediately.

The interesting thing: about 6 hours later the battery was still at 14%. I switched off flight mode again and surfed the web for almost 1 hour in WiFi mode. The battery continued to stay at 14%, usually surfing an hour uses 5% to 10% capacity.

So in total I think the displayed battery drop might more be a sensor / calculation issue and less related to the battery itself.

Since the last couple of updates I started feeling the battery was draining at a faster rate. For example during the night without using the phone it’s dropping about 20% and when I check the details it seems to be the microG Core service that is taking the most of it. even after some hours of usage the % of the microG Core is comparable to the screen!

Hmm… I can’t approve that, in my case microG is at 1% battery usage (since yesterday morning).
Did you happen to install additional apps (or app updates) that might explain the increased microG usage?

Mm no new apps. But yes i did several updates. Hard to figure out what could be…

This is after half day of usage including the night

1 Like

Maybe the microG settings might give a hint, e.g. by checking which apps are registered for Google Cloud Messaging?

Another idea: did you already check the #batteryguide?


Thanks a lot for your reply. I unregistered some apps that I really don’t need notifications for. I did this in the past. but there were some that I can still unregistered. I will give a look to the battery guide

Hi guys,

I recently chanced from FP OOS to Lineage with MicroG.


After backing everything up I downloaded the zipfile and followed the lineage instructions. As a person who never worked with ADB before I installed it (because it says so in the instructions) only to find that I cannot transfer the zip via console. So I restored the old OS and moved the zip to my SD card like that, not very convenient. Then I tried to install it out of TWRP and it complained “zip signature verification failed.” I disabled the verification (is one supposed to do that?) and it worked.

In MicroG I activated UnifiedNIp, the others services are so far deactivated

The main apps i use are

  • Threema and Telegram for messaging
  • Fdroid and Yalp as appstores
  • OSMand+ for navigating
  • myphoneexplorer as backup
  • trello for lots and lots of lists

I am running it for a few weeks now, and thus far these are my remarks:


  • backup from myphoneexplorer went smoothly
  • it is based on Android 7 with all it`s features
  • the GPS is soooo much faster! upon loading the map the position is determined (took up to 10 mins before)
  • the battery lasts significantly longer, without optimizing much about 2 full days compared to sometimes barely one day before
  • the camera is also much quicker
  • trello login works now (didn´t before)


  • my main con is that the screen is sometimes unpleasently jumpy. I know this issue also from FP OOS but not to that degree. It is not always the case though, and I cannot really determine what it is dependent on? does anyone know this?
  • It does not seem to be rooted. I did not have time to dig into that yet, but the easy slider option to root the phone seems not to be included. Is there an easy option to root the phone?

some minor issues:

  • I really liked the option from the FPOOS keyboard to have a button to switch the language. I frequently change between german and english, so it was superconvenient. Does anyone if there is a way to have this option with lineage?

  • something more general, but I couldn´t find a proper solution: is it possible to change the login screen background without xposed or some extreme measures like that? seems like a simple enough problem to me but I couldn’t find a simple solution. Would be very grateful if someone could help me with that.

all in all I am happy with the transition. It gives me a bit more flexibility installing google apps than before without having everything in google grip.

PS: I just updated to a newer version of LineageOS and maybe the screen glitch is now gone, but I still have to test it.

1 Like

Yeah there is the option too! Just go to “Einstellungen” and then “Sprache&Eingabe”.

I’m impressed of two days without charging. How you manage that? My battery life also improved a lot with Lineage but not at that point…

Ah, found it, brilliant! Tank you! (I wasn’t aware that I didn’t add english as language and with only 1 language the button doesn’t show up in the interface).

I don’t know if I do anything special about the battery life. I wouldn’t call myself a heavy user; at work I only look at the phone a few times a day, use it during travelling to and from work (which adds up to an hour) and in the evenings are mostly not very busy either. I don’t run a lot of backgroud services. I use mostly 2 wlans, so not a lot of switching there … before lineage K9 was using up a big chunk of the battery (up to 20 %) for some weird reason and I never got it fixed. That is not the case now anymore, so maybe it was just K9 by it’s self.

I put the the profile to efficient (2 point in the scale), didn’t dare to use the “energy saving” all the time so far. Maybe that makes the difference?

I had to do that also, I assume this is normal behaviour :wink:

Indeed the phone is not rooted by default, but it is really easy to do that, just one Zip ( to install from TWRP :slight_smile:


Yes, I think it’s K9 Mail. I was using K9 on FP OS and now on LOS, with 4-5 IMAP mailboxes (synchronized in IMAP push mode). Usually K9 is top or second battery consumer with 1/4 to 1/3 of battery usage.

Ah, thanks for the info! Good to know.

I have only 1 mailbox and I set it to manually checking now. That works obviously, but I still wonder why it behaves like that. I couldn’t find much on the topic so it doesn’t seem to be a major problem on other phones.

1 Like

10 posts were split to a new topic: Discussion about offficial LineageOS support from FP (and why it won’t happen)

Does anyone experiencing more battery consumption after updating the OS?

For me its usually a couple of days more battery usage than “normal” and after 4-6 days its back to where it were before the update or even better.

Is there an explanation for this?


What I had experienced that the media indexing process used quite some resources after there were file transactions like after an update or file transfer to the phone. One time it drained my fully charged battery within a few hours after I had transferred a few GBs of small files to the phone. It needed several hours to index them and at least on Lollipop it seems to run on high priority.
Maybe this is the effect with your phone and it calms down when finished. I am not sure if there was a change on Marshmallow concerning this process or the priority.

In this thread
I followed the hint of @media_rw placing empty “.nomedia” files in all folders I did not wanted to be indexed (neglect system folders like ringtones/notifications also pictures etc.).
This works fine for me and the media process only takes care of system files.

You could lookup the running media process and monitor its behavior if listed. Maybe that´s the explanation.

1 Like