English

LineageOS 14.1 with OTA updates for FP2

osupdates
livingwogoogle
lineageos
Tags: #<Tag:0x00007f9ffc334048> #<Tag:0x00007f9ffc333eb8> #<Tag:0x00007f9ffc333d78>

#161

I don’t know whether the LOS kennel uses stack protection, but maybe an out of order patch might be justified because of CVE-2017-1000251, aka Blueborne… this is a Bluetooth attack on the kennel, with remote (somewhat, due to bt range) exploit… But as a phone might use bt quite often, this might be interesting?


#162

Now I copied the update zip file to the SD card and flashed it via TWRP. Worked flawlessly!
Great thanks to all involved!


#163

At my device the sensor works properly: When I lift up the phones upper part and turn it clockwise or anticlockwise, the screen turns as well, staying upright.


#164

Yes, screen rotation does work. But placement of the phone, detection, whether it’s laying on the back or the display, which seems to be a sensor of its own, seems to not exist

Update: my profiles where mixed up after switching to LOS, obviously. It works now, sorry for the confusion


#165

Good morning Ladies and Gentleman,

short question: can and should we use the modem files for 17.09.3?

Cheers


#166

Good morning :slight_smile:

If you want to give them a go, you can let us know if they have a positive or detrimental effect on your telephony.

If you find issues with these files, then we can investigate, and you can always flash the older modem zip again.

Let us know how they go!


#167

Put the new modem files on the buildserver:

See: https://fp2.joutubes.nl/builds/full/


#168

I’m sorry, but I can’t try it right now, I can’t give it a go before Saturday. But as in the other thread problems are reported, I’ll probably wait…


#169

I installed modem-17.09.3.zip yesterday, and the phone runs fine so far.
I admit I haven’t done much with it since then apart from WiFi though … we’ll see.


#170

Modem 17.09.3 working fine here also. almost 2 days running without problems.


#171

I confirm that: 14.1-20170911-UNOFFICIAL-FP2 with baseband 4437.1-FP2-0-07 works fine since 2 days.


#172

Does the 20170911 version have the fix for the “BlueBorne” vulnerabilities?


#173

Not jet, I think; you better keep your bluetooth switched off at your LOS FP2, if bluetooth isn’t needed urgently!


#174

The testbuild that was built yesterday also still doesn’t have the patches. Hopefully lineageOS will incorporate them soon!


#175

does the testbuild that was built yesterday have the fix for call volume issues which was fixed with Fairphone OS and Fairphone Open OS 17.09.3?


#176

It should, feel free to test it (it flashed perfectly through TWRP). Please log your findings in the bugtracker.


#178

The test build did not solve the problem with the call volume.


#179

can someone confirm that the fix on OpenOS really does fix the issue there?

Chris


#180

I had some other problems with the testbuild and modem from 17.09.3:
1.: one spontaneous reboot during the night while charging
2.: the alarm had a strange behaviour one time: when I wanted to switch it off (slide to the right), the pointer stayed at the right, the sound went away but the vibration did not stop. The phone was not responding to any touch, I had to reboot it by long pressing the power button.


Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
Official LineageOS is here!
Official LineageOS is here!
Official LineageOS is here!
Official LineageOS is here!
Official LineageOS is here!
Official LineageOS is here!
Updating LineageOS 14.1 via TWRP + feature test
Updating LineageOS 14.1 via TWRP + feature test
#181

Building a new one now with blueborne patch and latest security patches.
Can you also help me test this build?