Lineage 17.1 - FP2

Some news about some ongoing issues:

Now there are three FP2s under LOS 17.1 in my family (let’s call them device A (mine), B and C), so we can do further testing about the current bugs.
FYI: Device A has magisk and is rooted, device B has magisk and is rooted, and is encrypted, device C hasn’t got much more than basic LOS, just a few apps but that’s about it.

Mobile data issue

I had it quite often again lately, but it is again random. We have observed the same bug on the three devices.

When and how we observe the bug: When using mobile data, most of the times after a relatively long period (a few hours) during which the phone has been inactive (by this I mean not in use, or at least internet not in use) but not in flight mode (could the problem be related to the SIM card going inactive and it would need to be “pinged”), we want to use mobile data, and the app either doesn’t download, shows an internet error, etc… although mobile data is shown as being connected in the status bar. To check I start Telegram, and if it keeps saying “Connecting…” for more than 10-20 seconds I consider I have the issue (it also works with Discord).

Also a strange fact: in the last one or two months, I have observed that one week I had more often the issue and the second nearly never, and over again. And it is the same for device B, and the same weeks as me (can’t tell for device C). Device A is updated weekly nearly as soon as the new build is available, device B is updated around once a month, device C is updated when we think about it :wink:, so I don’t think new builds are the problem. The three devices are under the same provider (Free Mobile France), so we suspect it could be related to it.

Also, our newest observation is that 4 to 5 minutes of flight mode can most of the times overcome the issue (one minute isn’t enough). But at this point, it’s faster to reboot the phone…

Random reboots

There was a topic in German about this some time ago, in which a few users had the same issue. I remember it was @DeepSea’s case but I can’t remember the others nor find the topic.

Device A and C get random reboots around once a week, device B never.
When in use: the screen freezes completely (i.e the clock stops, I can’t tap anything) and reboots after a few seconds. Locking the screen makes it reboot as well.
When not: it just reboots (though it happens less often I believe)

At first I had thought it was only when charging, but it happened when it wasn’t.
Then I thought when it was when using WhatsApp, but device C hasn’t got WA (it has Messenger though).
And then it also rebooted when locked (but it’s perhaps a hardware issue for these few times, the phone was in my pocket…).


Dual SIM

Device B has dual SIM issues: card 1 (Free Mobile France) is on 4G, card 2 (Telekom de) on 2G. Card 2 works without problems, but when card 2 is in, card 1 has many network issues (sometimes can’t be reached, disconnections during calls, poor network). When card 2 is out, card 1 works without any problem. Though these problems were already there under FPOOS Marshmallow, so it’s probably a problem with the firmware.
Therefore two questions:

  • Why isn’t it possible to disable a SIM in LOS 17.1? Why do you have to get it out? Would that be possible?
  • Will the android 9 upgrade on FP2 allow anything useful/new to be ported to LOS? Could it help solve issues?*

Also, I was considering switching to /e/ at some point but decided to stick with LOS. But actually I might do the switch if the bugs become too annoying.


Agreed! I took the habit of rebooting my FP2 as soon as I have network issues.

I have that behaviour regularly, at first I also though it was Whatsapp only, then I realised sometimes other apps do that too :wink:

1 Like

Hi Alex, I also see connectivity issues with my FP 2 since the beginnning in 2016, irrespective of which OS in which Version was installed… I could fix this for me for a long time by using 3G instead of 4G. Now that Germany is going to disable 3G step by step this does no longer work for me. I use 2 SIM cards, 1 private, 1 for work. The privat SIM has mobile data turned on, the work SIM has mobile data turned of and is set to 2G. Both SIM cards are from the same provider (Telefonica (O2, Eplus)) in Germany, so in my eyes it cannot be caused by the provider. In addition I had same issues as long as the privat SIM was from Telekom. On the work SIM I never have any phone connectivity issues unless there is real bad availability. However, on the privat SIM with mobile data turned on I have a lot issues with the call connectivity and therefore I do the following (this is really annoying and I’m not sure how long I will resist to get rid of the FP2…)

  • when I’m at home with Wlan I set the SIM to 2G and have full call connectivity
  • when I do not have Wlan and need mobile data I switch to 4G
  • when I do not have Wlan and urgently must be reachable on the phone I switch to 2G, i.e. without Wlan I have to decide what need/want more, fast internet or calls…

As I do use 1 SIM for work its no Option for me to re-route all calls from 1 to the other SIM, however, maybe that would be an option for you?

As I thought this might be a hardware issue of my FP2, I put both SIM in another FP2 with same result.

I’m currently on LOS16, because after I upgraded to LOS 17.1 I initially had no issues, however after some time I always had issues with mobile data not reconnecting wihtout a reboot, therefore I downgraded back to LOS16. I’m cheking here from time to time hoping the issues are finally fixed…My FP is not rootet, so this should not cause the issue.

this is a real common issue of the FP2, some only have it rarely other multiple times per day…this can at least sometimes be caused by the fact that the battery looses the connection for a second, so especially when this happens in the pocket I would guess its caused by this. I notice this sometimes e.g. when I lay it down on the table a bit “harder” it reboots sometimes, so as if the mild shock would cause a short disconnect of the battery. Overall this has in my eyes nothing to with the OS installed, rather with LOS installed it seems to happen less often.


Hello everyone.

I had some trouble tonite. First my phone with lineage 16 crashed compleatly. I could not install anything and not even accessing twrp.
I eventually managed to install the stock Fairphone open. Then I tried to install lineage 17 but now I get Error 7 in the installation process. I tried to install an old version of lineage 16 I saved on my sd but that also failed to install.
It seems that I am stuck with FPOS …
Doeas anyone have any clue on how to solve this issue?

Hi, I would advise to open a seperate topic, as this is not really a LOS 17.1 issue…
Then I would advise to specify further the FPOS Version you have installed, the twrp Version you have installed and at which step during installation you had that error?

Yes, you are right… I opened a new topic here… if someone has some spare minutes to help would be great.

Great summary, indeed! Regarding the mobile data issue: I have not had it for a very long time, but I do not know why. Maybe an update fixed that one. Or it might have something to do with Bluetooth which I have been using quite frequently for some weeks to have phone calls to other persons while driving my car.

I think I replied to this thread. I had random reboots with my FP2 until I withdrew my SD card. Since then (> 1 month), I have not had a reboot at all.


Yes. In my case it’s the same, but on android 6 the good thing was that you could easily disable a SIM card if you had issues with it, which wasn’t ported to android 7 and newer.

Might be, will check this out.

Well, if with LOS it happens less often, then it does depend on the OS installed, doesn’t it? :wink:

Actually, I have had reboots due to hardware as well, and I know they are more or less common on the FP2 because of its design, and I do sometimes observe the same symptoms as the ones you describe.
But in this case, I really don’t think it’s hardware, because the screen always freezes just before it reboots, and when it freezes like this, locking the screen makes it reboot. That would be rather strange if it weren’t software, wouldn’t it?

That’s what I thought as some stage, but just you wait until you have it again :wink:
Actually, I don’t understand either, and that’s quite frustrating.

My brother believes it’s because of the firmware files. They’re getting old for new android versions… And unfortunately, we can’t do much in this case…

I don’t believe so. I have been using bluetooth as well.

Well… I have a SD card in my device, but device C which is also affected doesn’t it… So either there are multiple causes, or it was a coincidence (because it actually doesn’t happen that often)?


Hi Alex, under A7 it was after some time again possible and is possible with LOS16…

Somehow you are correct, however this is a thread for LOS 17.1 and this issue is in my eyes not related to 17.1 but a common FP2 issue…I also sometimes have what you describe (freeze with following reboot) and others have with FPOS…there are weeks without any reboot and then I have several reboots in a short time…I always have SD card installed, so doubt that this is the cause…


True. But it’s not with LOS17.1.

Right, you have a good point. I thought it was LOS specific because I never experienced this under FPOOS.
I guess I could try without SD card then… But then device C which hasn’t got an SD card does experience reboots, so…

1 Like

Some FP2 had an issue with the internal antennae connector which became loose.

1 Like

But should I then not have an issue with both SIM cards, irrespective of what network I choose? Because I only have issues when mobile data are turned on and set to 4G. As long as mobile data are off or network set to 2G I have zero issues…and overall this is in my eyes also no LOS 17.1 issue so at the end nothing for this thread here

It was hinted (really) earlier in that (long) thread: modem firmware files are causing the bug. They’re old, yes, but firmware files are supposed to be as old as the hardware itself, so the bug probably isn’t in the hardware/firmware part but probably more in the firmware/software part (which changes with new Android versions).

The bad news is that this firmware is part of the “binary blob” stuff which in not open-sourced by the modem manufacturer. And given that the Fairphone 2 really is a kind of niche, there is no hope for that to change…


I recognized that I cant select anymore where to save my pictures in the stock camera app.
I have a working micro SD card but since a few weeks the pictures are saved in the internal storage.
I looked at the LOS update changelogs but couldn’t find something.
Does anybody know something about it?


I noticed the same.
But did you ever manage to save the photos to the SD card before? It had never worked for me, when selcting the SD card as storage path, the photos wouldn’t get saved. Maybe the option was removed because of this?

1 Like

While I never practiced this (saving photos directly to the SDXC) myself, I agree with Alex’ observation that it was always somewhat tricky to actually realize this. Recently I have actually come to advise people to a different behaviour: Let the camera app keep saving to the internal storage and move larger batches of photos to the SDXC manually (i.e. file manager) every now and then.

My assumption behind this is that it’s better to let the camera app work with the quickest, most instantly available and most reliable storage – the internal storage – so there’s no risk to have the camera app stalled from a backlog of photos. You can still make room later.

1 Like

Hi, it was dropped from lineage indeed.



Thanks for the confirmation!

Actually, it had become a bug with the LOS camera with the introduction of scoped storage as I see in the links given above.
Myself I use OpenCamera and have no problem with saving on the SD card.

But thanks for the advice, I may use it if I decide to switch back to the stock camera.

1 Like

Yes, i did.
On the SD card and then: Android/data/org.lineage.snap/files
But with Chris comment we have the answer :slight_smile:

1 Like

The mobile data issue doesn’t seem to be one on my phone currently but I found something else: On FPOS when the screen turned off automatically I could turn it on again by pressing the power button but without having to unlock the phone if all that happens within a few seconds. I found the setting in LOS, too. It’s under security->screen lock settings->lock after automatically turning off screen (or similar, my phone speaks German). The value that I set there is ignored, I have to also disable “On/Off locks phone immediately” to use this feature. Does that work for anyone else?


1 Like