Lineage 17.1 - FP2

Official Lineage 17.1 is out for the FP2.

This thread is to discuss stuff that does NOT work ONLY :slight_smile: !


If you have installed gapps, do not forget to flash new Android 10 gapps at the SAME time, otherwise you will BREAK your stuff (like on previous upgrades).


Note: There is also a lineage recovery available that can be used to flash lineage and gapps. It does not support data partition decryption (either).
Note: Do not upgrade from unofficial 17.1 builds. Do not upgrade from the 1st two builds of 17.1. Start with a “wipe/factory reset”. Upgrading from 16.0 is supposed to work.

Not yet implemented features in 17.1:

  • Charging sound (open - gerrit)
  • Lock screen modifications (open - gerrit)

What will not be implemented in 17.1:

  • Privacy Guard

What does not work:

Fixed in mean time:
FM Radio -> https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP2/+/272085


I came from the preview version, used the key migration script to switch to official, and then installed the ZIP via adb sideload incl. wipe of cache and dalvik cache.

Now, after unlocking the screen I get lots of warnings that several system apps are crashing repeatedly.
Will investigate further.

And for completeness sake: I have the new camera modules, connected to WiFi, one SIM inserted, no SD card.

Edit: forgot to update the GAPPs package, so no surprise there were problems. Will report after reinstalling with GAPPs
Edit2: same problems after wiping cache + system and then installing LOS 17.1 with GAPPs 10. Will probably try a factory reset later but not today

1 Like

Same here :astonished:
I can hardly do anything in the OS since Settings keeps stopping.
Just a glimpse at what is not working:

  • Cannot activate Wifi/Bluetooth/Network
  • SD Cards is not accessible
  • cannot unlock phone (more than once)

Apps and data are still there though :grin:

Any hint/help is appreciated.

How can I investigate, what’s going wrong?

Interestingly, when I switch back to unofficial keys, the Settings don’t crash anymore and the sim is recognized :raised_hands:
But connecting to Wifi and Cell network is still not working.

1 Like

Same here. a lot OS-Apps were crashing after first startup.
upgrade procedure: with new LOS-recovery from 16 to 17.1 (with ADB). With OpenGApps pico for Android 10.
Even after installing from scratch (with OpenGApps): same behavior.

3rd try: installing from scratch but without OpenGApps: same result. everything is crashing.

(BTW the OpenGApps.zip verification failed with LOS-recovery but I was able to install it anyway.)

This is what shows up, when I try to connect to Wifi. It hangs and then the UI crashes.


You should not try to go from the unofficial 17.1 previews to this version (even with changing keys).

Only official 16 to 17 is supported. I am sorry if I did not make this clear. The unofficial 17.1 versions were “random” snapshots.


1 Like

Any recommendation where to download Android Gapps 10? I don’t see them at https://wiki.lineageos.org/gapps.html

1 Like

https://opengapps.org/ ?

The Android 10.0 version doesn’t look too convincing, though, currently … “some known issues”, “only pico, nano and micro builds” … seems there’s some work to do still.


I’m a little unsure how to fix this situation now. Even a factory reset didn’t help.
I guess I’ll install the FPOS again for a fresh start.

Factory reset should help. I’ll test the official build now, too, myself, to see if there’s a problem with it.


OpenGapps - I would recommend pico for now. This was what I tried.


I installed it without problems but I can’t get any further than the unlock pattern

Crap - looks like this is 17.1 issue all across the board.



Remind me to buy you many beers at #37c3 (if there is still a congress). Just got your warning right in time. Good thing I fell asleep before and didn’t install it earlier :slight_smile:


Good that I wanted to check if it’s really working today. Now I will wait.

But thank you for your good work.


Please update the top post with your warning.
Kindest Regards

I don’t see where the first post would need any more warnings right now. It already states that the original file should not be downloaded and installed, and actually it is impossible right now to get the file because it was taken off the download page.

So what else would there be necessary? No damage can be done anymore.


It seems Lineage started building again! :slight_smile:
Our FP2 is in queue (~#27 at the time of writing), it should be out later today or tomorrow I guess… :slight_smile:

So thank you again @chrmhoffmann for your long-lasting hardwork! :heart_eyes:

EDIT: It’s building now!


Awesome! I love our FP2-developers! :slight_smile:


Now it is out! But I am not brave enough to test it (yet).