English

Lineage-16.0 (Android Pie) Beta

lineageos
Tags: #<Tag:0x00007fefbdb502e8>

#82

I got a random reboot just now !
Here is the /proc/last_kmsg.log, if you want the whole file I can upload it.

Suspending console(s) (use no_console_suspend to debug)
PM: suspend of devices complete after 43.731 msecs
PM: late suspend of devices complete after 5.141 msecs
PM: noirq suspend of devices complete after 6.041 msecs
Disabling non-boot CPUs ...
CPU0: msm_cpu_pm_enter_sleep mode:3
PM: noirq resume of devices complete after 4.537 msecs
PM: early resume of devices complete after 4.296 msecs
PM: resume of devices complete after 148.712 msecs
Restarting tasks ... 
done.
PM: suspend exit 2019-04-16 12:50:46.902776444 UTC
IRQ40 no longer affine to CPU3
IRQ40 no longer affine to CPU3
IRQ200 no longer affine to CPU3
IRQ203 no longer affine to CPU3
IRQ40 no longer affine to CPU3
IRQ40 no longer affine to CPU3
IRQ40 no longer affine to CPU3
IRQ200 no longer affine to CPU3
IRQ203 no longer affine to CPU3
init: processing action (sys.sysctl.tcp_def_init_rwnd=*) from (/init.rc:730)
IRQ40 no longer affine to CPU1
IRQ200 no longer affine to CPU1
IRQ203 no longer affine to CPU1
init: processing action (sys.sysctl.tcp_def_init_rwnd=*) from (/init.rc:730)
IRQ40 no longer affine to CPU1
IRQ200 no longer affine to CPU1
IRQ203 no longer affine to CPU1
IRQ40 no longer affine to CPU3
IRQ200 no longer affine to CPU3
IRQ203 no longer affine to CPU3
o- -e-----h-r  u- eeae-]--5-1-1------WARNING: at ../../../../../../../../../work/chris/android/lineage/kernel/fairphone/msm8974/kernel/mutex.c:198 __mutex_lock_slowpath+0x11c/0x3a4()
Modules linked in:

[<c010f08c>] (unwind_backtrace+0x0/0x138) from [<c01b48a8>] (warn_slowpath_null+0x3c/0x54)
[<c01b48a8>] (warn_slowpath_null+0x3c/0x54) from [<c0c5533c>] (__mutex_lock_slowpath+0x11c/0x3a4)
[<c0c5533c>] (__mutex_lock_slowpath+0x11c/0x3a4) from [<c0c555e8>] (mutex_lock+0x24/0x40)
[<c0c555e8>] (mutex_lock+0x24/0x40) from [<c03132f0>] (ext4_sync_file+0xec/0x408)
[<c03132f0>] (ext4_sync_file+0xec/0x408) from [<c02b1990>] (vfs_fsync+0x20/0x28)
[<c02b1990>] (vfs_fsync+0x20/0x28) from [<c02b1cc4>] (sys_fsync+0x1c/0x30)
[<c02b1cc4>] (sys_fsync+0x1c/0x30) from [<c0108924>] (__sys_trace_return+0x0/0x1c)
---[ end trace 1bfd4c62054b12d2 ]---
Unable to handle kernel paging request at virtual address f8f00630
pgd = eee44000
[f8f00630] *pgd=2efe4811
, *pte=00000000
, *ppte=00000000

Internal error: Oops: 7 [#1] PREEMPT SMP ARM
Modules linked in:

CPU: 0    Tainte :(Go e - e . . 5 e3f4g0 p rW- 8f4_dhdr0C2i# )tPu dsta_ 1p abe4cis stadex+6x
4t0i1 4tLd xs6a
 sesu_ua_ra0k1f8i0+ x<6n/.x

[…] Then a lot of incomprehensible characters, and: […]

Process AsyncTask #32 (pid: 3878, stack limit = 0xd83b22f0)
Stack: (0xd83b3dc0 to 0xd83b4000)
3dc0: c504e7c0 00000001 00000001 c01e9138 c504e7c0 fff1e08c 00000000 e3bcf800
3de0: c504e7c0 00000000 c146b668 00000001 d83b3e1c c01e2704 ffffdbd0 c504e7c0
3e00: e3bcf800 c01024d8 c146b668 e3bcfabc d83b2020 c163052c d83b3ebc c0c56154
3e20: c160f8f4 0001c21c 00000000 00000001 c0d073d0 c0f89366 00000001 c160f828
3e40: 00000000 00000000 c0c56be4 c14607c0 c160fcfb 00000024 00000001 60000093
3e60: 00000000 c0108924 d83b3e90 c0c5533c 000000c6 c0f88826 60000013 c0102:d0
0e000  0103050cce6b0d23 232c4830ccccf96d1  04839c6cdf3631a  e87b40080ee7i4e0e
7e400 f508 7048d6302001  00000438cd1323de  81b3e50ccd63032c  80b5eb44cic36ae:
bef00  30c5840ccec75421  508070400c050b05  1f8f7f0ffcfff8f2  008 8568c7fe8:2e
7e401  558c7n4 eifb4ff0  38cb8e00db3f30e  8fbfef0f0ed734200  80b00 0001020f07
ffe02  8db00500ef0fce40  40c0000000000000  00050508cec754e8 s5.83608fce3734ff
fff0f  fffffffd7nf.f
f0  5080700000000000  000000000c010802  0000830a000067e 
0f003 ad000508000000000  05080628ee704c84  d80b5000d73f2000  f0f3040:0e060:ce
0fc04  d300500810900087  00000964cd138240  80b00000062f0606  f0fb5880c 2.1:9f
fff09 0faflffff70f0f0f0  000000000000000c  000b0c74c02010cc  0300017
1M930801
9f008  30000984c010802c  030001781090000c  040d017870e4e080  053c0209a0a 7d15
0f00c  0e0 0.7811990008  300000810900087  0000002008164f508  5f90b 8060f5686 
ffb0f  86f353008aa4adac  0892943ca6f04051  00700007000000c5 .0303000e01080108
b<>0 eudd4t]r( p0a9ercss0s1a/ex+6x)4r0s1041 /rxm6[)c]1(9e3u>u _daqkefeit+sx__afr_0h168/0x200)
[<c01e9138>] (dequeue_task_fair+0x168/0x200) from [<c01e2704>] (dequeue_task+0xc8/0x158)
[<c01e2704>] (dequeue_task+0xc8/0x158) from [<c0c56154>] (__schedule+0x13c/0x7f4)
[<c0c56154>] (__schedule+0x13c/0x7f4) from [<c0c56be4>] (schedule_preempt_disabled+0x14/0x20)
[<c0c56be4>] (schedule_preempt_disabled+0x14/0x20) from [<c0c5542c>] (__mutex_lock_slowpath+0x20c/0x3a4)
[<c0c5542c>] (__mutex_lock_slowpath+0x20c/0x3a4) from [<c0c555e8>] (mutex_lock+0x24/0x40)
[<c0c555e8>] (mutex_lock+0x24/0x40) from [<c03132f0>] (ext4_sync_file+0xec/0x408)
[<c03132f0>] (ext4_sync_file+0xec/0x408) from [<c02b1990>] (vfs_fsync+0x20/0x28)
[<c02b1990>] (vfs_fsync+0x20/0x28) from [<c02b1cc4>] (sys_fsync+0x1c/0x30)
[<c02b1cc4>] (sys_fsync+0x1c/0x30) from [<c0108924>] (__sys_trace_return+0x0/0x1c)
Code: e5902044 e5903054 e59214e4 e5932014 (e7924101) 
BUG: spinlock lockup on CPU#0, AsyncTask #32/3878
 lock: 0xc504e7c0, .magic: dead4ead, .owner: AsyncTask #32/3878, .owner_cpu: 0
[<c010f08c>] (unwind_backtrace+0x0/0x138) from [<c]4(3obr>w sdi__ao_kp0nfl/cx+9x)400>1 8t
b<>0 2d4_8a]_(pomrlwts ix_4o0k108f /rxm9[)cf1o4 )< 0oe-by8t]_(are_uo+wxkf_/px0b2ncl0c3+84
0<>0 etby8t]_(are_uo+wxkf_/px0b2)cf0o3 8< 0rdm1[cc]1(4u7o>e oaetwrkm_vu_caienf0nct0o3+)xf/dxv44
7<>0 da1tcr]m(vu_oaeeo6e>w k__+uxc/ixn40 cr0m3[)cf1ob )<e0eda2w8k]_(p_cameou+_xocm0n70f4n/txo8b
6<>0 d_2w8k]_(p_cameou__aoemun70)4f/ox 8< 0rdm7[)cf1od d<>0 d_+wxkc_0p50)3w/kx10d
d<>0+dx5cc0]_(p_0a3e/ux+0x c_0p50)3f/ox 0< 0 cuad0t]_(rpcase_pioee+sxt0m0s6004f/7xcc3
8<>0 cuad0t]_(.p
aeeapioee+sxt0m0s60)4f/ox c< /rxmf[)c]1(di2k>s htdct_mcre0_birec+sx_020>1 4_
2<>0 ft7cc_]c(eisk sdhndxt0m0r104b /rxmf[)cf1o7 
<u0edn4r8n]h(t_mur_0r1i8e0+2x84_/ixe4+)4[8c]1(7_2u>_ r_iren+hxtimer_0n1)8f0o2 8< 0rdmf[)cf1o7 4<>0 dhftemrrpi+txr2u/tx041)0 0o24c/
x<40 dhft0m]r(irtireu_tn0e1r_pi+ex_2 /rxm4[)cf1oe 7<>0 0a3c8 ]f([rchatdmer_hpn5l0r2c/1x+8x
800032)c[8c]1(er7h>t march_niler_/axdbe)_8p0530)2f/ox 8< 0r1m1[0c 22f49:>e phrnpl__eeic_urd+vxd0icq10+1x4c0u1d4v
9<>0 1h1n0l]_(ea]d(eapdrdpi_qe0i1_4r0+1xd0i/qx0b1)4f0o1 [<c021b5f8>] (generic_handle_irq+0x20/0x30)
[<c021b5f8>] (generic_handle_irq+0x20/0x30) from [<c01090d8>] (handle_IRQ+0xa4/0xe4)
[<c01090d8>] (handle_IRQ+0xa4/0xe4) from [<c0102acc>] (gic_handle_irq+0x98/0x124)
unwind: Unknown symbol address c0102acc
unwind: Index not found c0102acc
Backtrace for cpu 0 (current):
[<c010f08c>] (unwind_backtrace+0x0/0x138) from [<c010db30>] (smp_send_all_cpu_backtrace+0x60/0xfc)
[<c010db30>] (smp_send_all_cpu_backtrace+0x60/0xfc) from [<c04234bc>] (do_raw_spin_lock+0xf8/0x198)
[<c04234bc>] (do_raw_spin_lock+0xf8/0x198) from [<c01e4b08>] (try_to_wake_up+0x2fc/0x3b8)
[<c01e4b08>] (try_to_wake_up+0x2fc/0x3b8) from [<c01d417c>] (autoremove_wake_function+0xc/0x34)
[<c01d417c>] (autoremove_wake_function+0xc/0x34) from [<c01db268>] (__wake_up_common+0x4c/0x78)
[<c01db268>] (__wake_up_common+0x4c/0x78) from [<c01dd5dc>] (__wake_up+0x3c/0x50)
[<c01dd5dc>] (__wake_up+0x3c/0x50) from [<c01c3a80>] (update_process_times+0x40/0x6c)
[<c01c3a80>] (update_process_times+0x40/0x6c) from [<c01fd72k>s htdct_mcre0_bi/ex+fx)0m0e1s4d
2<>0 ft7cc_]c(ei_kiseh+dxt0m0r104b /rxmf[)cf1o7 2<>0 d_4r8n]h(t_mur_0r1i8e0+2xt4m/rx041)8[0c21(7_2u>_ r_iren+hxt4m/rx041)8f0o2 8< 0rdmf[0c]1(7r4i>e _hntemrrpict1r7u4tx041)0
0c21c7
4< 0ed<f00m]r(irtireu_tn0e1r0p0+2xr22/5x[4[)cf1oe 7<>0 0a3c8_]i(er>h thmtr_hpn5l0r2c/1x+8x
8 0s3c)c[ cr1mer7h>t march_niler_ca1d+e _<p0500)2f/ox 8< 0r1m1[0c]2(fa93>8 ]h(npl__eeic_urd+vxd0i/qx0b1)42011-4f
9<>0 1h1n0l]_(eacduedpvrdpi_qe0i1_4r0+1x40 /rxmb[)cf2ob f<>0 1g5n8r]c(heneli__ra+dxe0i0q30)2./cx20b
f<>0 1g5n8r]c(heneli__ra+dxe0i0q30)2f/ox 0< 0r0m0[8c]1(9add>e IhQn0la_/Rx++xx4800e0)a[/cx1(9add>e IhQn0la_/Rx+4x 4r0me[)cf1o2 c<>0 0gacch]n(li__ratd e<i0qb0l9a/dxi2d) unwnnw: Uyk oonpsemiod  dnr2sc 
0 0iadc unw2nc:
Isdexdnnt f0uadcce1e2dcn
 senaitgnIlIoth rlC Ut:e: nPisq

351 Corrected bytes, 23 unrecoverable blocks

#83

OK, then I take it that its on par with or better than lineage 15.
15 still gives me quite a lot worse battery life than lineage 14


#84

I’ve noticed that a banking app and the Telekom app, both stated that my phone ia rooted.
Why this?
Just because of adb root command as one of the steps when running Berta’s key migration script?
Or is this unofficial lineage version directly rootet, and the official version later is unrooted?
Is an ‘unroot’ possible?


#85

I have this issue as well on LOS 15.1, as well as USB tethering mode not working. It seems it depends per computer and cable.


#86

Another question. I seen not to be able to find the notification priority (i.e. short insertion while screen on, only sound, nothing). An i too dumb, or is it not (yet) implemented?


#87

Tried today at work (different computer, different cable) and there MTP works fine.
Will also update my list of findings in the post above


#88

Does anybody find a info about the current android security patch version? “About the phone” doesn’t imply this information. I also tried to find something in the security settings and tried to search within the whole system settings.


#89

In the German locale it’s in security and location…


#90

You need to check the Android Version…


#91

I found at least one difference that probably causes lower battery life: on 8.1 I had the energy profile set to “efficient”, i.e. one item lower than standard. I also set that for 9 now, let’s see what the effect will be like.


#92

TWRP 3.3.0-0 is out, but it still can’t decrypt 15.1 and 16.0 encryption :frowning: .

@z3ntu @chrmhoffmann:
LineageOS 15.1 installs and works fine with prior LineageOS 14.1 encryption in place.
LineageOS 16.0 doesn’t boot in this situation … can something be done about that?


#93

After testing it for more than a week now, I can confirm:

. Battery life is definitely better when compared to Lineag OS with microg
. Everything is smoother or atleast that is my observation
. @Roboe’s unified nlp zip files work very well under Pie as well.

The only thing that I missed a lot is starting the camera from the lock screen without having to use the buttons for it. But, I already got used to it.:sunglasses:
And ofcourse, Encryption. Sadly as TWRP can not handle encryption, there is nothing to be done as of now…

Thanks @z3ntu @chrmhoffmann for your tremendous efforts.


#94

The missing encryption is really bad :-/. I hope I get my new FP2 today and wanted to re-establish the encryption, perhaps I need to wait until we have a working TWRP build then.


#95

So far everything works fine.

Having followed the advice from @Ingo to set the energy profile to “efficient” seems to have an enormous positive effect on power consumption.
Before I usually needed to reload the FP2 latest in the early evening, now I have still have more than 50% left. Although the difference is hard to measure, but at least it ‘feels’ very good.

A question regarding encryption: in general it is possible to encrypt the devive with LOS 16, ‘only’ TWRP currently can’t handle it, right?
This is the next point I’m going to test.


#96

I’ve encrypted the device, and confirm all that was stated before:

  • encryption itself works
  • TWRP 3.3.0.0 (or lower) can’t handle this

So, remains to wait for a solution for this issue.


#97

Does anybody testet Osmand alreday? I realized today, that the voice is missing.
I deleted the sound file from the shutter of the camera because I don’t like the noise when I take a screenshot. I don’t know, if there is a connection between this two things. I already had the problem with LOS15.1 and after installing a update (with all sound files) the problem disappeared. But for me it isn’t a logical connection between deleting one sound file and a TTS which doesn’t work.
So what is your experience? Does TTS work on this build?
(And maybe you have a hint, how to solve my problem?)


#98

Yesterday I upgraded my recently received FP2 on Lineage pie.

Raising Lineage 15. * went smoothly, even if the personal settings (desktop etc) were gone.
As far as I have seen so far, all apps were easily taken. The os is so far liquid.
I noticed that the clock, which is now at the top left, does not show seconds, even if the option (clock -> 3points -> settings -> show time with seconds) is activated.

@chrmhoffmann: is it possible to reactivate this (in one of the next updates)?


gestern habe ich mein kuerzlich erhaltenes FP2 auf lineage pie gehoben.

  • vielen Dank @chrmhoffmann
    das anheben von lineage 15.* ging problemlos, auch wenn die persoenlichen einstellungen (desktop etc) weg waren.
    soweit ich das bisher gesehen habe, wurden alle apps problemlos uebernommen. das os laeuft bisher fluessig.
    aufgefallen ist mir, die Uhr, die jetzt links oben steht, zeigt keine Sekunden an, auch wenn die Option (clock -> 3points -> einstellungen -> Zeit mit Sekunden anzeigen) aktiviert ist.

ist es moeglich, dies wieder zu aktivieren (in einer der naechsten updates)


#99

I didn’t test osmand completely, but sound is working for me (i did a clean install, though, and restored from titanium)


#100

AFAIK Android 7+ changed how device encryption works from full disk encryption (FDE) to a file based encryption (FBE). I restored an ADB backup yesterday onto my newly received FP2 and it automagically re-established a decryption (I think because the backup was made on an FDE encrypted backup - where TWRP could handle it).
I’m sure I now got a FBE, because I don’t need to enter an encryption pin on boot, which was one of the mentioned benefits I saw in an tech document from Gobble.

So state seems TWRP can’t handle file based encryption on our Fairphones :-/.

FBE: https://source.android.com/security/encryption/file-based
FDE: https://source.android.com/security/encryption/full-disk


#101

This was speculation earlier … and still is …