Lineage-16.0 (Android Pie) Beta

Tried today at work (different computer, different cable) and there MTP works fine.
Will also update my list of findings in the post above


Does anybody find a info about the current android security patch version? “About the phone” doesn’t imply this information. I also tried to find something in the security settings and tried to search within the whole system settings.

In the German locale it’s in security and location…

You need to check the Android Version…

1 Like

I found at least one difference that probably causes lower battery life: on 8.1 I had the energy profile set to “efficient”, i.e. one item lower than standard. I also set that for 9 now, let’s see what the effect will be like.

1 Like

TWRP 3.3.0-0 is out, but it still can’t decrypt 15.1 and 16.0 encryption :frowning: .

@z3ntu @chrmhoffmann:
LineageOS 15.1 installs and works fine with prior LineageOS 14.1 encryption in place.
LineageOS 16.0 doesn’t boot in this situation … can something be done about that?


After testing it for more than a week now, I can confirm:

. Battery life is definitely better when compared to Lineag OS with microg
. Everything is smoother or atleast that is my observation
. @Roboe’s unified nlp zip files work very well under Pie as well.

The only thing that I missed a lot is starting the camera from the lock screen without having to use the buttons for it. But, I already got used to it.:sunglasses:
And ofcourse, Encryption. Sadly as TWRP can not handle encryption, there is nothing to be done as of now…

Thanks @z3ntu @chrmhoffmann for your tremendous efforts.


The missing encryption is really bad :-/. I hope I get my new FP2 today and wanted to re-establish the encryption, perhaps I need to wait until we have a working TWRP build then.

So far everything works fine.

Having followed the advice from @Ingo to set the energy profile to “efficient” seems to have an enormous positive effect on power consumption.
Before I usually needed to reload the FP2 latest in the early evening, now I have still have more than 50% left. Although the difference is hard to measure, but at least it ‘feels’ very good.

A question regarding encryption: in general it is possible to encrypt the devive with LOS 16, ‘only’ TWRP currently can’t handle it, right?
This is the next point I’m going to test.


I’ve encrypted the device, and confirm all that was stated before:

  • encryption itself works
  • TWRP (or lower) can’t handle this

So, remains to wait for a solution for this issue.

Does anybody testet Osmand alreday? I realized today, that the voice is missing.
I deleted the sound file from the shutter of the camera because I don’t like the noise when I take a screenshot. I don’t know, if there is a connection between this two things. I already had the problem with LOS15.1 and after installing a update (with all sound files) the problem disappeared. But for me it isn’t a logical connection between deleting one sound file and a TTS which doesn’t work.
So what is your experience? Does TTS work on this build?
(And maybe you have a hint, how to solve my problem?)

Yesterday I upgraded my recently received FP2 on Lineage pie.

Raising Lineage 15. * went smoothly, even if the personal settings (desktop etc) were gone.
As far as I have seen so far, all apps were easily taken. The os is so far liquid.
I noticed that the clock, which is now at the top left, does not show seconds, even if the option (clock -> 3points -> settings -> show time with seconds) is activated.

@chrmhoffmann: is it possible to reactivate this (in one of the next updates)?

gestern habe ich mein kuerzlich erhaltenes FP2 auf lineage pie gehoben.

  • vielen Dank @chrmhoffmann
    das anheben von lineage 15.* ging problemlos, auch wenn die persoenlichen einstellungen (desktop etc) weg waren.
    soweit ich das bisher gesehen habe, wurden alle apps problemlos uebernommen. das os laeuft bisher fluessig.
    aufgefallen ist mir, die Uhr, die jetzt links oben steht, zeigt keine Sekunden an, auch wenn die Option (clock -> 3points -> einstellungen -> Zeit mit Sekunden anzeigen) aktiviert ist.

ist es moeglich, dies wieder zu aktivieren (in einer der naechsten updates)

I didn’t test osmand completely, but sound is working for me (i did a clean install, though, and restored from titanium)

1 Like

AFAIK Android 7+ changed how device encryption works from full disk encryption (FDE) to a file based encryption (FBE). I restored an ADB backup yesterday onto my newly received FP2 and it automagically re-established a decryption (I think because the backup was made on an FDE encrypted backup - where TWRP could handle it).
I’m sure I now got a FBE, because I don’t need to enter an encryption pin on boot, which was one of the mentioned benefits I saw in an tech document from Gobble.

So state seems TWRP can’t handle file based encryption on our Fairphones :-/.


1 Like

This was speculation earlier … and still is …


I wanted to install LOS 16 today. I booted to TWRP, did advanced wipe (with everything except SD-card TWICE), but the internal storage was still there will all the apps. I then still flashed LOS16 and su-addon and it rebooted. everything was there as before - only LOS. So this seemed to work, BUT, my old LOS15 problem was there, that Google Maps no longer works. :frowning: For some reason the app always dumps upon opening. So back to FPOOS it is. Sadly.

I don’t think maps works without Gapps


I would expect Google Maps to require basic Google services, e.g. Open GApps pico … did you install them?
Be aware that you would need to install ARM - 9.0 now.

1 Like

Yesterday I faced something similar.
I wanted to start from the beginning, flashing FPOS Android 6.
After wiping all (system, cache, data, internal storage, dalvik), and having flashed the FPOS package, after reboot it directly started, without going through the inital set-up steps (e.g. configuring WLAN, etc).
In another, next try I’ve formatted also data partition, besides wiping all the rest.
Only then the device behaved after like after factory reset, meaning with the first start all was gone, and I was led through the initial configuration procedure.

To GoogleMaps: nope. It runs without problems on FP Open OS (no google installed from my side).
I installed the new arm - (the one with 16.0 in the name).

1 Like