Lineage-16.0 (Android Pie) Beta

So I also installed Pie :wink: It was a clean install, as I was encrypted before, did look good, but it would not let me in. Wiped everything, installed ROM, Magisk and OpenGapps nano (want to experiment with Magisk also). Restored from TiBu Backup, the rest from my computer.


  • as already mentioned, auto brightness does not work
  • it looks like charging does not work when switched off
  • I have the impression, graphics performance suffers a bit
  • a few apps did not work after restoring (signal e.g.), I had to reinstall those from scratch
  • WLAN is slow to reconnect

I had one spontaneous reboot, unfortunately, last_kmsg ist corrupt, but here is it anyway:

Process swapper/0 (pid: 0, stack limit = 0xc14622f0)
Stack: (0xc1463ef0 to 0xc1464000)
3ee0:                                     00000000 c5048440 976eb726 0000005e
3f00: ffffffff 00ffffff c145f6e8 c504bc40 00000020 c504bc40 001697bb 1eaaab40
3f20: 00000051 001dc31e c504b200 c01fdbdc ffffffff 00000000 00000001 c1464140
3f40: 38a02780 00000dbd c1633568 c1464140 38d68da0 00000dbd 00000000 00000006
3f60: c1462000 c145dc40 c158b208 c0f58d1e 00000000 c158b140 c5048440 c158b19c
3f80: 00000000 c01fdce4 c1462000 c01096e0 c1631d74 c1463fa4 00000001 c0c0cb1c
3fa0: 00000027 00000001 c146b44c c158b1c4 00000000 c1300b00 00000000 00000000
3fc0: c1300538 00000000 00000000 c14004fc c1400efc 2719ed1c 10c43879 c1 6a50c
30e0:0c1431301 c1073804 0500406a 012f06f1500000003 0000800c 00000300 000000000[<c]1c3e50>e (gtt_nrxt_timeu_in0err/pt+7x98f0x2 4) 0romb[<ce1fdPdc>n (t_ck_pohzhstot_sc.ed_aick0isrb.5+]x36
/0x e4)b[<c]1fd0dc>8 (t_ck_pohzhstot_sc.ed_aickaisrr.5+3x36 /0xme4)cfrod [<>01ftce4_] (zicklnohn_id+e_ecter80x6s/0x04)
e<c0 fdcc4>]o(tiik_n_hz_edlexent0r+0)6c/ox84< fr0m [0c01(96e_>] ecpu2idlx+0x14/00fc)6[<cx109
e0>d (c0u_i/le+cx24r0xf[) faom [<c0 0cbsc>]n(re0t_i it+sx9cn0xb0)
[cc0c(cb1t>] iresx_in0t+0)9c/oxb8< fr0m [0c13(0b0r>] estalt_k3rne0+0x854/0x3b
C5de:3e083c181 e51c000c e050000c  a00900do(e5 0e0dc) eBUGr sp_nlosk lrcku  ongCPU 0,  wapter/ /0
oloct: baot_avecxbasxs+000/0m104c, .eagi_: d:ad4nad, .owper:/swanper 0/0p .o/nerkcpuc 0
8<c0 0f0wc>]_(undindcbacxtraxe+0)0/0o138< fr2m [8c04(34br>] sdo__aw_kpinflocx+0x)4/0w1983
[<>042d4b8a] (po_rlw_s+in_4ock10xf /0xm98)cfro2 [<>01cr9f8t] (run_fimeq_so6tirr+0xf8/0q39c6
[<t01cr9f8f] (qun_6imex_so>tirr+0x<8/0b39c0 fr(m [oc01dbe5)>] o__dl_soatirg+0x 48/5x27i)
[Lc01rbe50>] (__do_softirq+0x148/0x270) from [<c01bc3a4>] (irq_exit+0x48/0x94)
[<c01bc3a4>] (irq_exit+0x48/0x94) from [<c01090e0>] (handle_IRQ+0xac/0xe4)
[<c01090e0>] (handle_IRQ+0xac/0xe4) from [<c0102acc>] (gic_handle_irq+0x98/0x124)
unwind: Unknown symbol address c0102acc
unwind: Index not found c0102acc
Backtrace for cpu 0 (current):
[<c010f08c>] (unwind_backtrace+0x0/0x138) from [<c010db30>] (smp_send_all_cpu_backtrace+0x60/0xfc)
[<c010db30>] (smp_send_all_cpu_backtrace+0x60/0xfc) from [<c04234bc>] (do_raw_spin_lock+0xf8/0x198)
[<c04234bc>] (do_raw_spin_lock+0xf8/0x198) from [<c01c29f8>] (run_timer_softirq+0x68/0x39c)
[<c01c29f8>] (run_timer_softirq+0x68/0x39c) from [<c01bbe50>] (__do_softirq+0x148/0x270)
[<c01bbe50>] (__do_softirq+0x148/0x270) from [<c01bc3a4>] (irq_exit+0x48/0x94)
[<c01bc3a4>] (irq_exit+0x48/0x94) from [<c01090e0>] (handle_IRQ+0xac/0xe4)
[<c01090e0>] (handle_IRQ+0xac/0xe4) from [<c0102acc>] (gic_handle_irq+0x98/0x124)
unwind: Unknown symbol address c0102acc
unwind: Index not found c0102acc
1 Like

Finally managed to ‘remove’ encryption:

  • backup done with TWRP
  • formatted data
  • restored the backup
  • deleted /data/misc/vold/convert_fde (to prevent that after system reboot the device is re-encryted on boot
  • ran Berta’s migration script
  • installed lineage 16 and gapps nano

Will start to to check now the phone and all apps.

First points I noticed:

  • Trust has given a warning ‘This build was signed with public keys’, where I don’t no if this is really an issue or not.
  • The app ‘notification manager’ works now again without crashing. With lineage 14 it worked, with lineage 15 it always crashed, now with lineage 16 it works again
  • One banking app does not recognize the PIN at startup time

More feedback will follow.


First impression, among those stated above, it’s fast, and very battery efficient

1 Like

I had this too.
And it appears everytime i reboot or turn on the phone.

Thats my impression too. Especially at the navigation bar.

Does anybody can confirm this? Or is it a individual problem of my setup?

I can confirm this, picture is not in the default directory under DCIM.

Another bug. Some apps did not have network allowance in app settings. After switching network usage on for those it had no effect, only after reboot

1 Like

My first feeling is the exact opposite. Some actions lag and battery life is not as good as with 8.1
Need to analyse more. My feeling is that the difference could be using Blokada (tracking filter via VPN) uses more battery than AdAway (tracking filter via hosts file). But I wanted to try Blokada because AdAway was the last reason for rooting my phone.

Regarding TWRP-compatible encryption, I just tried the following …

  • Installed LineageOS 14.1
  • Set screen lock to “None”
  • Encrypted the phone
  • Wiped the phone in TWRP
  • Installed 16.0

When booting 16.0, I was then surprised when I got asked for a decryption password, when none was set.

For the record:

  • The required password in this case indeed seems to be “none” :slight_smile: .
  • Decryption stays unsuccessful this way :frowning: .

Other passwords are being declared as “Wrong password”, while “none” results in the “Decryption unsuccessful” screen.

Does anyone know whether this is a Pie-feature, or the ROM’s: I’m not sure i can set the notification volume, but i have call volume (what’s this?) and ring volume. Before, i could set volumes independently

New build uploaded (see 1st post). Fixed: auto-brightness, off-mode charger and notification led settings.



Thank you Chris! Is there a Github repo, where we can track these latest changes :)?

I think, this is it what you are looking for…


I’m constantly losing that link ^^… thanks!

I noticed something strange with my phone webbrowser: when I start a (big) download, there is a notification from Download manager, but when I switch to another app this notification disappear, and it seems like the download doesn’t progress until I switch back to the webbrowser and the Download manager is displayed again…

Is there no way anymore to manually set the accuracy of the location? In Android 8 there was “high”, “power saving”, “device only”.
Didn’t see it in Android 9. Just “on” or “off”.
How do I know if GPS is used or not?


It’s not exactly like Android 8, but in Parameters > Network and Internet > Wi-Fi > parameters of search I found those two options (sorry it’s in French):

Basically it says it’ll use Wi-Fi/Bluetooth for localisation even if it’s not activated…

Those are now in “Security & Location > Location > Extended > Search” for me (my UI is in German so those are probably not 100% the English terms).
Seems like there is now way to enable/disable GPS specifically…

1 Like

Hi everybody,

I was using the Lineage OS with microg version until now. I formated data to remove encryption, wiped cache and system and then installed the Lineage OS 16.0 with Unified NLP Zip from @Roboe. I managed to install the back up of many apps through Titanium Backup. Some of the apps did not work (for eg: Signal). So i uninstalled the apps which did not work and installed them new without feeding them with data.

So far, everything works. Looks smooth.
I can not confirm Oli.Sax’S problem with the download manager. For me, It works fine.

I will continue to test it the next couple of days and report back here.


Re LEDs: one app (wire chat) which had no explicit led setting in the app, now does not use led notification at all. Before, my app specific setting was applied…

Hi all,

I tried today to copy a file with a file manager from internal storage to the sd card, that is configured as ‘mobil’ and not ‘internal’.
When selcting the destination folder on sd card, I’m asked ‘please chose first the sd card’, and when clicking on ‘select’, a message appears ‘authorisation failed’.

Has someone else faced this, and solved it?

Today my first day with it in real life. I left my flat at 06:15 in the morning. I did everything I usually do with the phone, writing some texts, listening to music, surfing the web, doing calls. So far everything works like it should. Back at home at 20:30, still have 25% battery left. Ok, I don’t have so much screen on time, but during work I listened around 5 hours to Spotify.

For me it seems that also the standby time is quite good. So far, I am quite impressed. :grin:

Edit: this morning in the train I tested my wireless headphones, they also work.