Last manual install A.0084 broke my fairphone

i have the same issue… flashed the newest image and now i am stuck at the black “fairphone” boot screen. system.img gives me the same invalid sparse error as mentioned above… sadly i flashed it before finding this thread :frowning:

i am on a fp3+

Try flashing the previous version and then do an OTA update.

1 Like

yes i will try this. i am using this link to download the 0077 release: ✏ FP3 OS updates - changelog & OTA links

update: it worked as described below.

1 Like

Hi again thanks for taking the issue into account :relaxed:
So my phone was (badly) rooted making it impossible to OTA update like @lothar_muc
My initial objective was to manually flash the update without wiping my user data.
After bricking the phone with the provided update, I’ve just wiped my phone and reinstalled the last working update and performed OTA unrooted then root again :slight_smile:
I hope future OTA will be released quicker and without bugs :wink:

Also it will be nice to have a list of every OTA updates with downloads somewhere close to the manual installation tutorial :slight_smile:

That correct, I should have mentioned that my phone was rooted with modification on /system so I was out of luck for OTA :stuck_out_tongue:
Reinstalling the previous version and performing the OTA allowed me to bump my phone to A.0084


The manual install page now links to a new archive which contains a better system.img:
It is 2.7GB large and simg2img produces a raw image without any errors. The resulting image can be fsck’d and mounted (loop device under linux) successfully.

To summarize: The new image should be good, at least as far as I can tell without really installing it (I currently have lineageos running).


Hi everyone,

The new package was updated this morning around 10:30am as noted above. Thanks again for flagging this right away and apologies for the inconvenience.


Thanks! No Problem. QC ist hard with a small team…

1 Like

In this case, it shouldn’t be hard even with a small team, after all users (each a team of 1 person) simply using the file as intended found out it’s bad without too much trouble.

But we’re all just human.
Hopefully the process gets improved, so that the same thing can’t happen again.

1 Like

I can not unlock the Fairphone 3, in Fastboot Mode, fastboot oem unlock:
no way for install new !!!

Not sure if this still works, but one year ago it did


Thanks to all of your fast responses my issue is solved.

The linked Unlock steps worked like a charm, managed to flash the new A.0084 (ending with _r2), bootup and everything.
Couple of notes:

  • This time the installer did not lock the bootloader itself, not sure if this is intentional or not.
  • During setup WiFi connected, but stated there was no internet. After skipping some of the setup steps connected again manually from the settings menu and I have internet access (same network).

All this tipps function not, unlock and Reset, is all incomptent nonsens, see here my new Video: Fairphone 3 after flashing Firmware A 0084 no unlock Bootloader - YouTube

Who said to run a fastboot command with the phone awaiting a package to install via ADB Sideload? This doesn’t work to the surprise of no one.

The alternative unlocking procedure seems to have worked for @ValentinBG,
perhaps you should try it.

Else … since Fairphone released a defunct install file causing this issue, you could contact Fairphone support to get your issue fixed.

1 Like

I have not see the Thred for Valetin, i wil test it.

1 Like

With this i have unfuck the Fairphone, is an very grat theater. I have make the Android 9 120 installation, i will never install the Android 10, Fairphone must finisch programm this buggy bullshit.
The Android 9 120 i can reflash the same, without unlock, for repair the Software, all later Versions are locked ??? The Android 9 120 function very good. For the future is betther install from SD Card, no Driver problehm, android support this !!!

Your first post on 20th seems to say you had a problem manually installing A10 0084. Did your network not provide an automatic update maybe because it wasn’t ready.

The you go on to say you couldn’t get past that and do a reinstall of an earlier version under apparently you apparently succeeded and install A9 but as you haven’t tried A10, only failed to install it, maybe inappropriately, how can you say it’s buggy when you haven’t tried it.

And do you mean “I have unlock the Fairphone”


I have tested the Adroid 10, is not good. I make only Manual installation, after installing the A10 0084 the Fairphone hangs on the bootlogo. I have no Internet on the Phone, no WLAN, i wil not this. The cost per Megabyte on the Phone is to high, i make wit an Widows 7 inernet Computer. The best Versions of Software is the latest from 9, an new Version, is normaly buggy, im not a betatester, i wil use the Phone without probleme.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.